summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2009-09-21 15:21:28 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2009-09-21 15:21:28 +0000
commit6df1ff75eab8dc108bb1adadacb89719373e6263 (patch)
treed3cf99db686ac93f0fe9ca59580b38be5eb2ef81 /kde-misc
parentVersion bump, supports new macros : http://releases.xfce.org/feeds/project/xf... (diff)
downloadgentoo-2-6df1ff75eab8dc108bb1adadacb89719373e6263.tar.gz
gentoo-2-6df1ff75eab8dc108bb1adadacb89719373e6263.tar.bz2
gentoo-2-6df1ff75eab8dc108bb1adadacb89719373e6263.zip
Version bump. Remove old.
(Portage version: 2.2_rc41/cvs/Linux x86_64)
Diffstat (limited to 'kde-misc')
-rw-r--r--kde-misc/tellico/ChangeLog8
-rw-r--r--kde-misc/tellico/metadata.xml14
-rw-r--r--kde-misc/tellico/tellico-2.0.ebuild55
-rw-r--r--kde-misc/tellico/tellico-2.0_pre2.ebuild30
4 files changed, 71 insertions, 36 deletions
diff --git a/kde-misc/tellico/ChangeLog b/kde-misc/tellico/ChangeLog
index 11c75dc524f4..33b98d994737 100644
--- a/kde-misc/tellico/ChangeLog
+++ b/kde-misc/tellico/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-misc/tellico
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-misc/tellico/ChangeLog,v 1.82 2009/09/10 13:43:22 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/tellico/ChangeLog,v 1.83 2009/09/21 15:21:28 scarabeus Exp $
+
+*tellico-2.0 (21 Sep 2009)
+
+ 21 Sep 2009; Tomáš Chvátal <scarabeus@gentoo.org>
+ -tellico-2.0_pre2.ebuild, +tellico-2.0.ebuild, metadata.xml:
+ Version bump. Remove old.
*tellico-2.0_pre2 (10 Sep 2009)
diff --git a/kde-misc/tellico/metadata.xml b/kde-misc/tellico/metadata.xml
index daca0b7f8a47..2d847952de5c 100644
--- a/kde-misc/tellico/metadata.xml
+++ b/kde-misc/tellico/metadata.xml
@@ -2,9 +2,13 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>kde</herd>
-<longdescription lang="en">
-Tellico is a KDE application for organizing your collections. It provides
-default templates for books, bibliographies, videos, music, video games, coins,
-stamps, trading cards, comic books, and wines.
-</longdescription>
+ <longdescription lang="en">
+ Tellico is a KDE application for organizing your collections. It provides
+ default templates for books, bibliographies, videos, music, video games, coins,
+ stamps, trading cards, comic books, and wines.
+ </longdescription>
+<use>
+ <flag name="addressbook">Add support for kdepim addressbook (kabc)</flag>
+ <flag name="xmp">Adds support for PDF/XMP metadata using <pkg>media-libs/exempi</pkg></flag>
+</use>
</pkgmetadata>
diff --git a/kde-misc/tellico/tellico-2.0.ebuild b/kde-misc/tellico/tellico-2.0.ebuild
new file mode 100644
index 000000000000..1b7979200b71
--- /dev/null
+++ b/kde-misc/tellico/tellico-2.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/tellico/tellico-2.0.ebuild,v 1.1 2009/09/21 15:21:28 scarabeus Exp $
+
+EAPI="2"
+
+KDE_LINGUAS="bg ca cs da de el en_GB es et fi fr ga gl hu it lt ms nb nds nl nn
+pl pt pt_BR ro ru sk sv tr uk zh_CN zh_TW"
+
+KDE_DOC_DIRS="doc doc-translations/%lingua_${PN}"
+
+inherit kde4-base
+
+MY_P="${P/_}"
+
+DESCRIPTION="A collection manager for the KDE environment."
+HOMEPAGE="http://www.periapsis.org/tellico/"
+SRC_URI="http://tellico-project.org/files/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+SLOT="4"
+IUSE="addressbook cddb debug +handbook pdf scanner taglib xmp yaz"
+
+DEPEND="
+ dev-libs/libxml2
+ dev-libs/libxslt
+ x11-libs/qt-dbus:4
+ addressbook? ( >=kde-base/kdepimlibs-${KDE_MINIMAL} )
+ cddb? ( >=kde-base/libkcddb-${KDE_MINIMAL} )
+ pdf? ( virtual/poppler-qt4 )
+ scanner? ( >=kde-base/libksane-${KDE_MINIMAL} )
+ taglib? ( >=media-libs/taglib-1.5 )
+ xmp? ( >=media-libs/exempi-2 )
+ yaz? ( >=dev-libs/yaz-2 )
+"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ # Kcal marked as failing to build in CMakeLists.txt by upstream
+ local mycmakeargs="${mycmakeargs}
+ -DWITH_Kcal=OFF
+ $(cmake-utils_use_with addressbook Kabc)
+ $(cmake-utils_use_with cddb Kcddb)
+ $(cmake-utils_use_with pdf PopplerQt4)
+ $(cmake-utils_use_with scanner KSane)
+ $(cmake-utils_use_with taglib)
+ $(cmake-utils_use_with xmp Exempi)
+ $(cmake-utils_use_with yaz)
+ "
+
+ kde4-base_src_configure
+}
diff --git a/kde-misc/tellico/tellico-2.0_pre2.ebuild b/kde-misc/tellico/tellico-2.0_pre2.ebuild
deleted file mode 100644
index c4ba2a75334c..000000000000
--- a/kde-misc/tellico/tellico-2.0_pre2.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-misc/tellico/tellico-2.0_pre2.ebuild,v 1.1 2009/09/10 13:43:22 ssuominen Exp $
-
-EAPI=2
-inherit kde4-base
-
-DESCRIPTION="A collection manager for the KDE environment."
-HOMEPAGE="http://www.periapsis.org/tellico/"
-SRC_URI="http://tellico-project.org/files/${P/_}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="4"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
-
-RDEPEND=">=kde-base/libkcddb-4.2
- >=kde-base/libksane-4.2
- >=kde-base/kdepimlibs-4.2
- >=media-libs/exempi-2
- dev-libs/libxslt
- dev-libs/libxml2
- >=media-libs/taglib-1.5
- >=dev-libs/yaz-2
- virtual/poppler-qt4
- x11-libs/qt-dbus:4
- kde-base/qimageblitz"
-DEPEND="${RDEPEND}"
-
-S=${WORKDIR}/${P/_}