summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Ostorga <vostorga@gentoo.org>2010-01-22 20:22:39 +0000
committerVictor Ostorga <vostorga@gentoo.org>2010-01-22 20:22:39 +0000
commitada7c2c74f7aab18fcf2917aadacd3e96ddd4306 (patch)
tree0c9450b781d42522774e5de21230b2c69c231d98 /lxde-base/lxde-common
parentNew package lxde-icon-theme , which was splitted from lxde-common and contain... (diff)
downloadgentoo-2-ada7c2c74f7aab18fcf2917aadacd3e96ddd4306.tar.gz
gentoo-2-ada7c2c74f7aab18fcf2917aadacd3e96ddd4306.tar.bz2
gentoo-2-ada7c2c74f7aab18fcf2917aadacd3e96ddd4306.zip
Version bump to 0.5.0
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'lxde-base/lxde-common')
-rw-r--r--lxde-base/lxde-common/ChangeLog10
-rw-r--r--lxde-base/lxde-common/files/lxde-common-0.5.0-session-fix.patch11
-rw-r--r--lxde-base/lxde-common/lxde-common-0.5.0.ebuild40
3 files changed, 59 insertions, 2 deletions
diff --git a/lxde-base/lxde-common/ChangeLog b/lxde-base/lxde-common/ChangeLog
index cd8e3984fa20..3b01c8a1ef49 100644
--- a/lxde-base/lxde-common/ChangeLog
+++ b/lxde-base/lxde-common/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for lxde-base/lxde-common
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/lxde-base/lxde-common/ChangeLog,v 1.8 2009/11/21 18:29:15 nixnut Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/lxde-base/lxde-common/ChangeLog,v 1.9 2010/01/22 20:22:38 vostorga Exp $
+
+*lxde-common-0.5.0 (22 Jan 2010)
+
+ 22 Jan 2010; Víctor Ostorga <vostorga@gentoo.org>
+ +lxde-common-0.5.0.ebuild, +files/lxde-common-0.5.0-session-fix.patch:
+ Version bump to 0.5.0
21 Nov 2009; nixnut <nixnut@gentoo.org> lxde-common-0.4.2.ebuild:
ppc stable #292698
diff --git a/lxde-base/lxde-common/files/lxde-common-0.5.0-session-fix.patch b/lxde-base/lxde-common/files/lxde-common-0.5.0-session-fix.patch
new file mode 100644
index 000000000000..23a5438f032a
--- /dev/null
+++ b/lxde-base/lxde-common/files/lxde-common-0.5.0-session-fix.patch
@@ -0,0 +1,11 @@
+diff -NrU5 lxde-common-0.5.0.original/startlxde.in lxde-common-0.5.0/startlxde.in
+--- lxde-common-0.5.0.original/startlxde.in 2010-01-21 09:18:33.000000000 -0600
++++ lxde-common-0.5.0/startlxde.in 2010-01-21 09:19:12.000000000 -0600
+@@ -23,6 +23,6 @@
+
+ # Enable GTK+2 integration for OpenOffice.org, if available.
+ export SAL_USE_VCLPLUGIN=gtk
+
+ # Start the LXDE session
+-exec @prefix@/bin/lxsession -s LXDE
++exec @prefix@/bin/lxsession -s LXDE -e LXDE
diff --git a/lxde-base/lxde-common/lxde-common-0.5.0.ebuild b/lxde-base/lxde-common/lxde-common-0.5.0.ebuild
new file mode 100644
index 000000000000..cca143044b8e
--- /dev/null
+++ b/lxde-base/lxde-common/lxde-common-0.5.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/lxde-base/lxde-common/lxde-common-0.5.0.ebuild,v 1.1 2010/01/22 20:22:38 vostorga Exp $
+
+EAPI="1"
+
+inherit eutils
+
+DESCRIPTION="LXDE Session default configuration files and nuoveXT2 iconset"
+HOMEPAGE="http://lxde.sf.net/"
+SRC_URI="mirror://sourceforge/lxde/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ sys-devel/gettext"
+PDEPEND="lxde-base/lxde-icon-theme"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-session-fix.patch
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog README || die "dodoc failed"
+}
+
+pkg_postinst() {
+ elog "${P} has renamed the configuration file name to"
+ elog "/etc/xdg/lxsession/LXDE/desktop.conf"
+ elog "Keep in mind you have to migrate your custom settings"
+ elog "from /etc/xdg/lxsession/LXDE/config"
+}