summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2012-03-25 08:33:47 +0000
committerAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2012-03-25 08:33:47 +0000
commitc5043eac5dba0b75f5d7271fd19c970ef6540b8c (patch)
treea34214bd03dedbf220dfb69bc6e0523cdf2cecac /mail-client/alot
parentRemove old. (diff)
downloadgentoo-2-c5043eac5dba0b75f5d7271fd19c970ef6540b8c.tar.gz
gentoo-2-c5043eac5dba0b75f5d7271fd19c970ef6540b8c.tar.bz2
gentoo-2-c5043eac5dba0b75f5d7271fd19c970ef6540b8c.zip
mail-client/alot: Versioning scheme has been corrected.
Previous 0.21 is 0.2.1 now. (Portage version: 2.1.10.50/cvs/Linux x86_64)
Diffstat (limited to 'mail-client/alot')
-rw-r--r--mail-client/alot/ChangeLog8
-rw-r--r--mail-client/alot/alot-0.2.1-r1.ebuild (renamed from mail-client/alot/alot-0.21-r1.ebuild)17
-rw-r--r--mail-client/alot/alot-0.3.ebuild11
3 files changed, 27 insertions, 9 deletions
diff --git a/mail-client/alot/ChangeLog b/mail-client/alot/ChangeLog
index f5b353bb078b..85c1a41d7e8d 100644
--- a/mail-client/alot/ChangeLog
+++ b/mail-client/alot/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for mail-client/alot
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/alot/ChangeLog,v 1.3 2012/03/24 17:11:16 aidecoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/alot/ChangeLog,v 1.4 2012/03/25 08:33:46 aidecoe Exp $
+
+*alot-0.2.1-r1 (25 Mar 2012)
+
+ 25 Mar 2012; Amadeusz Żołnowski <aidecoe@gentoo.org> +alot-0.2.1-r1.ebuild,
+ alot-0.3.ebuild, -alot-0.21-r1.ebuild:
+ Versioning scheme has been corrected. Previous 0.21 is 0.2.1 now.
*alot-0.3 (24 Mar 2012)
diff --git a/mail-client/alot/alot-0.21-r1.ebuild b/mail-client/alot/alot-0.2.1-r1.ebuild
index c20d57d7880c..f73dd1aeb82f 100644
--- a/mail-client/alot/alot-0.21-r1.ebuild
+++ b/mail-client/alot/alot-0.2.1-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/alot/alot-0.21-r1.ebuild,v 1.1 2011/12/27 11:23:56 aidecoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/alot/alot-0.2.1-r1.ebuild,v 1.1 2012/03/25 08:33:46 aidecoe Exp $
EAPI=4
@@ -8,11 +8,14 @@ PYTHON_DEPEND="2:2.7"
SUPPORT_PYTHON_ABIS="1"
RESTRICT_PYTHON_ABIS="2.[456] 3.*"
-inherit distutils
+inherit distutils versionator
+
+MY_PV=$(replace_version_separator 2 '')
+MY_P="${PN}-${MY_PV}"
DESCRIPTION="Experimental terminal UI for net-mail/notmuch written in Python"
HOMEPAGE="https://github.com/pazz/alot"
-SRC_URI="${HOMEPAGE}/tarball/${PV} -> ${P}.tar.gz"
+SRC_URI="${HOMEPAGE}/tarball/${MY_PV} -> ${MY_P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
@@ -43,5 +46,9 @@ src_prepare() {
mv "${md}" "${md%.md}"
done
- echo "${PV}" > alot/VERSION
+ echo "${MY_PV}" > alot/VERSION
+}
+
+pkg_postinst() {
+ ewarn "Versioning scheme has been corrected. Previous 0.21 is 0.2.1 now."
}
diff --git a/mail-client/alot/alot-0.3.ebuild b/mail-client/alot/alot-0.3.ebuild
index fe71412253f8..f0396158babf 100644
--- a/mail-client/alot/alot-0.3.ebuild
+++ b/mail-client/alot/alot-0.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/alot/alot-0.3.ebuild,v 1.1 2012/03/24 17:11:16 aidecoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/alot/alot-0.3.ebuild,v 1.2 2012/03/25 08:33:46 aidecoe Exp $
EAPI=4
@@ -8,11 +8,14 @@ PYTHON_DEPEND="2:2.7"
SUPPORT_PYTHON_ABIS="1"
RESTRICT_PYTHON_ABIS="2.[456] 3.*"
-inherit distutils vcs-snapshot
+inherit distutils vcs-snapshot versionator
+
+MY_PV=$(replace_version_separator 2 '')
+MY_P="${PN}-${MY_PV}"
DESCRIPTION="Experimental terminal UI for net-mail/notmuch written in Python"
HOMEPAGE="https://github.com/pazz/alot"
-SRC_URI="${HOMEPAGE}/tarball/${PV} -> ${P}.tar.gz"
+SRC_URI="${HOMEPAGE}/tarball/${MY_PV} -> ${MY_P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
@@ -39,6 +42,8 @@ src_prepare() {
}
pkg_postinst() {
+ ewarn "Versioning scheme has been corrected. Previous 0.21 is 0.2.1 now."
+ echo
ewarn "If you're upgrading from version prior to 0.3, you need to remove"
ewarn "current config (\$HOME/.config/alot/config) before running alot,"
ewarn "because its format has been changed."