summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2012-05-17 21:00:03 +0000
committerAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2012-05-17 21:00:03 +0000
commitdd28d074a8bcd4734e7a369561a4ad9c71dcd12e (patch)
treea78a8952dd2e67cc2d1a1308c58b9783ebc55f5b /mail-client/alot
parentChange >=media-video/libav-0.8.2 to <=media-video/libav-0.8.2 for ensuring st... (diff)
downloadgentoo-2-dd28d074a8bcd4734e7a369561a4ad9c71dcd12e.tar.gz
gentoo-2-dd28d074a8bcd4734e7a369561a4ad9c71dcd12e.tar.bz2
gentoo-2-dd28d074a8bcd4734e7a369561a4ad9c71dcd12e.zip
Version bump.
(Portage version: 2.1.10.62/cvs/Linux x86_64)
Diffstat (limited to 'mail-client/alot')
-rw-r--r--mail-client/alot/ChangeLog35
-rw-r--r--mail-client/alot/alot-0.3.1.ebuild48
2 files changed, 82 insertions, 1 deletions
diff --git a/mail-client/alot/ChangeLog b/mail-client/alot/ChangeLog
index 06fac1120784..443cc759f619 100644
--- a/mail-client/alot/ChangeLog
+++ b/mail-client/alot/ChangeLog
@@ -1,6 +1,39 @@
# ChangeLog for mail-client/alot
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/alot/ChangeLog,v 1.5 2012/03/25 08:45:09 aidecoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/alot/ChangeLog,v 1.6 2012/05/17 21:00:03 aidecoe Exp $
+
+*alot-0.3.1 (17 May 2012)
+
+ 17 May 2012; Amadeusz Żołnowski <aidecoe@gentoo.org> +alot-0.3.1.ebuild:
+ Version bump.
+
+ NEWS
+ ~~~~
+ (Copied from NEWS file.)
+
+ * use separate database for each write-queue entry when flushing
+ * fix behaviour of editor spawning
+ * fix opening of attachments in thread buffer
+ * fix pre_edit_translate hook
+ * fix opening of attachments without filename Content-Disposition parm
+ * clean up and complete theming (bindings help/envelope/mainframe body)
+ * fix datetime decoding issues
+ * fix abort commands on pre-hook exceptions
+ * fix correct default sendmail command to 'sendmail -t'
+ * use '> ' instead of '>' to quote in replies/fwds
+ * fix path completer wrt spaces in paths
+ * fix UI when no buffers are open
+ * fix issue with buffer type changing between flushes
+ * support multiple addresses per abook contact when using 'abook' completer
+ * smarter timestamp pretty printer
+ * new hook 'timestamp_format'
+ * merge multiple cc/to headers into one when displaying
+ * respect NOTMUCH_CONFIG env var
+ * smarter parsing of edited header values
+ * allow for singleton lists without trailing comma in config
+ * fix reverse-date sorted content in threadline if displayed
+ * emacs-style C-a and C-E in prompts
+ * added ability to sign outgoing mails via PGP/MIME
25 Mar 2012; Amadeusz Żołnowski <aidecoe@gentoo.org> alot-0.2.1-r1.ebuild:
vcs-snapshot is used in the ebuild instead of custom src_unpack().
diff --git a/mail-client/alot/alot-0.3.1.ebuild b/mail-client/alot/alot-0.3.1.ebuild
new file mode 100644
index 000000000000..3b8d448e824c
--- /dev/null
+++ b/mail-client/alot/alot-0.3.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/alot/alot-0.3.1.ebuild,v 1.1 2012/05/17 21:00:03 aidecoe Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="2:2.7"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.[456] 3.*"
+
+inherit distutils vcs-snapshot
+
+DESCRIPTION="Experimental terminal UI for net-mail/notmuch written in Python"
+HOMEPAGE="https://github.com/pazz/alot"
+SRC_URI="${HOMEPAGE}/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="
+ >=dev-python/configobj-4.6.0
+ >=dev-python/pyme-0.8.1
+ >=dev-python/twisted-10.2.0
+ >=dev-python/urwid-1.0.0
+ net-mail/mailbase
+ >=net-mail/notmuch-0.13[crypt,python]
+ sys-apps/file[python]
+ "
+
+src_prepare() {
+ distutils_src_prepare
+
+ local md
+ for md in *.md; do
+ mv "${md}" "${md%.md}"
+ done
+}
+
+pkg_postinst() {
+ ewarn "Versioning scheme has been corrected. Previous 0.21 is 0.2.1 now."
+ echo
+ ewarn "If you're upgrading from version prior to 0.3, you need to remove"
+ ewarn "current config (\$HOME/.config/alot/config) before running alot,"
+ ewarn "because its format has been changed."
+}