summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <fauli@gentoo.org>2010-06-12 07:36:09 +0000
committerChristian Faulhammer <fauli@gentoo.org>2010-06-12 07:36:09 +0000
commitb4de0602f10b40f9212d7fcad5c0e351a5a4fd1a (patch)
tree371fff57f7cb5e6b3eca43ce92a293248cd425dc /mail-client/claws-mail-python/claws-mail-python-0.4.ebuild
parentversion bump, bug 319161 (diff)
downloadgentoo-2-b4de0602f10b40f9212d7fcad5c0e351a5a4fd1a.tar.gz
gentoo-2-b4de0602f10b40f9212d7fcad5c0e351a5a4fd1a.tar.bz2
gentoo-2-b4de0602f10b40f9212d7fcad5c0e351a5a4fd1a.zip
version bump, bug 319161
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'mail-client/claws-mail-python/claws-mail-python-0.4.ebuild')
-rw-r--r--mail-client/claws-mail-python/claws-mail-python-0.4.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/mail-client/claws-mail-python/claws-mail-python-0.4.ebuild b/mail-client/claws-mail-python/claws-mail-python-0.4.ebuild
new file mode 100644
index 000000000000..7828c88da2d3
--- /dev/null
+++ b/mail-client/claws-mail-python/claws-mail-python-0.4.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail-python/claws-mail-python-0.4.ebuild,v 1.1 2010/06/12 07:36:09 fauli Exp $
+
+MY_P="${PN#claws-mail-}_plugin-${PV}"
+
+DESCRIPTION="Plugin to integrate with Python"
+HOMEPAGE="http://www.claws-mail.org/"
+SRC_URI="http://www.claws-mail.org/downloads/plugins/${MY_P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RDEPEND=">=mail-client/claws-mail-3.7.6
+ >=dev-lang/python-2.5"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc ChangeLog README
+
+ # kill useless files
+ rm -f "${D}"/usr/lib*/claws-mail/plugins/*.{a,la}
+}