summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2007-08-06 13:32:17 +0000
committerRoy Marples <uberlord@gentoo.org>2007-08-06 13:32:17 +0000
commit4ff332def23ab7bae3d2e985d4965470263a45f7 (patch)
treee4c5ddcdcb841319db8b6b6497231b9692373f49 /mail-client/pine
parentStable on sparc wrt security #185446 (diff)
downloadgentoo-2-4ff332def23ab7bae3d2e985d4965470263a45f7.tar.gz
gentoo-2-4ff332def23ab7bae3d2e985d4965470263a45f7.tar.bz2
gentoo-2-4ff332def23ab7bae3d2e985d4965470263a45f7.zip
Fix building on FreeBSD and keyword ~x86-fbsd, #104760.
(Portage version: 2.1.3.3)
Diffstat (limited to 'mail-client/pine')
-rw-r--r--mail-client/pine/ChangeLog5
-rw-r--r--mail-client/pine/pine-4.64-r6.ebuild21
2 files changed, 20 insertions, 6 deletions
diff --git a/mail-client/pine/ChangeLog b/mail-client/pine/ChangeLog
index 26e0a0eb64a6..2f86028701dc 100644
--- a/mail-client/pine/ChangeLog
+++ b/mail-client/pine/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for mail-client/pine
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/pine/ChangeLog,v 1.99 2007/04/21 13:19:41 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/pine/ChangeLog,v 1.100 2007/08/06 13:32:17 uberlord Exp $
+
+ 06 Aug 2007; Roy Marples <uberlord@gentoo.org> pine-4.64-r6.ebuild:
+ Fix building on FreeBSD and keyword ~x86-fbsd, #104760.
21 Apr 2007; Raúl Porcel <armin76@gentoo.org> pine-4.64-r5.ebuild:
ia64 stable
diff --git a/mail-client/pine/pine-4.64-r6.ebuild b/mail-client/pine/pine-4.64-r6.ebuild
index bda21e671f07..799af21fd6bd 100644
--- a/mail-client/pine/pine-4.64-r6.ebuild
+++ b/mail-client/pine/pine-4.64-r6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/pine/pine-4.64-r6.ebuild,v 1.4 2007/06/26 02:08:16 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/pine/pine-4.64-r6.ebuild,v 1.5 2007/08/06 13:32:17 uberlord Exp $
inherit eutils
@@ -21,13 +21,13 @@ SRC_URI="ftp://ftp.cac.washington.edu/pine/${P/-/}.tar.bz2
LICENSE="PICO"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
IUSE="ssl ldap kerberos largeterminal pam passfile debug"
DEPEND="virtual/libc
>=sys-apps/sed-4
>=sys-libs/ncurses-5.1
- pam? ( >=sys-libs/pam-0.72 )
+ pam? ( virtual/pam )
ssl? ( dev-libs/openssl )
ldap? ( net-nds/openldap )
kerberos? ( app-crypt/mit-krb5 )"
@@ -118,6 +118,15 @@ src_unpack() {
sed -e "s:/usr/local/lib/pine.conf:/etc/pine.conf:" \
-i "${S}/pine/osdep/os-lnx.h" || die "sed os-lnx.h failed"
+
+ sed -e "s:/usr/local/lib/pine.conf:/etc/pine.conf:" \
+ -i "${S}/pine/osdep/os-bsf.h" || die "sed os-bsf.h failed"
+
+ # We use ncurses for FreeBSD
+ for x in "${S}"/*/makefile.bsf ; do
+ sed -e "s/-ltermcap/-lcurses/g" -e "s/-ltermlib/-lcurses/g" \
+ -i "${x}" || die "sed ${x} failed"
+ done
}
src_compile() {
@@ -126,7 +135,7 @@ src_compile() {
myconf="${myconf} SSLDIR=/usr SSLTYPE=unix SSLCERTS=/etc/ssl/certs"
sed -e "s:\$(SSLDIR)/certs:/etc/ssl/certs:" \
-e "s:\$(SSLCERTS):/etc/ssl/certs:" \
- -e "s:-I\$(SSLINCLUDE) ::" \
+ -e "s:-I\$(SSLINCLUDE):-I/usr/include/openssl:" \
-i "${S}/imap/src/osdep/unix/Makefile" || die "sed Makefile failed"
else
myconf="${myconf} NOSSL"
@@ -141,7 +150,9 @@ src_compile() {
myconf="${myconf} EXTRAAUTHENTICATORS=gss"
fi
- if use pam ; then
+ if use elibc_FreeBSD ; then
+ target=bsf
+ elif use pam ; then
target=lnp
else
target=slx