summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Kacian <ticho@gentoo.org>2006-05-31 09:48:44 +0000
committerAndrej Kacian <ticho@gentoo.org>2006-05-31 09:48:44 +0000
commit0be7c91541986daec0583006789859502f078bd7 (patch)
tree8e47023b0017d235653ef6a6022dcef7d89db175 /mail-filter
parent- dont use full hardcoded path for the math library. bug 134956 (diff)
downloadgentoo-2-0be7c91541986daec0583006789859502f078bd7.tar.gz
gentoo-2-0be7c91541986daec0583006789859502f078bd7.tar.bz2
gentoo-2-0be7c91541986daec0583006789859502f078bd7.zip
Version bump. Closes bug #93414, reported by Oleg Kostyuk <cub.uanic@gmail.com>.
(Portage version: 2.1_rc3-r2)
Diffstat (limited to 'mail-filter')
-rw-r--r--mail-filter/tmda/ChangeLog10
-rw-r--r--mail-filter/tmda/files/digest-tmda-1.1.43
-rw-r--r--mail-filter/tmda/tmda-1.1.4.ebuild66
3 files changed, 77 insertions, 2 deletions
diff --git a/mail-filter/tmda/ChangeLog b/mail-filter/tmda/ChangeLog
index c2d093faf95c..53aefdb98c33 100644
--- a/mail-filter/tmda/ChangeLog
+++ b/mail-filter/tmda/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for mail-filter/tmda
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/tmda/ChangeLog,v 1.13 2005/06/05 12:01:28 hansmi Exp $
+# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/tmda/ChangeLog,v 1.14 2006/05/31 09:48:44 ticho Exp $
+
+*tmda-1.1.4 (31 May 2006)
+
+ 31 May 2006; Andrej Kacian <ticho@gentoo.org> +tmda-1.1.4.ebuild:
+ Version bump. Closes bug #93414, reported by Oleg Kostyuk
+ <cub.uanic@gmail.com>.
05 Jun 2005; Michael Hanselmann <hansmi@gentoo.org> tmda-1.0.3-r3.ebuild:
Stable on ppc.
diff --git a/mail-filter/tmda/files/digest-tmda-1.1.4 b/mail-filter/tmda/files/digest-tmda-1.1.4
new file mode 100644
index 000000000000..88723ffbfb5b
--- /dev/null
+++ b/mail-filter/tmda/files/digest-tmda-1.1.4
@@ -0,0 +1,3 @@
+MD5 58c79099ea0cd4bfc48f85de5502a2f2 tmda-1.1.4.tgz 391723
+RMD160 8ea4e660e47b1d087d349ada8c166f834a64601a tmda-1.1.4.tgz 391723
+SHA256 d26f5cd59af6e39421f8197fff9397c647f86745efe0c3a541130c969d6cd90f tmda-1.1.4.tgz 391723
diff --git a/mail-filter/tmda/tmda-1.1.4.ebuild b/mail-filter/tmda/tmda-1.1.4.ebuild
new file mode 100644
index 000000000000..c367a24b84dd
--- /dev/null
+++ b/mail-filter/tmda/tmda-1.1.4.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/tmda/tmda-1.1.4.ebuild,v 1.1 2006/05/31 09:48:44 ticho Exp $
+
+inherit eutils
+
+DESCRIPTION="Python-based SPAM reduction system"
+HOMEPAGE="http://www.tmda.net/"
+LICENSE="GPL-2"
+
+DEPEND=">=dev-lang/python-2.2
+ virtual/mta"
+
+SRC_URI="http://www.tmda.net/releases/unstable/${P}.tgz"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+src_compile () {
+ # Fix multipart mail handling. (See bug #60367) -ticho
+ epatch ${FILESDIR}/tmda-1.0-multipart-handling.patch
+
+ # Do not open /dev/tty when in batch mode. (bug #67150) -ticho
+ epatch ${FILESDIR}/tmda-1.0-non-interactive-tty.patch
+
+ ./compileall || die "tmda compilation failed"
+}
+
+src_install () {
+ # Figure out python version
+ # below hack should be replaced w/ pkg-config, when we get it working
+ local pv=`python -V 2>&1 | sed -e 's:Python \([0-9].[0-9]\).*:\1:'`
+
+ # Executables
+ dobin bin/tmda-*
+
+ # The Python TMDA module
+ insinto "/usr/lib/python${pv}/site-packages/TMDA"
+ doins TMDA/*.py*
+ insinto "/usr/lib/python${pv}/site-packages/TMDA/pythonlib/email"
+ doins TMDA/pythonlib/email/*.py*
+
+ # The templates
+ insinto /etc/tmda
+ doins templates/*.txt
+
+ # Documentation
+ dodoc COPYING ChangeLog README THANKS UPGRADE CRYPTO CODENAMES INSTALL
+ dohtml -r htdocs/*.html
+ dohtml -r htdocs/img
+
+ # Contributed binaries and stuff
+ cd ${S}/contrib
+
+ exeinto /usr/lib/tmda/contrib
+ doexe collectaddys def2html printcdb printdbm \
+ sendit.sh smtp-check-sender update-internaldomains vadduser-tmda \
+ vmailmgr-vdir.sh vpopmail-vdir.sh wrapfd3.sh
+
+ insinto /usr/lib/tmda/contrib
+ doins ChangeLog tmda.el tmda.spec \
+ tofmipd.init tofmipd.sysconfig vtmdarc
+
+ insinto /usr/lib/tmda/contrib/dot-tmda
+ doins dot-tmda/*
+}