summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2008-05-23 07:41:30 +0000
committerAlfredo Tupone <tupone@gentoo.org>2008-05-23 07:41:30 +0000
commit706b845cd913d94af19f789b0e823627fd4b4ded (patch)
tree6c32ff70000861a21adf59fc4110c4992d1049f6 /mail-filter
parentFixed DESCRIPTION, thanks to nightmorph. (diff)
downloadgentoo-2-706b845cd913d94af19f789b0e823627fd4b4ded.tar.gz
gentoo-2-706b845cd913d94af19f789b0e823627fd4b4ded.tar.bz2
gentoo-2-706b845cd913d94af19f789b0e823627fd4b4ded.zip
Version bump to 3.1.8 Bug #223157
(Portage version: 2.1.4.4)
Diffstat (limited to 'mail-filter')
-rw-r--r--mail-filter/spamdyke/ChangeLog7
-rw-r--r--mail-filter/spamdyke/spamdyke-3.1.8.ebuild68
2 files changed, 74 insertions, 1 deletions
diff --git a/mail-filter/spamdyke/ChangeLog b/mail-filter/spamdyke/ChangeLog
index 982362ed631a..73e0302b0f88 100644
--- a/mail-filter/spamdyke/ChangeLog
+++ b/mail-filter/spamdyke/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for mail-filter/spamdyke
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/spamdyke/ChangeLog,v 1.6 2008/05/21 20:19:24 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/spamdyke/ChangeLog,v 1.7 2008/05/23 07:41:30 tupone Exp $
+
+*spamdyke-3.1.8 (23 May 2008)
+
+ 23 May 2008; <atupone@gentoo.org> +spamdyke-3.1.8.ebuild:
+ Version bump to 3.1.8 Bug #223157 by toto
21 May 2008; Christian Faulhammer <opfer@gentoo.org>
spamdyke-3.1.7.ebuild:
diff --git a/mail-filter/spamdyke/spamdyke-3.1.8.ebuild b/mail-filter/spamdyke/spamdyke-3.1.8.ebuild
new file mode 100644
index 000000000000..94b594f57f54
--- /dev/null
+++ b/mail-filter/spamdyke/spamdyke-3.1.8.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/spamdyke/spamdyke-3.1.8.ebuild,v 1.1 2008/05/23 07:41:30 tupone Exp $
+
+EAPI="1"
+
+DESCRIPTION="A drop-in connection-time spam filter for qmail"
+HOMEPAGE="http://www.spamdyke.org/"
+SRC_URI="http://www.spamdyke.org/releases/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+tls"
+
+DEPEND="tls? ( dev-libs/openssl )"
+
+S=${WORKDIR}/${P}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ echo "# Configuration option for ${PN}" > ${PN}.conf
+ if use tls; then
+ echo "tls-certificate-file=/var/qmail/control/clientcert.pem" \
+ >> ${PN}.conf
+ fi
+ echo "graylist-dir=/var/tmp/${PN}/graylist" >> ${PN}.conf
+ echo "never-graylist-rdns-dir=/etc/${PN}/never-graylist" >> ${PN}.conf
+ echo "reject-empty-rdns" >> ${PN}.conf
+ echo "reject-unresolvable-rdns" >> ${PN}.conf
+}
+
+src_compile() {
+ econf --with-debug \
+ $(use_enable tls) || die "econf failed"
+ emake CFLAGS="${CFLAGS}" || die "emake failed"
+ cd ../utils
+ econf || die "econf failed in utils"
+ emake CFLAGS="${CFLAGS}" || die "emake in utils died"
+}
+
+src_install() {
+ dobin ${PN} || die "Installing ${PN} binary failed"
+ insinto /etc/${PN}
+ doins ${PN}.conf || die "Installing ${PN} configuration file failed"
+ keepdir /var/tmp/${PN}/graylist/$(../utils/domain2path -d localhost)
+ fowners -R qmaild /var/tmp/${PN}
+ insinto /etc/${PN}/never-graylist/$(../utils/domain2path -d localhost)
+ touch localhost
+ doins localhost
+ cd ../utils
+ dobin domain2path || die "Installing domain2path binary failed"
+ cd ../documentation
+ dodoc {Changelog,INSTALL,UPGRADING}.txt
+ dohtml FAQ.html \
+ README.html \
+ README_ip_file_format.html \
+ README_rdns_directory_format.html \
+ README_rdns_file_format.html
+}
+
+pkg_postinst() {
+ elog "In /var/qmail/control/conf-smtpd insert the line:"
+ elog "QMAIL_SMTP_PRE=\"${QMAIL_SMTP_PRE} spamdyke -f /etc/${PN}/${PN}.conf\""
+ elog "Run spamdyke with the '-h' flag to see the available options and"
+ elog "update /etc/spamdyke.conf accordingly"
+}