summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2004-05-30 09:56:46 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2004-05-30 09:56:46 +0000
commitc010cc1753f2a5a38c6e47624317f1148b91dc36 (patch)
tree621a58dae6759c5b25b01025f4c833e2f52ce240 /mail-mta/ssmtp/ssmtp-2.38.14-r1.ebuild
parentAdded to ~ppc (Manifest recommit) (diff)
downloadgentoo-2-c010cc1753f2a5a38c6e47624317f1148b91dc36.tar.gz
gentoo-2-c010cc1753f2a5a38c6e47624317f1148b91dc36.tar.bz2
gentoo-2-c010cc1753f2a5a38c6e47624317f1148b91dc36.zip
Moved from net-mail/ssmtp to mail-mta/ssmtp.
Diffstat (limited to 'mail-mta/ssmtp/ssmtp-2.38.14-r1.ebuild')
-rw-r--r--mail-mta/ssmtp/ssmtp-2.38.14-r1.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/mail-mta/ssmtp/ssmtp-2.38.14-r1.ebuild b/mail-mta/ssmtp/ssmtp-2.38.14-r1.ebuild
new file mode 100644
index 000000000000..a282338c2880
--- /dev/null
+++ b/mail-mta/ssmtp/ssmtp-2.38.14-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/ssmtp/ssmtp-2.38.14-r1.ebuild,v 1.1 2004/05/30 09:56:46 robbat2 Exp $
+
+DESCRIPTION="Extremely simple MTA to get mail off the system to a Mailhub"
+SRC_URI="ftp://ftp.ibiblio.org/pub/Linux/system/mail/mta/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc sparc alpha hppa"
+
+DEPEND="virtual/glibc"
+RDEPEND="!virtual/mta
+ net-mail/mailbase"
+PROVIDE="virtual/mta"
+
+src_compile() {
+ make clean || die
+ make ${MAKEOPTS} || die
+}
+
+src_install() {
+ dodir /usr/bin /usr/sbin /usr/lib
+ dosbin ssmtp
+ chmod 755 ${D}/usr/sbin/ssmtp
+ dosym /usr/sbin/ssmtp /usr/bin/mailq
+ dosym /usr/sbin/ssmtp /usr/bin/newaliases
+ # Removed symlink due to conflict with mailx
+ # See bug #7448
+ #dosym /usr/sbin/ssmtp /usr/bin/mail
+ dosym /usr/sbin/ssmtp /usr/sbin/sendmail
+ dosym /usr/sbin/ssmtp /usr/lib/sendmail
+ doman ssmtp.8
+ dosym /usr/share/man/man8/ssmtp.8 /usr/share/man/man8/sendmail.8
+ dodoc CHANGELOG INSTALL MANIFEST README
+ newdoc ssmtp.lsm DESC
+ insinto /etc/ssmtp
+ doins ssmtp.conf revaliases
+}
+
+pkg_config() {
+ local conffile="/etc/ssmtp/ssmtp.conf"
+ local hostname=`hostname -f`
+ local domainame=`hostname -d`
+ mv ${conffile} ${conffile}.orig
+ sed -e "s:rewriteDomain\=:rewriteDomain\=${domainame}:g" \
+ -e "s:_HOSTNAME_:${hostname}:" \
+ -e "s:\=mail:\=mail.${domainame}:g" \
+ ${conffile}.orig > ${conffile}
+
+}