summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorScott W Taylor <swtaylor@gentoo.org>2005-01-31 00:35:56 +0000
committerScott W Taylor <swtaylor@gentoo.org>2005-01-31 00:35:56 +0000
commitae89b46801c3459f75954bcae882eed674ebfc2c (patch)
tree967b73aa5e01a192f77d8adeeaa12e1341247e6e /mail-mta
parentrepoman: Fix leading whitespace (diff)
downloadgentoo-2-ae89b46801c3459f75954bcae882eed674ebfc2c.tar.gz
gentoo-2-ae89b46801c3459f75954bcae882eed674ebfc2c.tar.bz2
gentoo-2-ae89b46801c3459f75954bcae882eed674ebfc2c.zip
bump and add smtp auth
(Portage version: 2.0.51-r15)
Diffstat (limited to 'mail-mta')
-rw-r--r--mail-mta/courier/ChangeLog6
-rw-r--r--mail-mta/courier/courier-0.48.2.20050130.ebuild16
2 files changed, 13 insertions, 9 deletions
diff --git a/mail-mta/courier/ChangeLog b/mail-mta/courier/ChangeLog
index 4eba54c4c10d..3883f5dd9273 100644
--- a/mail-mta/courier/ChangeLog
+++ b/mail-mta/courier/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for mail-mta/courier
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/courier/ChangeLog,v 1.44 2005/01/30 23:33:25 swtaylor Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/courier/ChangeLog,v 1.45 2005/01/31 00:35:55 swtaylor Exp $
+
+ 30 Jan 2005; Scott W Taylor <swtaylor@gentoo.org>
+ courier-0.48.2.20050130.ebuild:
+ version bump, add smtp auth methods as well.
*courier-0.48.2 (30 Jan 2005)
diff --git a/mail-mta/courier/courier-0.48.2.20050130.ebuild b/mail-mta/courier/courier-0.48.2.20050130.ebuild
index 6ecc18b68a66..946f2d56fe8e 100644
--- a/mail-mta/courier/courier-0.48.2.20050130.ebuild
+++ b/mail-mta/courier/courier-0.48.2.20050130.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/courier/courier-0.48.2.20050130.ebuild,v 1.1 2005/01/30 23:33:25 swtaylor Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/courier/courier-0.48.2.20050130.ebuild,v 1.2 2005/01/31 00:35:56 swtaylor Exp $
inherit eutils
@@ -14,8 +14,7 @@ S="${WORKDIR}/${P%%_pre}"
SLOT="0"
LICENSE="GPL-2"
# not in keywords due to missing dependencies: ~arm ~s390 ~ppc64
-#KEYWORDS="~x86 ~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~sparc"
-KEYWORDS="-*"
+KEYWORDS="~x86 ~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~sparc"
IUSE="postgres ldap mysql pam nls ipv6 spell fax crypt norewrite uclibc mailwrapper"
PROVIDE="virtual/mta
@@ -99,11 +98,10 @@ etc_courier() {
}
etc_courier_chg() {
- set -v -x
- file="${1}" ; key="${2}" ; value="${3}"
+ file="${1}" ; key="${2}" ; value="${3}" ; section="${4}"
+ [ -z "${section}" ] && section="${2}"
grep -q "${key}" "${file}" && einfo "Changing ${file}: ${key} to ${value}"
- sed -i -e"/\#\#NAME: ${key}/,+20 s|${key}=.*|${key}=\"${value}\"|g" ${file}
- set +v +x
+ sed -i -e"/\#\#NAME: ${section}/,+20 s|${key}=.*|${key}=\"${value}\"|g" ${file}
}
set_maildir() {
@@ -170,7 +168,9 @@ src_install() {
etc_courier esmtpd-msa "BOFHBADMIME=accept"
etc_courier_chg esmtpd ESMTPDSTART YES
etc_courier_chg esmtpd ESMTPAUTH "LOGIN CRAM-SHA1 CRAM-MD5"
- etc_courier_chg esmtpd ESMTPAUTH_TLS "PLAIN LOGIN CRAM-SHA1 CRAM-MD5"
+ etc_courier_chg esmtpd ESMTPAUTH_WEBADMIN "LOGIN CRAM-SHA1 CRAM-MD5"
+ etc_courier_chg esmtpd ESMTPAUTH_TLS "PLAIN LOGIN CRAM-SHA1 CRAM-MD5" ESMTPAUTHINFOTLS
+ etc_courier_chg esmtpd ESMTPAUTH_TLS_WEBADMIN "PLAIN LOGIN CRAM-SHA1 CRAM-MD5" ESMTPAUTHINFOTLS
etc_courier_chg esmtpd-msa ESMTPDSTART YES
etc_courier_chg esmtpd-msa AUTH_REQUIRED 1
etc_courier_chg esmtpd-ssl ESMTPDSSLSTART YES