summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-10-15 19:03:04 +0000
committerPacho Ramos <pacho@gentoo.org>2013-10-15 19:03:04 +0000
commitd1e07a54792112a8516fab006f83e70e1421fa17 (patch)
tree510aade0d50c04989baf664bae129a9a654c6369 /media-gfx/dcraw
parentVersion bump, drop old (diff)
downloadgentoo-2-d1e07a54792112a8516fab006f83e70e1421fa17.tar.gz
gentoo-2-d1e07a54792112a8516fab006f83e70e1421fa17.tar.bz2
gentoo-2-d1e07a54792112a8516fab006f83e70e1421fa17.zip
Use readme.gentoo.eclass, drop old
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'media-gfx/dcraw')
-rw-r--r--media-gfx/dcraw/ChangeLog6
-rw-r--r--media-gfx/dcraw/dcraw-9.05.ebuild123
-rw-r--r--media-gfx/dcraw/dcraw-9.12.ebuild125
-rw-r--r--media-gfx/dcraw/dcraw-9.17.ebuild59
4 files changed, 36 insertions, 277 deletions
diff --git a/media-gfx/dcraw/ChangeLog b/media-gfx/dcraw/ChangeLog
index aee5d8b9a2c8..5819424eb2a6 100644
--- a/media-gfx/dcraw/ChangeLog
+++ b/media-gfx/dcraw/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-gfx/dcraw
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/dcraw/ChangeLog,v 1.87 2013/03/03 16:55:47 wschlich Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/dcraw/ChangeLog,v 1.88 2013/10/15 19:03:04 pacho Exp $
+
+ 15 Oct 2013; Pacho Ramos <pacho@gentoo.org> -dcraw-9.05.ebuild,
+ -dcraw-9.12.ebuild, dcraw-9.17.ebuild:
+ Use readme.gentoo.eclass, drop old
03 Mar 2013; Wolfram Schlich <wschlich@gentoo.org> metadata.xml:
removed myself from metadata.xml
diff --git a/media-gfx/dcraw/dcraw-9.05.ebuild b/media-gfx/dcraw/dcraw-9.05.ebuild
deleted file mode 100644
index c62cc7cc6aed..000000000000
--- a/media-gfx/dcraw/dcraw-9.05.ebuild
+++ /dev/null
@@ -1,123 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/dcraw/dcraw-9.05.ebuild,v 1.9 2012/05/05 07:00:19 jdhore Exp $
-
-EAPI="2"
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="Converts the native (RAW) format of various digital cameras into netpbm portable pixmap (.ppm) image"
-HOMEPAGE="http://www.cybercom.net/~dcoffin/dcraw/"
-SRC_URI="http://www.cybercom.net/~dcoffin/dcraw/archive/${P}.tar.gz
- mirror://gentoo/parse-1.71.tar.bz2
- gimp? ( mirror://gentoo/rawphoto-1.32.tar.bz2 )"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~x86-solaris"
-IUSE="nls gimp jpeg lcms"
-
-COMMON_DEPEND="jpeg? ( virtual/jpeg )
- lcms? ( =media-libs/lcms-1* )
- gimp? ( media-gfx/gimp )"
-DEPEND="${COMMON_DEPEND}
- nls? ( sys-devel/gettext )
- gimp? ( virtual/pkgconfig )"
-RDEPEND="${COMMON_DEPEND}
- media-libs/netpbm"
-
-S=${WORKDIR}/dcraw
-
-LANGS="ca cs de da eo es fr hu it nl pl pt ru sv zh_CN zh_TW"
-
-for lng in ${LANGS}; do
- IUSE+=" linguas_${lng}"
-done
-
-# Helper function to list only langs listed in LANGS or
-linguas_list() {
- local nolangs=true
- for lng in ${LANGS}; do
- if use linguas_${lng}; then
- nolangs=false
- echo " ${lng}"
- fi
- done
- if ${nolangs}; then
- echo ${LANGS}
- fi
-}
-
-run_build() {
- einfo "${@}"
- ${@} || die
-}
-
-src_prepare() {
- rename dcraw_ dcraw. dcraw_*.1 || die "Failed to rename"
-}
-
-src_compile() {
- local ECFLAGS="-O2" # Without optimisation build fails
- local ELIBS="-lm"
-
- use lcms && ELIBS="-llcms ${ELIBS}" || ECFLAGS+=" -DNO_LCMS=yes"
- use jpeg && ELIBS="-ljpeg ${ELIBS}" || ECFLAGS+=" -DNO_JPEG=yes"
- use nls && ECFLAGS+=" -DLOCALEDIR=\"/usr/share/locale/\""
-
- run_build $(tc-getCC) ${ECFLAGS} ${CFLAGS} ${LDFLAGS} \
- -o dcraw dcraw.c ${ELIBS}
-
- run_build $(tc-getCC) -O2 ${CFLAGS} ${LDFLAGS} \
- -o dcparse parse.c
-
- # rawphoto gimp plugin
- if use gimp; then
- run_build $(tc-getCC) ${CFLAGS} ${LDFLAGS} \
- $(pkg-config --cflags gimpui-2.0) rawphoto.c -o rawphoto \
- $(pkg-config --libs gimpui-2.0)
- fi
-
- if use nls; then
- for lng in $(linguas_list); do
- run_build msgfmt -c -o dcraw_${lng}.mo dcraw_${lng}.po
- done
- fi
-}
-
-src_install() {
- dobin dcraw dcparse || die
- dodoc "${FILESDIR}"/{conversion-examples.txt,dcwrap} || die
-
- # rawphoto gimp plugin
- if use gimp; then
- insinto "$(pkg-config --variable=gimplibdir gimp-2.0)/plug-ins"
- insopts -m0755
- doins rawphoto || die
- fi
-
- doman dcraw.1 || die
- if use nls; then
- for lng in $(linguas_list); do
- [[ -f dcraw.${lng}.1 ]] && doman dcraw.${lng}.1
- insinto /usr/share/locale/${lng}/LC_MESSAGES
- newins dcraw_${lng}.mo dcraw.mo || die "failed to install dcraw_${lng}.mo"
- done
- fi
-}
-
-pkg_postinst() {
- elog ""
- elog "See conversion-examples.txt.gz on how to convert"
- elog "the PPM files produced by dcraw to other image formats."
- elog ""
- ewarn "The functionality of the external program 'fujiturn' was"
- ewarn "incorporated into dcraw and is automatically used now."
- elog ""
- elog "There's an example wrapper script included called 'dcwrap'."
- elog ""
- elog "This package also includes 'dcparse', which extracts"
- elog "thumbnail images (preferably JPEGs) from any raw digital"
- elog "camera formats that have them, and shows table contents."
- elog ""
-}
diff --git a/media-gfx/dcraw/dcraw-9.12.ebuild b/media-gfx/dcraw/dcraw-9.12.ebuild
deleted file mode 100644
index 463f4408c2ea..000000000000
--- a/media-gfx/dcraw/dcraw-9.12.ebuild
+++ /dev/null
@@ -1,125 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/dcraw/dcraw-9.12.ebuild,v 1.1 2012/06/11 08:56:10 xmw Exp $
-
-EAPI="2"
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="Converts the native (RAW) format of various digital cameras into netpbm portable pixmap (.ppm) image"
-HOMEPAGE="http://www.cybercom.net/~dcoffin/dcraw/"
-SRC_URI="http://www.cybercom.net/~dcoffin/dcraw/archive/${P}.tar.gz
- mirror://gentoo/parse-1.73.tar.bz2
- gimp? ( mirror://gentoo/rawphoto-1.32.tar.bz2 )"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
-IUSE="nls gimp jpeg jpeg2k lcms"
-
-COMMON_DEPEND="jpeg? ( virtual/jpeg )
- lcms? ( =media-libs/lcms-1* )
- jpeg2k? ( media-libs/jasper )
- gimp? ( media-gfx/gimp )"
-DEPEND="${COMMON_DEPEND}
- nls? ( sys-devel/gettext )
- gimp? ( virtual/pkgconfig )"
-RDEPEND="${COMMON_DEPEND}
- media-libs/netpbm"
-
-S=${WORKDIR}/dcraw
-
-LANGS="ca cs de da eo es fr hu it nl pl pt ru sv zh_CN zh_TW"
-
-for lng in ${LANGS}; do
- IUSE+=" linguas_${lng}"
-done
-
-# Helper function to list only langs listed in LANGS or
-linguas_list() {
- local nolangs=true
- for lng in ${LANGS}; do
- if use linguas_${lng}; then
- nolangs=false
- echo " ${lng}"
- fi
- done
- if ${nolangs}; then
- echo ${LANGS}
- fi
-}
-
-run_build() {
- einfo "${@}"
- ${@} || die
-}
-
-src_prepare() {
- rename dcraw_ dcraw. dcraw_*.1 || die "Failed to rename"
-}
-
-src_compile() {
- local ECFLAGS="-O2" # Without optimisation build fails
- local ELIBS="-lm"
-
- use lcms && ELIBS="-llcms ${ELIBS}" || ECFLAGS+=" -DNO_LCMS=yes"
- use jpeg && ELIBS="-ljpeg ${ELIBS}" || ECFLAGS+=" -DNO_JPEG=yes"
- use jpeg2k && ELIBS="-ljasper ${ELIBS}" || ECFLAGS+=" -DNO_JASPER=yes"
- use nls && ECFLAGS+=" -DLOCALEDIR=\"/usr/share/locale/\""
-
- run_build $(tc-getCC) ${ECFLAGS} ${CFLAGS} ${LDFLAGS} \
- -o dcraw dcraw.c ${ELIBS}
-
- run_build $(tc-getCC) -O2 ${CFLAGS} ${LDFLAGS} \
- -o dcparse parse.c
-
- # rawphoto gimp plugin
- if use gimp; then
- run_build $(tc-getCC) ${CFLAGS} ${LDFLAGS} \
- $(pkg-config --cflags gimpui-2.0) rawphoto.c -o rawphoto \
- $(pkg-config --libs gimpui-2.0)
- fi
-
- if use nls; then
- for lng in $(linguas_list); do
- run_build msgfmt -c -o dcraw_${lng}.mo dcraw_${lng}.po
- done
- fi
-}
-
-src_install() {
- dobin dcraw dcparse || die
- dodoc "${FILESDIR}"/{conversion-examples.txt,dcwrap} || die
-
- # rawphoto gimp plugin
- if use gimp; then
- insinto "$(pkg-config --variable=gimplibdir gimp-2.0)/plug-ins"
- insopts -m0755
- doins rawphoto || die
- fi
-
- doman dcraw.1 || die
- if use nls; then
- for lng in $(linguas_list); do
- [[ -f dcraw.${lng}.1 ]] && doman dcraw.${lng}.1
- insinto /usr/share/locale/${lng}/LC_MESSAGES
- newins dcraw_${lng}.mo dcraw.mo || die "failed to install dcraw_${lng}.mo"
- done
- fi
-}
-
-pkg_postinst() {
- elog ""
- elog "See conversion-examples.txt.gz on how to convert"
- elog "the PPM files produced by dcraw to other image formats."
- elog ""
- ewarn "The functionality of the external program 'fujiturn' was"
- ewarn "incorporated into dcraw and is automatically used now."
- elog ""
- elog "There's an example wrapper script included called 'dcwrap'."
- elog ""
- elog "This package also includes 'dcparse', which extracts"
- elog "thumbnail images (preferably JPEGs) from any raw digital"
- elog "camera formats that have them, and shows table contents."
- elog ""
-}
diff --git a/media-gfx/dcraw/dcraw-9.17.ebuild b/media-gfx/dcraw/dcraw-9.17.ebuild
index 0ccf7ab5db32..68934281c6a4 100644
--- a/media-gfx/dcraw/dcraw-9.17.ebuild
+++ b/media-gfx/dcraw/dcraw-9.17.ebuild
@@ -1,10 +1,9 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/dcraw/dcraw-9.17.ebuild,v 1.1 2013/01/24 09:57:21 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/dcraw/dcraw-9.17.ebuild,v 1.2 2013/10/15 19:03:04 pacho Exp $
-EAPI="2"
-
-inherit eutils toolchain-funcs
+EAPI=5
+inherit eutils readme.gentoo toolchain-funcs
DESCRIPTION="Converts the native (RAW) format of various digital cameras into netpbm portable pixmap (.ppm) image"
HOMEPAGE="http://www.cybercom.net/~dcoffin/dcraw/"
@@ -17,15 +16,19 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
IUSE="nls gimp jpeg jpeg2k lcms"
-COMMON_DEPEND="jpeg? ( virtual/jpeg )
- lcms? ( =media-libs/lcms-1* )
+COMMON_DEPEND="
+ jpeg? ( virtual/jpeg )
+ lcms? ( media-libs/lcms:0 )
jpeg2k? ( media-libs/jasper )
- gimp? ( media-gfx/gimp )"
+ gimp? ( media-gfx/gimp )
+"
DEPEND="${COMMON_DEPEND}
nls? ( sys-devel/gettext )
- gimp? ( virtual/pkgconfig )"
+ gimp? ( virtual/pkgconfig )
+"
RDEPEND="${COMMON_DEPEND}
- media-libs/netpbm"
+ media-libs/netpbm
+"
S=${WORKDIR}/dcraw
@@ -35,6 +38,19 @@ for lng in ${LANGS}; do
IUSE+=" linguas_${lng}"
done
+DOC_CONTENTS="
+ See conversion-examples.txt.gz on how to convert
+ the PPM files produced by dcraw to other image formats.\n
+
+ \nThe functionality of the external program 'fujiturn' was
+ incorporated into dcraw and is automatically used now.\n
+
+ \nThere's an example wrapper script included called 'dcwrap'.
+ This package also includes 'dcparse', which extracts
+ thumbnail images (preferably JPEGs) from any raw digital
+ camera formats that have them, and shows table contents.
+"
+
# Helper function to list only langs listed in LANGS or
linguas_list() {
local nolangs=true
@@ -88,17 +104,18 @@ src_compile() {
}
src_install() {
- dobin dcraw dcparse || die
- dodoc "${FILESDIR}"/{conversion-examples.txt,dcwrap} || die
+ dobin dcraw dcparse
+ dodoc "${FILESDIR}"/{conversion-examples.txt,dcwrap}
# rawphoto gimp plugin
if use gimp; then
insinto "$(pkg-config --variable=gimplibdir gimp-2.0)/plug-ins"
insopts -m0755
- doins rawphoto || die
+ doins rawphoto
fi
- doman dcraw.1 || die
+ doman dcraw.1
+
if use nls; then
for lng in $(linguas_list); do
[[ -f dcraw.${lng}.1 ]] && doman dcraw.${lng}.1
@@ -106,20 +123,6 @@ src_install() {
newins dcraw_${lng}.mo dcraw.mo || die "failed to install dcraw_${lng}.mo"
done
fi
-}
-pkg_postinst() {
- elog ""
- elog "See conversion-examples.txt.gz on how to convert"
- elog "the PPM files produced by dcraw to other image formats."
- elog ""
- ewarn "The functionality of the external program 'fujiturn' was"
- ewarn "incorporated into dcraw and is automatically used now."
- elog ""
- elog "There's an example wrapper script included called 'dcwrap'."
- elog ""
- elog "This package also includes 'dcparse', which extracts"
- elog "thumbnail images (preferably JPEGs) from any raw digital"
- elog "camera formats that have them, and shows table contents."
- elog ""
+ readme.gentoo_create_doc
}