summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-06-06 10:59:08 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-06-06 10:59:08 +0000
commit9db776a0e19f4587f740c43bd107feac6ba99c49 (patch)
tree71ea02276a149be090bd3292ba64654b318da9eb /media-gfx/dispcalgui
parentInitial version of PyPy (bug 300301). (diff)
downloadgentoo-2-9db776a0e19f4587f740c43bd107feac6ba99c49.tar.gz
gentoo-2-9db776a0e19f4587f740c43bd107feac6ba99c49.tar.bz2
gentoo-2-9db776a0e19f4587f740c43bd107feac6ba99c49.zip
Initial commit. Fixes bug #328603
(Portage version: 2.1.9.49/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx/dispcalgui')
-rw-r--r--media-gfx/dispcalgui/ChangeLog13
-rw-r--r--media-gfx/dispcalgui/dispcalgui-0.7.0.7.ebuild63
-rw-r--r--media-gfx/dispcalgui/metadata.xml18
3 files changed, 94 insertions, 0 deletions
diff --git a/media-gfx/dispcalgui/ChangeLog b/media-gfx/dispcalgui/ChangeLog
new file mode 100644
index 000000000000..e6f9c6f99793
--- /dev/null
+++ b/media-gfx/dispcalgui/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for media-gfx/dispcalgui
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/dispcalgui/ChangeLog,v 1.1 2011/06/06 10:59:08 hwoarang Exp $
+
+*dispcalgui-0.7.0.7 (06 Jun 2011)
+
+ 06 Jun 2011; Markos Chandras <hwoarang@gentoo.org>
+ +dispcalgui-0.7.0.7.ebuild, +metadata.xml:
+ Initial commit. Thanks to Bjoern Olausson, Richard and Marios Andreopoulos
+ for
+ the ebuilds. Marios will be the actual maintainer of this package. Fixes bug
+ 328603
+
diff --git a/media-gfx/dispcalgui/dispcalgui-0.7.0.7.ebuild b/media-gfx/dispcalgui/dispcalgui-0.7.0.7.ebuild
new file mode 100644
index 000000000000..34c4b7d03e20
--- /dev/null
+++ b/media-gfx/dispcalgui/dispcalgui-0.7.0.7.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/dispcalgui/dispcalgui-0.7.0.7.ebuild,v 1.1 2011/06/06 10:59:08 hwoarang Exp $
+
+EAPI="2"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils fdo-mime
+
+MY_PN="dispcalGUI"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Display Calibration and Characterization powered by Argyll CMS"
+HOMEPAGE="http://dispcalgui.hoech.net/"
+SRC_URI="http://dispcalgui.hoech.net/archive/${PV}/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=media-gfx/argyllcms-1.1.0
+ >=dev-python/wxpython-2.8.10.1
+ >=x11-libs/libX11-1.3.3
+ >=x11-apps/xrandr-1.3.2
+ >=x11-libs/libXxf86vm-1.1.0
+ >=x11-proto/xineramaproto-1.2
+ >=x11-libs/libXinerama-1.1"
+RDEPEND="${DEPEND}
+ >=dev-python/numpy-1.2.1"
+
+# Just in case someone renames the ebuild
+S=${WORKDIR}/${MY_P}
+
+DOCS=(
+ README.html
+)
+
+src_prepare() {
+# Prohibit setup from running xdg-* programs, resulting to sandbox violation
+ cd "${S}/dispcalGUI" || die "Cannot cd to source directory."
+ sed -e 's/if which(\"xdg-icon-resource\"):/if which(\"xdg-icon-resource-non-existant\"):/' \
+ -e 's/if which(\"xdg-desktop-menu\"):/if which(\"xdg-desktop-menu-non-existant\"):/' \
+ -i postinstall.py || die "sed'ing out the xdg-* setup functions failed"
+
+ distutils_src_prepare
+}
+
+pkg_postinst() {
+# Run xdg-* programs the Gentoo way since we removed this functionality from the original package
+ fdo-mime_mime_database_update
+ fdo-mime_desktop_database_update
+ distutils_pkg_postinst
+}
+
+pkg_postrm() {
+# Run xdg-* programs the Gentoo way since we removed this functionality from the original package
+ fdo-mime_mime_database_update
+ fdo-mime_desktop_database_update
+ distutils_pkg_postrm
+}
diff --git a/media-gfx/dispcalgui/metadata.xml b/media-gfx/dispcalgui/metadata.xml
new file mode 100644
index 000000000000..2ebcd753b3cf
--- /dev/null
+++ b/media-gfx/dispcalgui/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+<email>hwoarang@gentoo.org</email>
+<name>Markos Chandras</name>
+<description>Proxy maintainer. CC him on bugs</description>
+</maintainer>
+<maintainer>
+<email>opensource@andmarios.com</email>
+<name>Marios Andreopoulos</name>
+<description>Maintainer. Assign bugs to him</description>
+</maintainer>
+<longdescription lang="en">
+</longdescription>
+</pkgmetadata>
+