summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2014-05-08 18:50:54 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2014-05-08 18:50:54 +0000
commitcb9613b82a0f3ba8767728823d12b09ba79648d0 (patch)
tree605c352b729eaa3bdf6e9cfe27b9b65cff4ea576 /media-gfx/dispcalgui
parentNew HOMEPAGE (bug #509862 by John Stile). (diff)
downloadgentoo-2-cb9613b82a0f3ba8767728823d12b09ba79648d0.tar.gz
gentoo-2-cb9613b82a0f3ba8767728823d12b09ba79648d0.tar.bz2
gentoo-2-cb9613b82a0f3ba8767728823d12b09ba79648d0.zip
Version bump. Bug #493410
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 09BF4F54C2BA7F3C!)
Diffstat (limited to 'media-gfx/dispcalgui')
-rw-r--r--media-gfx/dispcalgui/ChangeLog10
-rw-r--r--media-gfx/dispcalgui/dispcalgui-2.0.0.0.ebuild74
-rw-r--r--media-gfx/dispcalgui/files/dispcalgui-2.0.0.0-wxversion-select.patch13
3 files changed, 96 insertions, 1 deletions
diff --git a/media-gfx/dispcalgui/ChangeLog b/media-gfx/dispcalgui/ChangeLog
index bc3500d9c164..be29316da75b 100644
--- a/media-gfx/dispcalgui/ChangeLog
+++ b/media-gfx/dispcalgui/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-gfx/dispcalgui
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/dispcalgui/ChangeLog,v 1.22 2014/03/04 20:10:14 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/dispcalgui/ChangeLog,v 1.23 2014/05/08 18:50:54 hwoarang Exp $
+
+*dispcalgui-2.0.0.0 (08 May 2014)
+
+ 08 May 2014; Markos Chandras <hwoarang@gentoo.org>
+ +dispcalgui-2.0.0.0.ebuild, +files/dispcalgui-2.0.0.0-wxversion-select.patch:
+ Version bump. Bug #493410. Thanks to Andreas Sturmlechner
+ <andreas.sturmlechner@gmail.com> and Marios Andreopoulos
+ <opensource@andmarios.com>
04 Mar 2014; Agostino Sarubbo <ago@gentoo.org> dispcalgui-1.2.7.0.ebuild:
Stable for x86, wrt bug #495696
diff --git a/media-gfx/dispcalgui/dispcalgui-2.0.0.0.ebuild b/media-gfx/dispcalgui/dispcalgui-2.0.0.0.ebuild
new file mode 100644
index 000000000000..7e0e81b855af
--- /dev/null
+++ b/media-gfx/dispcalgui/dispcalgui-2.0.0.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/dispcalgui/dispcalgui-2.0.0.0.ebuild,v 1.1 2014/05/08 18:50:54 hwoarang Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 fdo-mime eutils
+
+MY_PN="dispcalGUI"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Display Calibration and Characterization powered by Argyll CMS"
+HOMEPAGE="http://dispcalgui.hoech.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=media-gfx/argyllcms-1.1.0
+ dev-python/wxpython:2.8
+ >=x11-libs/libX11-1.3.3
+ >=x11-apps/xrandr-1.3.2
+ >=x11-libs/libXxf86vm-1.1.0
+ >=x11-proto/xineramaproto-1.2
+ >=x11-libs/libXinerama-1.1"
+RDEPEND="${DEPEND}
+ >=dev-python/numpy-1.2.1"
+
+# Just in case someone renames the ebuild
+S=${WORKDIR}/${MY_P}
+
+DOCS=(
+ README.html
+)
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-wxversion-select.patch"
+
+# Prohibit setup from running xdg-* programs, resulting to sandbox violation
+ cd "${S}/dispcalGUI" || die "Cannot cd to source directory."
+ sed -e 's/if which(\"xdg-icon-resource\"):/if which(\"xdg-icon-resource-non-existant\"):/' \
+ -e 's/if which(\"xdg-desktop-menu\"):/if which(\"xdg-desktop-menu-non-existant\"):/' \
+ -i postinstall.py || die "sed'ing out the xdg-* setup functions failed"
+
+# Remove deprecated Encoding key from .desktop file
+ cd "${S}" || die "Cannot cd to work directory."
+ for offendingFile in $(grep -r -l "Encoding=UTF-8" .); do
+ sed -e '/Encoding=UTF-8/d' -i "${offendingFile}" || \
+ die "removing deprecated Encoding key from .desktop files failed"
+ done
+
+ distutils-r1_src_prepare
+}
+
+src_install() {
+ distutils-r1_src_install
+ #remove udev files
+ rm -rf "${D}"/etc/udev/rules.d
+}
+
+pkg_postinst() {
+# Run xdg-* programs the Gentoo way since we removed this functionality from the original package
+ fdo-mime_mime_database_update
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+# Run xdg-* programs the Gentoo way since we removed this functionality from the original package
+ fdo-mime_mime_database_update
+ fdo-mime_desktop_database_update
+}
diff --git a/media-gfx/dispcalgui/files/dispcalgui-2.0.0.0-wxversion-select.patch b/media-gfx/dispcalgui/files/dispcalgui-2.0.0.0-wxversion-select.patch
new file mode 100644
index 000000000000..dd3815df68cb
--- /dev/null
+++ b/media-gfx/dispcalgui/files/dispcalgui-2.0.0.0-wxversion-select.patch
@@ -0,0 +1,13 @@
+--- dispcalGUI/main.py.orig 2014-03-04 20:44:41.266561455 +0200
++++ dispcalGUI/main.py 2014-03-04 20:44:24.194511770 +0200
+@@ -19,6 +19,10 @@ if pyver < py_minversion or pyver > py_m
+ ".".join(str(n) for n in py_maxversion),
+ sys.version.split()[0]))
+
++# Gentoo compatibility module
++import wxversion
++wxversion.select("2.8")
++
+ from config import (autostart_home, datahome, enc, exe, exe_ext, exedir,
+ exename, fs_enc, isapp, isexe, pydir, pyname, pypath,
+ runtype)