summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2004-03-03 16:12:13 +0000
committerMarinus Schraal <foser@gentoo.org>2004-03-03 16:12:13 +0000
commit2209b5c8ea3fda31dd74e9d28785be0bf36a0f8b (patch)
tree3baf958993f42bf5fec338c3bfe2ce6a53ce58fc /media-gfx/eog/eog-0.6-r4.ebuild
parentstable on sparc (Manifest recommit) (diff)
downloadgentoo-2-2209b5c8ea3fda31dd74e9d28785be0bf36a0f8b.tar.gz
gentoo-2-2209b5c8ea3fda31dd74e9d28785be0bf36a0f8b.tar.bz2
gentoo-2-2209b5c8ea3fda31dd74e9d28785be0bf36a0f8b.zip
fix several issues in 0.6 and cleanup
Diffstat (limited to 'media-gfx/eog/eog-0.6-r4.ebuild')
-rw-r--r--media-gfx/eog/eog-0.6-r4.ebuild30
1 files changed, 17 insertions, 13 deletions
diff --git a/media-gfx/eog/eog-0.6-r4.ebuild b/media-gfx/eog/eog-0.6-r4.ebuild
index dc0e26aa7ff9..915757d54a31 100644
--- a/media-gfx/eog/eog-0.6-r4.ebuild
+++ b/media-gfx/eog/eog-0.6-r4.ebuild
@@ -1,22 +1,23 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/eog/eog-0.6-r4.ebuild,v 1.9 2003/09/06 23:56:38 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/eog/eog-0.6-r4.ebuild,v 1.10 2004/03/03 16:12:13 foser Exp $
+
+GNOME_TARBALL_SUFFIX="gz"
+inherit gnome.org
IUSE="nls png jpeg"
-S=${WORKDIR}/${P}
DESCRIPTION="Eye of GNOME"
-SRC_URI="ftp://ftp.gnome.org/pub/GNOME/unstable/sources/eog/${P}.tar.gz"
HOMEPAGE="http://www.gnome.org/gnome-office/eog.shtml"
-SLOT="0"
+SLOT="1"
LICENSE="GPL-2"
KEYWORDS="x86 ppc"
DEPEND=">=gnome-base/gconf-1.0.4-r2
>=gnome-base/bonobo-1.0.9-r1
>=gnome-base/gnome-print-0.25i
- >=gnome-base/libglade-0.17
+ =gnome-base/libglade-0*
>=gnome-base/oaf-0.6.2
>=media-libs/gdk-pixbuf-0.16.0
=dev-libs/glib-1.2*
@@ -28,22 +29,25 @@ RDEPEND="${DEPEND}
nls? ( sys-devel/gettext
>=dev-util/intltool-0.11 )"
+src_unpack() {
-src_compile() {
+ unpack ${A}
- local myconf
+ cd ${S}/po
+ # Fix the makefile to use DESTDIR for locale dirs as well
+ epatch ${FILESDIR}/${P}-version_locale_dirs.patch
- use nls || myconf="--disable-nls"
+}
+
+src_compile() {
- econf ${myconf} || die
+ econf `use_enable nls` || die
emake || die
}
src_install() {
- make prefix=${D}/usr \
- sysconfdir=${D}/etc \
- localstatedir=/var/lib \
+ make DESTDIR=${D} \
GCONF_CONFIG_SOURCE="xml::${D}/etc/gconf/gconf.xml.defaults" \
install || die