summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2013-02-18 09:47:56 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2013-02-18 09:47:56 +0000
commitc9a694d15f4450f2a3f1bca59b952e6d5359233d (patch)
tree8ae40dce1ed733aabbf2ae5fa345f16a7b9b9910 /media-gfx/iscan-plugin-gt-f720
parentvdr-plugin.eclass, add eerror to get .eclass depricated (diff)
downloadgentoo-2-c9a694d15f4450f2a3f1bca59b952e6d5359233d.tar.gz
gentoo-2-c9a694d15f4450f2a3f1bca59b952e6d5359233d.tar.bz2
gentoo-2-c9a694d15f4450f2a3f1bca59b952e6d5359233d.zip
Version bump with new SRC_URI. Thanks to Jared in bug #455776.
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 1CD13C8AD4301342)
Diffstat (limited to 'media-gfx/iscan-plugin-gt-f720')
-rw-r--r--media-gfx/iscan-plugin-gt-f720/ChangeLog11
-rw-r--r--media-gfx/iscan-plugin-gt-f720/iscan-plugin-gt-f720-0.0.1.2.ebuild69
2 files changed, 77 insertions, 3 deletions
diff --git a/media-gfx/iscan-plugin-gt-f720/ChangeLog b/media-gfx/iscan-plugin-gt-f720/ChangeLog
index 1ad8957bb0cd..0670158053aa 100644
--- a/media-gfx/iscan-plugin-gt-f720/ChangeLog
+++ b/media-gfx/iscan-plugin-gt-f720/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-gfx/iscan-plugin-gt-f720
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/iscan-plugin-gt-f720/ChangeLog,v 1.4 2012/06/08 02:16:33 zmedico Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/iscan-plugin-gt-f720/ChangeLog,v 1.5 2013/02/18 09:47:56 flameeyes Exp $
+
+*iscan-plugin-gt-f720-0.0.1.2 (18 Feb 2013)
+
+ 18 Feb 2013; Diego E. Pettenò <flameeyes@gentoo.org>
+ +iscan-plugin-gt-f720-0.0.1.2.ebuild:
+ Version bump with new SRC_URI. Thanks to Jared in bug #455776.
08 Jun 2012; Zac Medico <zmedico@gentoo.org>
iscan-plugin-gt-f720-0.0.1.ebuild:
@@ -20,4 +26,3 @@
+iscan-plugin-gt-f720-0.0.1.ebuild:
Initial import from bug #274625. Ebuild contributed by W. Trevor King and
Will Lepofsky, thanks guys.
-
diff --git a/media-gfx/iscan-plugin-gt-f720/iscan-plugin-gt-f720-0.0.1.2.ebuild b/media-gfx/iscan-plugin-gt-f720/iscan-plugin-gt-f720-0.0.1.2.ebuild
new file mode 100644
index 000000000000..85f59165f2d2
--- /dev/null
+++ b/media-gfx/iscan-plugin-gt-f720/iscan-plugin-gt-f720-0.0.1.2.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/iscan-plugin-gt-f720/iscan-plugin-gt-f720-0.0.1.2.ebuild,v 1.1 2013/02/18 09:47:56 flameeyes Exp $
+
+EAPI="4"
+
+inherit multilib versionator rpm
+
+MY_PV="$(get_version_component_range 1-3)"
+MY_PVR="$(replace_version_separator 3 -)"
+MY_P="esci-interpreter-gt-f720-${MY_PVR}"
+
+DESCRIPTION="Epson Perfection V300 PHOTO scanner plugin for SANE 'epkowa' backend."
+HOMEPAGE="http://download.ebz.epson.net/dsc/search/01/search/?OSC=LX"
+SRC_URI="amd64? ( http://dev.gentoo.org/~flameeyes/avasys/${MY_P}.x86_64.rpm )
+ x86? ( http://dev.gentoo.org/~flameeyes/avasys/${MY_P}.i386.rpm )"
+
+LICENSE="AVASYS"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+
+IUSE=""
+IUSE_LINGUAS="ja"
+
+for X in ${IUSE_LINGUAS}; do IUSE="${IUSE} linguas_${X}"; done
+
+DEPEND=">=media-gfx/iscan-2.21.0"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"
+
+QA_PREBUILT="usr/lib64/esci/libesci-interpreter-gt-f720.so*"
+
+src_install() {
+ local MY_LIB="/usr/$(get_libdir)"
+
+ # install scanner firmware
+ insinto /usr/share/esci
+ doins "${WORKDIR}/usr/share/esci/"*
+
+ # install docs
+ if use linguas_ja; then
+ dodoc usr/share/doc/*/AVASYSPL.ja.txt
+ else
+ dodoc usr/share/doc/*/AVASYSPL.en.txt
+ fi
+
+ # install scanner plugins
+ insinto "${MY_LIB}/esci"
+ INSOPTIONS="-m0755"
+ doins "${WORKDIR}/usr/$(get_libdir)/esci/"*
+}
+
+pkg_postinst() {
+ local MY_LIB="/usr/$(get_libdir)"
+
+ # Needed for scaner to work properly.
+ iscan-registry --add interpreter usb 0x04b8 0x0131 "${MY_LIB}/esci/libesci-interpreter-gt-f720 /usr/share/esci/esfw8b.bin"
+ elog
+ elog "Firmware file esfw8b.bin for Epson Perfection V300 PHOTO"
+ elog "has been installed in /usr/share/esci and registered for use."
+ elog
+}
+
+pkg_prerm() {
+ local MY_LIB="/usr/$(get_libdir)"
+
+ iscan-registry --remove interpreter usb 0x04b8 0x0131 "${MY_LIB}/esci/libesci-interpreter-gt-f720 /usr/share/esci/esfw8b.bin"
+}