summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-04-04 07:50:09 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-04-04 07:50:09 +0000
commitc2933ee266aef0d5b6854d25aff02341cb628991 (patch)
tree1783cbfaecda2166c8a62f0ffb592c2b1d0f5ba9 /media-gfx/mypaint
parentarm/sparc stable (bug 337160) (diff)
downloadgentoo-2-c2933ee266aef0d5b6854d25aff02341cb628991.tar.gz
gentoo-2-c2933ee266aef0d5b6854d25aff02341cb628991.tar.bz2
gentoo-2-c2933ee266aef0d5b6854d25aff02341cb628991.zip
Version bump. Bug #361711
(Portage version: 2.1.9.44/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx/mypaint')
-rw-r--r--media-gfx/mypaint/ChangeLog8
-rw-r--r--media-gfx/mypaint/files/mypaint-0.9.1-gentoo.patch25
-rw-r--r--media-gfx/mypaint/mypaint-0.9.1.ebuild53
3 files changed, 85 insertions, 1 deletions
diff --git a/media-gfx/mypaint/ChangeLog b/media-gfx/mypaint/ChangeLog
index 25a987608baf..407d2ae8e5a5 100644
--- a/media-gfx/mypaint/ChangeLog
+++ b/media-gfx/mypaint/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-gfx/mypaint
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/mypaint/ChangeLog,v 1.6 2011/03/13 16:06:33 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/mypaint/ChangeLog,v 1.7 2011/04/04 07:50:09 hwoarang Exp $
+
+*mypaint-0.9.1 (04 Apr 2011)
+
+ 04 Apr 2011; Markos Chandras <hwoarang@gentoo.org> +mypaint-0.9.1.ebuild,
+ +files/mypaint-0.9.1-gentoo.patch:
+ Version bump. Bug #361711
13 Mar 2011; Markos Chandras <hwoarang@gentoo.org> mypaint-0.9.0.ebuild:
Stable on amd64 wrt bug #358579
diff --git a/media-gfx/mypaint/files/mypaint-0.9.1-gentoo.patch b/media-gfx/mypaint/files/mypaint-0.9.1-gentoo.patch
new file mode 100644
index 000000000000..9c0f884d752a
--- /dev/null
+++ b/media-gfx/mypaint/files/mypaint-0.9.1-gentoo.patch
@@ -0,0 +1,25 @@
+Index: mypaint-0.9.1/SConstruct
+===================================================================
+--- mypaint-0.9.1.orig/SConstruct
++++ mypaint-0.9.1/SConstruct
+@@ -70,6 +70,20 @@ if env.get('CPPDEFINES'):
+ if env['debug']:
+ env.Append(CPPDEFINES='HEAVY_DEBUG')
+ env.Append(CCFLAGS='-O0', LINKFLAGS='-O0')
++# Respect cxxflags,ldflags and cxx
++# Code found on
++# http://http://dev.gentoo.org/~vapier/scons-blows.txt
++import SCons.Util
++if os.environ.has_key('CC'):
++ env['CC'] = os.environ['CC']
++if os.environ.has_key('CFLAGS'):
++ env['CCFLAGS'] += SCons.Util.CLVar(os.environ['CFLAGS'])
++if os.environ.has_key('CXX'):
++ env['CXX'] = os.environ['CXX']
++if os.environ.has_key('CXXFLAGS'):
++ env['CXXFLAGS'] += SCons.Util.CLVar(os.environ['CXXFLAGS'])
++if os.environ.has_key('LDFLAGS'):
++ env['LINKFLAGS'] += SCons.Util.CLVar(os.environ['LDFLAGS'])
+
+ Export('env', 'python')
+ module = SConscript('lib/SConscript')
diff --git a/media-gfx/mypaint/mypaint-0.9.1.ebuild b/media-gfx/mypaint/mypaint-0.9.1.ebuild
new file mode 100644
index 000000000000..001a743e00c6
--- /dev/null
+++ b/media-gfx/mypaint/mypaint-0.9.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/mypaint/mypaint-0.9.1.ebuild,v 1.1 2011/04/04 07:50:09 hwoarang Exp $
+
+EAPI=2
+
+inherit eutils fdo-mime multilib scons-utils toolchain-funcs
+
+DESCRIPTION="fast and easy graphics application for digital painters"
+HOMEPAGE="http://mypaint.intilinux.com/"
+SRC_URI="http://download.gna.org/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/pygtk
+ dev-python/numpy
+ >=dev-python/pycairo-1.4
+ >=dev-lang/python-2.4
+ <dev-lang/python-3
+ dev-libs/protobuf[python]"
+DEPEND="${RDEPEND}
+ >=dev-util/scons-1.0
+ dev-lang/swig"
+
+src_prepare() {
+ # multilib support
+ sed -i -e "s:lib\/${PN}:$(get_libdir)\/${PN}:" "${S}"/SConstruct || die
+ # respect CXXFLAGS,CXX,LDFLAGS
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+}
+
+src_compile() {
+ #workaround scons bug with locales. Bug #352700
+ export LANG="en_US.UTF-8"
+ tc-export CXX
+ escons || die "scons failed"
+}
+
+src_install () {
+ escons prefix="${D}/usr" install || die "scons install failed"
+ newicon pixmaps/${PN}_logo.png ${PN}.png
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}