summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-05-28 09:21:33 +0000
committerTim Harder <radhermit@gentoo.org>2011-05-28 09:21:33 +0000
commitde8ba473238356bfe1be88edbffa129aa59e4dd1 (patch)
treeced96944a25ec6593b211cef182dd24e1c80ccd3 /media-gfx/structure-synth
parentx86 stable per bug 366663 (diff)
downloadgentoo-2-de8ba473238356bfe1be88edbffa129aa59e4dd1.tar.gz
gentoo-2-de8ba473238356bfe1be88edbffa129aa59e4dd1.tar.bz2
gentoo-2-de8ba473238356bfe1be88edbffa129aa59e4dd1.zip
Initial import.
(Portage version: 2.2.0_alpha37/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx/structure-synth')
-rw-r--r--media-gfx/structure-synth/ChangeLog10
-rw-r--r--media-gfx/structure-synth/metadata.xml5
-rw-r--r--media-gfx/structure-synth/structure-synth-1.5.0.ebuild39
3 files changed, 54 insertions, 0 deletions
diff --git a/media-gfx/structure-synth/ChangeLog b/media-gfx/structure-synth/ChangeLog
new file mode 100644
index 000000000000..3035243bbd94
--- /dev/null
+++ b/media-gfx/structure-synth/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for media-gfx/structure-synth
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/structure-synth/ChangeLog,v 1.1 2011/05/28 09:21:33 radhermit Exp $
+
+*structure-synth-1.5.0 (28 May 2011)
+
+ 28 May 2011; Tim Harder <radhermit@gentoo.org> +structure-synth-1.5.0.ebuild,
+ +metadata.xml:
+ Initial import.
+
diff --git a/media-gfx/structure-synth/metadata.xml b/media-gfx/structure-synth/metadata.xml
new file mode 100644
index 000000000000..9be90a258970
--- /dev/null
+++ b/media-gfx/structure-synth/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>graphics</herd>
+</pkgmetadata>
diff --git a/media-gfx/structure-synth/structure-synth-1.5.0.ebuild b/media-gfx/structure-synth/structure-synth-1.5.0.ebuild
new file mode 100644
index 000000000000..06f90dff5c41
--- /dev/null
+++ b/media-gfx/structure-synth/structure-synth-1.5.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/structure-synth/structure-synth-1.5.0.ebuild,v 1.1 2011/05/28 09:21:33 radhermit Exp $
+
+EAPI=4
+
+inherit eutils qt4-r2
+
+MY_P="StructureSynth-Source-v${PV}"
+DESCRIPTION="A program to generate 3D structures by specifying a design grammar"
+HOMEPAGE="http://structuresynth.sourceforge.net/"
+SRC_URI="mirror://sourceforge/structuresynth/${MY_P}.zip"
+
+LICENSE="|| ( LGPL-2.1 GPL-3 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="virtual/opengl
+ x11-libs/qt-core:4
+ x11-libs/qt-gui:4
+ x11-libs/qt-opengl:4
+ x11-libs/qt-script:4"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S="${WORKDIR}/Structure Synth Source Code"
+
+src_prepare() {
+ qmake -project -o ${PN}.pro -after "CONFIG+=opengl" \
+ -after "QT+=xml opengl script" || die "qmake failed"
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc roadmap.txt changelog.txt bugs.txt
+ domenu ${PN}.desktop
+ newicon images/structuresynth.png ${PN}.png
+}