summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-05-06 09:14:56 +0000
committerJustin Lecher <jlec@gentoo.org>2013-05-06 09:14:56 +0000
commite5019532e4bee8a1e3b7cf266642cb44d888d2c3 (patch)
tree6293af3ddc8354ecba6ccb49c3aa3435ac38cdd8 /media-gfx/uniconvertor/uniconvertor-1.1.5-r1.ebuild
parentRemove old versions. (diff)
downloadgentoo-2-e5019532e4bee8a1e3b7cf266642cb44d888d2c3.tar.gz
gentoo-2-e5019532e4bee8a1e3b7cf266642cb44d888d2c3.tar.bz2
gentoo-2-e5019532e4bee8a1e3b7cf266642cb44d888d2c3.zip
media-gfx/uniconvertor: Bump to distutils-r1.eclass, #466352; thanks Nikoli for a first patch
(Portage version: 2.2.0_alpha174/cvs/Linux x86_64, signed Manifest commit with key 8009D6F070EB7916)
Diffstat (limited to 'media-gfx/uniconvertor/uniconvertor-1.1.5-r1.ebuild')
-rw-r--r--media-gfx/uniconvertor/uniconvertor-1.1.5-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/media-gfx/uniconvertor/uniconvertor-1.1.5-r1.ebuild b/media-gfx/uniconvertor/uniconvertor-1.1.5-r1.ebuild
new file mode 100644
index 000000000000..e1c975e51f1d
--- /dev/null
+++ b/media-gfx/uniconvertor/uniconvertor-1.1.5-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/uniconvertor/uniconvertor-1.1.5-r1.ebuild,v 1.1 2013/05/06 09:14:56 jlec Exp $
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_5,2_6,2_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Commandline tool for popular vector formats convertion"
+HOMEPAGE="http://sk1project.org/modules.php?name=Products&product=uniconvertor"
+SRC_URI="http://uniconvertor.googlecode.com/files/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~x64-macos ~sparc-solaris ~x86-solaris"
+SLOT="0"
+LICENSE="GPL-2 LGPL-2"
+IUSE=""
+
+DEPEND=">=media-libs/sk1libs-0.9.1[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+ app-text/ghostscript-gpl"
+
+PATCHES=( "${FILESDIR}/uniconvertor-1.1.5_export_raster.py_fix_import.patch" )
+
+python_prepare_all() {
+ sed -i \
+ -e "s/'GNU_GPL_v2', 'GNU_LGPL_v2', 'COPYRIGHTS',//" \
+ setup.py || die
+
+ distutils-r1_python_prepare_all
+}