summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-02-15 04:21:58 +0000
committerMike Frysinger <vapier@gentoo.org>2015-02-15 04:21:58 +0000
commit67bbbd5332774b947e16e8accd729123c4fec5a1 (patch)
tree6ac14a43223c02d5b1437d7a22b8d336fb193d52 /media-gfx
parentRemove the need for git-r3 since there is a valid archive path (diff)
downloadgentoo-2-67bbbd5332774b947e16e8accd729123c4fec5a1.tar.gz
gentoo-2-67bbbd5332774b947e16e8accd729123c4fec5a1.tar.bz2
gentoo-2-67bbbd5332774b947e16e8accd729123c4fec5a1.zip
Backport libtool logic from newer versions to fix building with newer autotools #539032 by Jeff.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/graphviz/ChangeLog7
-rw-r--r--media-gfx/graphviz/files/graphviz-2.26.3-libtool-configure.patch52
-rw-r--r--media-gfx/graphviz/graphviz-2.26.3-r4.ebuild9
3 files changed, 63 insertions, 5 deletions
diff --git a/media-gfx/graphviz/ChangeLog b/media-gfx/graphviz/ChangeLog
index 37cc1963ced3..986ca741c04c 100644
--- a/media-gfx/graphviz/ChangeLog
+++ b/media-gfx/graphviz/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/graphviz
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphviz/ChangeLog,v 1.282 2015/02/15 02:18:59 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphviz/ChangeLog,v 1.283 2015/02/15 04:21:58 vapier Exp $
+
+ 15 Feb 2015; Mike Frysinger <vapier@gentoo.org>
+ +files/graphviz-2.26.3-libtool-configure.patch, graphviz-2.26.3-r4.ebuild:
+ Backport libtool logic from newer versions to fix building with newer
+ autotools #539032 by Jeff.
15 Feb 2015; Mike Frysinger <vapier@gentoo.org> graphviz-2.26.3-r3.ebuild,
graphviz-2.26.3-r4.ebuild:
diff --git a/media-gfx/graphviz/files/graphviz-2.26.3-libtool-configure.patch b/media-gfx/graphviz/files/graphviz-2.26.3-libtool-configure.patch
new file mode 100644
index 000000000000..142aea2843fd
--- /dev/null
+++ b/media-gfx/graphviz/files/graphviz-2.26.3-libtool-configure.patch
@@ -0,0 +1,52 @@
+backport newer libtool logic
+
+https://bugs.gentoo.org/539032
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -464,28 +464,15 @@
+ dnl -----------------------------------
+ dnl libtool ltdl on-demand plugin loading
+
+-m4_ifdef([LT_INIT],
+- [ #code that is for Libtool 2.x
+-AM_PROG_LIBTOOL
+- ],
+- [ #code that is for 1.5.x
+- ])
++LT_INIT([dlopen])
++LT_CONFIG_LTDL_DIR([libltdl])
++LTDL_INIT
++
+ AC_ARG_ENABLE(ltdl,
+ [AS_HELP_STRING([--enable-ltdl],[support on-demand plugin loading])])
+ if test "x$enable_ltdl" != "xno"; then
+ AC_DEFINE(ENABLE_LTDL,1,[Define if you want on-demand plugin loading])
+- AC_LIBTOOL_DLOPEN
+-m4_ifdef([LT_INIT],
+- [ #code that is for Libtool 2.x
+- LT_CONFIG_LTDL_DIR([libltdl])
+- LTDL_INIT
+- ],
+- [ #code that is for 1.5.x
+- AC_CONFIG_SUBDIRS([libltdl])
+- ])
+ use_ltdl="Yes"
+-
+- AC_LIBLTDL_CONVENIENCE
+ if test "x$DARWIN9" = "xyes"; then
+ LIBLTDL_LDFLAGS="-Wl,-unexported_symbol,_lt_*"
+ fi
+@@ -494,12 +483,6 @@
+ AC_SUBST(INCLTDL)
+ AC_SUBST(LIBLTDL)
+ AC_SUBST(LIBLTDL_LDFLAGS)
+-m4_ifdef([LT_INIT],
+- [ #code that is for Libtool 2.x
+- ],
+- [ #code that is for 1.5.x
+-AM_PROG_LIBTOOL
+- ])
+
+ # Checks for libraries.
+ #AC_CHECK_LIB([ICE], [main])
diff --git a/media-gfx/graphviz/graphviz-2.26.3-r4.ebuild b/media-gfx/graphviz/graphviz-2.26.3-r4.ebuild
index 1affe207b3f6..cac27cf0efb1 100644
--- a/media-gfx/graphviz/graphviz-2.26.3-r4.ebuild
+++ b/media-gfx/graphviz/graphviz-2.26.3-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphviz/graphviz-2.26.3-r4.ebuild,v 1.15 2015/02/15 02:18:59 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphviz/graphviz-2.26.3-r4.ebuild,v 1.16 2015/02/15 04:21:58 vapier Exp $
EAPI=3
PYTHON_DEPEND="python? 2"
@@ -107,6 +107,7 @@ pkg_setup() {
src_prepare() {
epatch \
"${FILESDIR}"/${P}-libtool.patch \
+ "${FILESDIR}"/${P}-libtool-configure.patch \
"${FILESDIR}"/${P}-automake-1.11.2.patch
# ToDo: Do the same thing for examples and/or
@@ -118,9 +119,9 @@ src_prepare() {
fi
# This is an old version of libtool
+ # use the ./configure option to exclude its use, and
+ # delete the dir since we don't need to eautoreconf it
rm -rf libltdl
- sed -i -e '/libltdl/d' configure.ac || die
- sed -i -e 's/AC_LIBLTDL_CONVENIENCE/AC_LIBLTDL_INSTALLABLE/' configure.ac || die
# no nls, no gettext, no iconv macro, so disable it
use nls || { sed -i -e '/^AM_ICONV/d' configure.ac || die; }
@@ -139,7 +140,7 @@ src_prepare() {
src_configure() {
# libtool file collision, bug 276609
- local myconf="--disable-ltdl-install"
+ local myconf="--without-included-ltdl --disable-ltdl-install"
# Core functionality:
# All of X, cairo-output, gtk need the pango+cairo functionality