summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2002-01-30 18:08:27 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2002-01-30 18:08:27 +0000
commita8a29ae2c7007a0672576654d94df8656059c2b0 (patch)
tree6275adc4652c8cceda803a2184f62466a7f65bda /media-gfx
parentSuperceded by 0.8.7 (diff)
downloadgentoo-2-a8a29ae2c7007a0672576654d94df8656059c2b0.tar.gz
gentoo-2-a8a29ae2c7007a0672576654d94df8656059c2b0.tar.bz2
gentoo-2-a8a29ae2c7007a0672576654d94df8656059c2b0.zip
Already added
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/k3studio/k3studio-0.97.ebuild23
1 files changed, 20 insertions, 3 deletions
diff --git a/media-gfx/k3studio/k3studio-0.97.ebuild b/media-gfx/k3studio/k3studio-0.97.ebuild
index 6f84bb01b374..80f1b669fb9e 100644
--- a/media-gfx/k3studio/k3studio-0.97.ebuild
+++ b/media-gfx/k3studio/k3studio-0.97.ebuild
@@ -1,18 +1,35 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Bart Verwilst <verwilst@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/k3studio/k3studio-0.97.ebuild,v 1.1 2002/01/25 17:02:58 verwilst Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/k3studio/k3studio-0.97.ebuild,v 1.2 2002/01/30 18:08:27 karltk Exp $
. /usr/portage/eclass/inherit.eclass || die
inherit kde-base || die
need-kde 2.1
-newdepend ">=dev-lang/python-2.1
+newdepend "=dev-lang/python-2.0*
>=media-libs/glut-3.7
>=sys-libs/readline-4.1
- >=media-libs/freetype-2.0.5"
+ >=media-libs/freetype-2.0.5
+ >=media-libs/qhull-3.1
+ "
+# >=media-libs/gle
+# >=media-libs/nurbs++
+# >=media-libs/libvrml97
+# >=media-libs/gltt
DESCRIPTION="KDE universal workbench for 2D/3D modeling, visualization and simulation."
SRC_URI="http://prdownloads.sourceforge.net/k3studio/k3studio-0.97.tar.gz"
HOMEPAGE="http://k3studio.sourceforge.net"
+src_compile() {
+ myconf="--with-qhull-includes=/usr/include/qhull"
+ myconf="$myconf --with-qhull-libraries=/usr/lib"
+ myconf="$myconf --with-python-includes=/usr/include/python2.0"
+ myconf="$myconf --with-python-libraries=\\\"-L. -L/usr/lib/python2.0/config `python-config`\\\""
+
+ echo $myconf
+ kde_src_compile myconf
+ kde_src_compile configure
+ kde_src_compile make
+}