summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-12-26 14:38:11 +0000
committerJustin Lecher <jlec@gentoo.org>2012-12-26 14:38:11 +0000
commitc29967f11eabc4028c760bd4c3bec7b6a76f1258 (patch)
tree8a211e201ed70b8751047cc5decae34d118a0d88 /media-libs/SoQt/SoQt-1.5.0-r1.ebuild
parentVersion bump, wrt bug #447824. (diff)
downloadgentoo-2-c29967f11eabc4028c760bd4c3bec7b6a76f1258.tar.gz
gentoo-2-c29967f11eabc4028c760bd4c3bec7b6a76f1258.tar.bz2
gentoo-2-c29967f11eabc4028c760bd4c3bec7b6a76f1258.zip
media-libs/SoQt: Drop old; move to EAPI=5 and autotools-utils.eclass
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key 8009D6F070EB7916)
Diffstat (limited to 'media-libs/SoQt/SoQt-1.5.0-r1.ebuild')
-rw-r--r--media-libs/SoQt/SoQt-1.5.0-r1.ebuild40
1 files changed, 19 insertions, 21 deletions
diff --git a/media-libs/SoQt/SoQt-1.5.0-r1.ebuild b/media-libs/SoQt/SoQt-1.5.0-r1.ebuild
index 52489d088906..96b5f4a5e3ef 100644
--- a/media-libs/SoQt/SoQt-1.5.0-r1.ebuild
+++ b/media-libs/SoQt/SoQt-1.5.0-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/SoQt/SoQt-1.5.0-r1.ebuild,v 1.4 2012/05/05 08:02:33 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/SoQt/SoQt-1.5.0-r1.ebuild,v 1.5 2012/12/26 14:38:11 jlec Exp $
-EAPI="2"
+EAPI=5
-inherit base
+inherit autotools-utils
DESCRIPTION="The glue between Coin3D and Qt"
SRC_URI="http://ftp.coin3d.org/coin/src/all/${P}.tar.gz"
@@ -34,27 +34,25 @@ PATCHES=(
DOCS=(AUTHORS ChangeLog FAQ HACKING NEWS README)
src_configure() {
- econf \
- htmldir="/usr/share/doc/${PF}/html" \
- --disable-compact \
- --disable-html-help \
- --disable-loadlibrary \
- --disable-man \
- --enable-pkgconfig \
- --includedir="/usr/include/coin" \
- --with-coin \
- $(use_enable debug) \
- $(use_enable debug symbols) \
- $(use_enable doc html) \
- $(use_enable static-libs static)
+ local myeconfargs=(
+ htmldir="/usr/share/doc/${PF}/html"
+ --disable-compact
+ --disable-html-help
+ --disable-loadlibrary
+ --disable-man
+ --enable-pkgconfig
+ --includedir="/usr/include/coin"
+ --with-coin
+ $(use_enable debug)
+ $(use_enable debug symbols)
+ $(use_enable doc html)
+ )
+ autotools-utils_src_configure
}
src_install() {
# Remove SoQt from Libs.private
- sed -e '/Libs.private/s/ -lSoQt//' -i SoQt.pc || die
+ sed -e '/Libs.private/s/ -lSoQt//' -i "${BUILD_DIR}"/SoQt.pc || die
- base_src_install
-
- # Remove libtool files when not needed.
- use static-libs || rm -f "${D}"/usr/lib*/*.la
+ autotools-utils_src_install
}