summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2010-02-26 21:41:15 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2010-02-26 21:41:15 +0000
commit173f09c0a69aabb2fd5deb12033d53f993e51980 (patch)
treec052e645ecdabc600e1e2e72d33fb8665a414be0 /media-libs/clutter
parentVersion Bump (diff)
downloadgentoo-2-173f09c0a69aabb2fd5deb12033d53f993e51980.tar.gz
gentoo-2-173f09c0a69aabb2fd5deb12033d53f993e51980.tar.bz2
gentoo-2-173f09c0a69aabb2fd5deb12033d53f993e51980.zip
Initial ebuild for clutter, an opengl-based toolkit for user interfaces
(Portage version: 2.1.7.17/cvs/Linux i686)
Diffstat (limited to 'media-libs/clutter')
-rw-r--r--media-libs/clutter/ChangeLog11
-rw-r--r--media-libs/clutter/clutter-1.0.10.ebuild89
-rw-r--r--media-libs/clutter/files/clutter-1.0.0-disable-tests.patch53
-rw-r--r--media-libs/clutter/metadata.xml12
4 files changed, 165 insertions, 0 deletions
diff --git a/media-libs/clutter/ChangeLog b/media-libs/clutter/ChangeLog
new file mode 100644
index 000000000000..24f9165d8d4e
--- /dev/null
+++ b/media-libs/clutter/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for media-libs/clutter
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/clutter/ChangeLog,v 1.1 2010/02/26 21:41:15 nirbheek Exp $
+
+*clutter-1.0.10 (26 Feb 2010)
+
+ 26 Feb 2010; Nirbheek Chauhan <nirbheek@gentoo.org>
+ +files/clutter-1.0.0-disable-tests.patch, +clutter-1.0.10.ebuild,
+ +metadata.xml:
+ Initial ebuild for clutter, an opengl-based toolkit for user interfaces
+
diff --git a/media-libs/clutter/clutter-1.0.10.ebuild b/media-libs/clutter/clutter-1.0.10.ebuild
new file mode 100644
index 000000000000..5eaee9b569c2
--- /dev/null
+++ b/media-libs/clutter/clutter-1.0.10.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/clutter/clutter-1.0.10.ebuild,v 1.1 2010/02/26 21:41:15 nirbheek Exp $
+
+EAPI="2"
+
+inherit autotools clutter
+
+DESCRIPTION="Clutter is a library for creating graphical user interfaces"
+
+SLOT="1.0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc +gtk introspection +opengl"
+
+RDEPEND=">=dev-libs/glib-2.16
+ >=x11-libs/cairo-1.4
+ >=x11-libs/pango-1.20
+
+ gtk? ( >=x11-libs/gtk+-2.0 )
+ opengl? (
+ virtual/opengl
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXdamage
+ x11-libs/libXi
+ x11-proto/inputproto
+
+ >=x11-libs/libXfixes-3
+ >=x11-libs/libXcomposite-0.4 )
+ !opengl? ( media-libs/libsdl )
+"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ dev-util/gtk-doc-am
+ doc? (
+ >=dev-util/gtk-doc-1.11
+ >=app-text/docbook-sgml-utils-0.6.14[jadetex]
+ app-text/xmlto )
+ introspection? (
+ >=dev-libs/gobject-introspection-0.6.4
+ >=dev-libs/gir-repository-0.6.3[pango] )"
+
+src_configure() {
+ local myconf=""
+
+ if use opengl; then
+ elog "Using GLX for OpenGL backend"
+ myconf="${myconf} --with-flavour=glx"
+ else
+ elog "Using SDL for OpenGL backend"
+ myconf="${myconf} --with-flavour=sdl"
+ ewarn "You have disabled OpenGL, do not report bugs about breakage"
+ fi
+
+ if use gtk; then
+ myconf="${myconf} --with-imagebackend=gdk-pixbuf"
+ else
+ myconf="${myconf} --with-imagebackend=internal"
+ # Internal image backend is experimental
+ ewarn "You have selected the experimental internal image backend"
+ fi
+
+ if ! use debug; then
+ myconf="${myconf}
+ --enable-debug=minimum
+ --enable-cogl-debug=minimum"
+ fi
+
+ # FIXME: Tests are interactive, not of use for us
+ # FIXME: Using external json-glib breaks introspection
+ myconf="${myconf}
+ --disable-tests
+ --enable-maintainer-flags=no
+ --enable-xinput
+ --with-json=internal
+ $(use_enable introspection)
+ $(use_enable doc manual)"
+ econf ${myconf}
+}
+
+src_prepare() {
+ # Make it libtool-1 compatible
+ rm -v build/autotools/lt* build/autotools/libtool.m4 || die "removing libtool macros failed"
+
+ # FIXME: Tests are interactive, not of use for us
+ epatch "${FILESDIR}/${PN}-1.0.0-disable-tests.patch"
+
+ eautoreconf
+}
diff --git a/media-libs/clutter/files/clutter-1.0.0-disable-tests.patch b/media-libs/clutter/files/clutter-1.0.0-disable-tests.patch
new file mode 100644
index 000000000000..d47855d0b1fd
--- /dev/null
+++ b/media-libs/clutter/files/clutter-1.0.0-disable-tests.patch
@@ -0,0 +1,53 @@
+Interactive Tests.
+
+http://bugzilla.o-hand.com/show_bug.cgi?id=1618
+
+--
+--- configure.ac
++++ configure.ac
+@@ -718,6 +718,18 @@
+
+ AM_CONDITIONAL(ENABLE_MANUAL, [test "x$enable_manual" = "xyes"])
+
++dnl = tests ================================================================
++AC_ARG_ENABLE(tests,
++ AS_HELP_STRING([--enable-tests],[Enable building of tests and examples]),
++ [case "${enableval}" in
++ yes) ENABLE_TESTS=yes ;;
++ no) ENABLE_TESTS=no ;;
++ *) AC_MSG_ERROR(bad value ${enableval} for --enable-tests) ;;
++ esac],
++ [ENABLE_TESTS=no])
++
++AM_CONDITIONAL([ENABLE_TESTS], [test "x$ENABLE_TESTS" = "xyes"])
++
+ dnl === I18N ==================================================================
+
+ GETTEXT_PACKAGE="clutter-$CLUTTER_API_VERSION"
+@@ -803,6 +815,7 @@
+ echo " Compiler flags: ${CPPFLAGS} ${MAINTAINER_CFLAGS}"
+ echo " Build API documentation: ${enable_gtk_doc}"
+ echo " Build manual documentation: ${enable_manual}"
++echo " Enable tests: ${enable_tests}"
+ echo " Build introspection data: ${enable_introspection}"
+ echo ""
+
+--- Makefile.am
++++ Makefile.am
+@@ -1,11 +1,15 @@
+ NULL =
+
+-SUBDIRS = build clutter tests po
++SUBDIRS = build clutter po
+
+ if BUILD_GTK_DOC
+ SUBDIRS += doc
+ endif
+
++if ENABLE_TESTS
++SUBDIRS += tests
++endif
++
+ DIST_SUBDIRS = build clutter tests doc po
+
+ ACLOCAL_AMFLAGS = -I build/autotools
diff --git a/media-libs/clutter/metadata.xml b/media-libs/clutter/metadata.xml
new file mode 100644
index 000000000000..d116e9a19e27
--- /dev/null
+++ b/media-libs/clutter/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+<use>
+ <flag name="gtk">Use gdk-pixbuf from <pkg>x11-libs/gtk+</pkg> as image rendering backend</flag>
+ <flag name="introspection">Use <pkg>dev-libs/gobject-introspection</pkg> for
+ introspection</flag>
+ <flag name="opengl">Use <pkg>virtual/opengl</pkg> as the backend for
+ rendering (default). If disabled, <pkg>media-libs/libsdl</pkg> is used.</flag>
+</use>
+</pkgmetadata>