summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2007-11-20 18:46:24 +0000
committerAlexis Ballier <aballier@gentoo.org>2007-11-20 18:46:24 +0000
commit5102b5c3719036fee57c7b7ceb27bf43b1b98007 (patch)
tree4477c7864e9d1ced770e6f776df7951ceef1d28b /media-libs/faad2
parentalpha/ia64/sparc stable wrt #199693 (diff)
downloadgentoo-2-5102b5c3719036fee57c7b7ceb27bf43b1b98007.tar.gz
gentoo-2-5102b5c3719036fee57c7b7ceb27bf43b1b98007.tar.bz2
gentoo-2-5102b5c3719036fee57c7b7ceb27bf43b1b98007.zip
bump it now that the license issues are resolved, force abi number to be bumped because all symbols have been renamed, upstream has been informed but not very responsive which kinda sucks
(Portage version: 2.1.3.19)
Diffstat (limited to 'media-libs/faad2')
-rw-r--r--media-libs/faad2/ChangeLog10
-rw-r--r--media-libs/faad2/faad2-2.6.1.ebuild42
-rw-r--r--media-libs/faad2/files/digest-faad2-2.6.13
-rw-r--r--media-libs/faad2/files/faad2-2.6.1-abi_has_changed.patch14
4 files changed, 68 insertions, 1 deletions
diff --git a/media-libs/faad2/ChangeLog b/media-libs/faad2/ChangeLog
index f6e1ff28bcb5..5043a5f23992 100644
--- a/media-libs/faad2/ChangeLog
+++ b/media-libs/faad2/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-libs/faad2
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/faad2/ChangeLog,v 1.91 2007/05/21 21:03:56 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/faad2/ChangeLog,v 1.92 2007/11/20 18:46:24 aballier Exp $
+
+*faad2-2.6.1 (20 Nov 2007)
+
+ 20 Nov 2007; Alexis Ballier <aballier@gentoo.org>
+ +files/faad2-2.6.1-abi_has_changed.patch, +faad2-2.6.1.ebuild:
+ bump it now that the license issues are resolved, force abi number to be
+ bumped because all symbols have been renamed, upstream has been informed but
+ not very responsive which kinda sucks
21 May 2007; Raúl Porcel <armin76@gentoo.org> faad2-2.0-r13.ebuild:
alpha stable wrt #161390
diff --git a/media-libs/faad2/faad2-2.6.1.ebuild b/media-libs/faad2/faad2-2.6.1.ebuild
new file mode 100644
index 000000000000..a681c0a61161
--- /dev/null
+++ b/media-libs/faad2/faad2-2.6.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/faad2/faad2-2.6.1.ebuild,v 1.1 2007/11/20 18:46:24 aballier Exp $
+
+inherit eutils autotools
+
+DESCRIPTION="AAC audio decoding library"
+HOMEPAGE="http://www.audiocoding.com/"
+SRC_URI="mirror://sourceforge/faac/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=""
+DEPEND=""
+
+S="${WORKDIR}/${PN}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-abi_has_changed.patch"
+ eautoreconf
+}
+
+src_compile() {
+ econf \
+ --with-drm \
+ --without-xmms \
+ || die "econf failed"
+
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog NEWS README README.linux TODO
+}
diff --git a/media-libs/faad2/files/digest-faad2-2.6.1 b/media-libs/faad2/files/digest-faad2-2.6.1
new file mode 100644
index 000000000000..1bf209d064a0
--- /dev/null
+++ b/media-libs/faad2/files/digest-faad2-2.6.1
@@ -0,0 +1,3 @@
+MD5 74e92df40c270f216a8305fc87603c8a faad2-2.6.1.tar.gz 839410
+RMD160 ad559933dad6a65576a9947819190f04cb3b1c16 faad2-2.6.1.tar.gz 839410
+SHA256 8ad2c2e0c09b787a943e2ef831c1c84534e3a8726cc1eb1abc4da9eb3038285c faad2-2.6.1.tar.gz 839410
diff --git a/media-libs/faad2/files/faad2-2.6.1-abi_has_changed.patch b/media-libs/faad2/files/faad2-2.6.1-abi_has_changed.patch
new file mode 100644
index 000000000000..7206e3803bc5
--- /dev/null
+++ b/media-libs/faad2/files/faad2-2.6.1-abi_has_changed.patch
@@ -0,0 +1,14 @@
+Index: faad2/libfaad/Makefile.am
+===================================================================
+--- faad2.orig/libfaad/Makefile.am
++++ faad2/libfaad/Makefile.am
+@@ -3,7 +3,8 @@ lib_LTLIBRARIES = libfaad.la
+ include_HEADERS = $(top_srcdir)/include/faad.h \
+ $(top_srcdir)/include/neaacdec.h
+
+-libfaad_la_LDFLAGS = -lm
++libfaad_la_LDFLAGS = -version-info 1:0:0
++libfaad_la_LIBADD = -lm
+
+ libfaad_la_SOURCES = bits.c cfft.c decoder.c drc.c \
+ drm_dec.c error.c filtbank.c \