summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2001-12-13 17:36:05 +0000
committerMikael Hallendal <hallski@gentoo.org>2001-12-13 17:36:05 +0000
commit8945a106bcd63c86b421015c9c82aaffebd09803 (patch)
tree9e2e2b3a12fd24278a0663b35f7cdaf257dcb3bd /media-libs/freetype
parentreverted and checked in as a new name (diff)
downloadgentoo-2-8945a106bcd63c86b421015c9c82aaffebd09803.tar.gz
gentoo-2-8945a106bcd63c86b421015c9c82aaffebd09803.tar.bz2
gentoo-2-8945a106bcd63c86b421015c9c82aaffebd09803.zip
enable font hinting, Apple have patent on this and as far I understand that is the reason why it's not shipped with this enabled. Red Hat ships there rpm's without but Debian ships with this enabled.
Diffstat (limited to 'media-libs/freetype')
-rw-r--r--media-libs/freetype/files/digest-freetype-2.0.5-r11
-rw-r--r--media-libs/freetype/files/freetype-2-hinting.patch12
-rw-r--r--media-libs/freetype/freetype-2.0.5-r1.ebuild30
3 files changed, 43 insertions, 0 deletions
diff --git a/media-libs/freetype/files/digest-freetype-2.0.5-r1 b/media-libs/freetype/files/digest-freetype-2.0.5-r1
new file mode 100644
index 000000000000..7f1b33d7a979
--- /dev/null
+++ b/media-libs/freetype/files/digest-freetype-2.0.5-r1
@@ -0,0 +1 @@
+MD5 b4a3f9f42667a71045050f80b5229642 freetype-2.0.5.tar.bz2 565248
diff --git a/media-libs/freetype/files/freetype-2-hinting.patch b/media-libs/freetype/files/freetype-2-hinting.patch
new file mode 100644
index 000000000000..a91f12babd55
--- /dev/null
+++ b/media-libs/freetype/files/freetype-2-hinting.patch
@@ -0,0 +1,12 @@
+diff -r -u freetype-2.0.5.orig/include/freetype/config/ftoption.h freetype-2.0.5/include/freetype/config/ftoption.h
+--- freetype-2.0.5.orig/include/freetype/config/ftoption.h Tue Aug 21 10:50:45 2001
++++ freetype-2.0.5/include/freetype/config/ftoption.h Thu Dec 13 18:15:16 2001
+@@ -338,7 +338,7 @@
+ /* By undefining this, you will only compile the code necessary to load */
+ /* TrueType glyphs without hinting. */
+ /* */
+-#undef TT_CONFIG_OPTION_BYTECODE_INTERPRETER
++#define TT_CONFIG_OPTION_BYTECODE_INTERPRETER
+
+
+ /*************************************************************************/
diff --git a/media-libs/freetype/freetype-2.0.5-r1.ebuild b/media-libs/freetype/freetype-2.0.5-r1.ebuild
new file mode 100644
index 000000000000..56bfd176128f
--- /dev/null
+++ b/media-libs/freetype/freetype-2.0.5-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-libs/freetype/freetype-2.0.5-r1.ebuild,v 1.1 2001/12/13 17:36:05 hallski Exp $
+
+
+S=${WORKDIR}/${P}
+DESCRIPTION="TTF-Library"
+SRC_URI="http://download.sourceforge.net/freetype/${P}.tar.bz2"
+HOMEPAGE="http://www.freetype.org/"
+
+DEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ patch -p1 < ${FILESDIR}/freetype-2-hinting.patch
+}
+
+src_compile() {
+ make CFG="--host=${CHOST} --prefix=/usr" || die
+ emake || die
+}
+
+src_install() {
+ make prefix=${D}/usr install || die
+
+ dodoc ChangeLog README
+ dodoc docs/{BUILD,CHANGES,*.txt,PATENTS,readme.vms,todo}
+}