summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Meier <maekke@gentoo.org>2009-11-09 12:59:48 +0000
committerMarkus Meier <maekke@gentoo.org>2009-11-09 12:59:48 +0000
commit485fee2a60b9f501c9889817710f6c53015c51e8 (patch)
tree533bf4d2b97eae9a27288cca2c8eeda080682e47 /media-libs/gd/gd-2.0.35-r1.ebuild
parentclean up (diff)
downloadgentoo-2-485fee2a60b9f501c9889817710f6c53015c51e8.tar.gz
gentoo-2-485fee2a60b9f501c9889817710f6c53015c51e8.tar.bz2
gentoo-2-485fee2a60b9f501c9889817710f6c53015c51e8.zip
revision bump wrt security bug #292130
(Portage version: 2.2_rc49/cvs/Linux i686)
Diffstat (limited to 'media-libs/gd/gd-2.0.35-r1.ebuild')
-rw-r--r--media-libs/gd/gd-2.0.35-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/media-libs/gd/gd-2.0.35-r1.ebuild b/media-libs/gd/gd-2.0.35-r1.ebuild
new file mode 100644
index 000000000000..731a98b36e07
--- /dev/null
+++ b/media-libs/gd/gd-2.0.35-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gd/gd-2.0.35-r1.ebuild,v 1.1 2009/11/09 12:59:47 maekke Exp $
+
+inherit autotools
+
+DESCRIPTION="A graphics library for fast image creation"
+HOMEPAGE="http://libgd.org/"
+SRC_URI="http://libgd.org/releases/${P}.tar.bz2"
+
+LICENSE="|| ( as-is BSD )"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="fontconfig jpeg png truetype xpm"
+
+RDEPEND="fontconfig? ( media-libs/fontconfig )
+ jpeg? ( >=media-libs/jpeg-6b )
+ png? ( >=media-libs/libpng-1.2.5 sys-libs/zlib )
+ truetype? ( >=media-libs/freetype-2.1.5 )
+ xpm? ( x11-libs/libXpm x11-libs/libXt )"
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-maxcolors.patch
+ eautoconf
+ find . -type f -print0 | xargs -0 touch -r configure
+}
+
+src_compile() {
+ econf \
+ $(use_with fontconfig) \
+ $(use_with png) \
+ $(use_with truetype freetype) \
+ $(use_with jpeg) \
+ $(use_with xpm) \
+ || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc INSTALL README*
+ dohtml -r ./
+}