summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Gall <tgall@gentoo.org>2004-06-19 14:20:26 +0000
committerTom Gall <tgall@gentoo.org>2004-06-19 14:20:26 +0000
commitfbffdf5013257b7f57e367efce89d9afa7e6ffde (patch)
tree89afa1b595baff42d79e5c0bb524497410a5b921 /media-libs/giflib/giflib-4.1.0-r3.ebuild
parentAdded IUSE. (Manifest recommit) (diff)
downloadgentoo-2-fbffdf5013257b7f57e367efce89d9afa7e6ffde.tar.gz
gentoo-2-fbffdf5013257b7f57e367efce89d9afa7e6ffde.tar.bz2
gentoo-2-fbffdf5013257b7f57e367efce89d9afa7e6ffde.zip
stable on ppc64, bug #54120
Diffstat (limited to 'media-libs/giflib/giflib-4.1.0-r3.ebuild')
-rw-r--r--media-libs/giflib/giflib-4.1.0-r3.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/media-libs/giflib/giflib-4.1.0-r3.ebuild b/media-libs/giflib/giflib-4.1.0-r3.ebuild
index 901486757d24..5578db62a518 100644
--- a/media-libs/giflib/giflib-4.1.0-r3.ebuild
+++ b/media-libs/giflib/giflib-4.1.0-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/giflib/giflib-4.1.0-r3.ebuild,v 1.25 2004/06/02 20:21:00 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/giflib/giflib-4.1.0-r3.ebuild,v 1.26 2004/06/19 14:20:26 tgall Exp $
inherit gnuconfig
@@ -11,7 +11,7 @@ SRC_URI="ftp://metalab.unc.edu/pub/Linux/libs/giflib/${P}.tar.gz
LICENSE="as-is | BSD"
SLOT="0"
-KEYWORDS="x86 ppc sparc mips alpha arm hppa amd64 ia64"
+KEYWORDS="x86 ppc sparc mips alpha arm hppa amd64 ia64 ppc64"
IUSE="X gif"
DEPEND="X? ( virtual/x11 )"
@@ -20,6 +20,13 @@ src_unpack() {
unpack ${A}
cd ${S}
gnuconfig_update
+ # The library it tries to create is like 12 bytes, which is obviously bogus,
+ # updating libtool/autoconf fixes this!
+ if [ "${ARCH}" = "ppc64" ] ; then
+ libtoolize -c -f
+ aclocal
+ autoconf
+ fi
}
src_compile() {