summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-10-01 07:11:27 +0000
committerTim Harder <radhermit@gentoo.org>2011-10-01 07:11:27 +0000
commitec765ce2518b70896633a82480c856e4e1224894 (patch)
tree46ade211bd4b17c91c9a30a4d06edbcae6683fe3 /media-libs/glew/glew-1.7.0.ebuild
parentRemove old. (diff)
downloadgentoo-2-ec765ce2518b70896633a82480c856e4e1224894.tar.gz
gentoo-2-ec765ce2518b70896633a82480c856e4e1224894.tar.bz2
gentoo-2-ec765ce2518b70896633a82480c856e4e1224894.zip
Version bump.
(Portage version: 2.2.0_alpha60/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/glew/glew-1.7.0.ebuild')
-rw-r--r--media-libs/glew/glew-1.7.0.ebuild67
1 files changed, 67 insertions, 0 deletions
diff --git a/media-libs/glew/glew-1.7.0.ebuild b/media-libs/glew/glew-1.7.0.ebuild
new file mode 100644
index 000000000000..3276f1bfeb41
--- /dev/null
+++ b/media-libs/glew/glew-1.7.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/glew/glew-1.7.0.ebuild,v 1.1 2011/10/01 07:11:27 radhermit Exp $
+
+EAPI=4
+inherit multilib toolchain-funcs
+
+DESCRIPTION="The OpenGL Extension Wrangler Library"
+HOMEPAGE="http://glew.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+
+LICENSE="BSD MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc static-libs"
+
+RDEPEND="x11-libs/libXmu
+ x11-libs/libXi
+ virtual/glu
+ virtual/opengl
+ x11-libs/libXext
+ x11-libs/libX11"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ myglewopts=(
+ AR="$(tc-getAR)"
+ STRIP=true
+ CC="$(tc-getCC)"
+ LD="$(tc-getCC) ${LDFLAGS}"
+ M_ARCH=""
+ LDFLAGS.EXTRA=""
+ POPT="${CFLAGS}"
+ )
+}
+
+src_prepare() {
+ sed -i \
+ -e '/INSTALL/s:-s::' \
+ -e '/$(CC) $(CFLAGS) -o/s:$(CFLAGS):$(CFLAGS) $(LDFLAGS):' \
+ Makefile || die
+
+ if ! use static-libs ; then
+ sed -i -e '/glew.lib:/s|lib/$(LIB.STATIC) ||' \
+ -e '/glew.lib.mx:/s|lib/$(LIB.STATIC.MX) ||' \
+ -e '/STRIP.* lib\/$(LIB.STATIC)/{N;d}' \
+ -e '/STRIP.* lib\/$(LIB.STATIC.MX)/{N;d}' \
+ Makefile || die
+ fi
+
+ # don't do stupid Solaris specific stuff that won't work in Prefix
+ cp config/Makefile.linux config/Makefile.solaris || die
+}
+
+src_compile(){
+ emake "${myglewopts[@]}"
+}
+
+src_install() {
+ emake \
+ GLEW_DEST="${ED}/usr" \
+ LIBDIR="${ED}/usr/$(get_libdir)" \
+ "${myglewopts[@]}" install.all
+
+ dodoc TODO.txt
+ use doc && dohtml doc/*
+}