summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2013-08-02 22:29:55 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2013-08-02 22:29:55 +0000
commit37467710e33adc082952e24bd96fd7f504e30f39 (patch)
treeba5323efbcd749d61b86b74a943b2a8c4cfc6715 /media-libs/grilo
parentAdd messages for bug #477356. (diff)
downloadgentoo-2-37467710e33adc082952e24bd96fd7f504e30f39.tar.gz
gentoo-2-37467710e33adc082952e24bd96fd7f504e30f39.tar.bz2
gentoo-2-37467710e33adc082952e24bd96fd7f504e30f39.zip
Add missing liboauth dependency. Switch to python-any-r1 eclass.
(Portage version: 2.2.0_alpha191/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'media-libs/grilo')
-rw-r--r--media-libs/grilo/ChangeLog6
-rw-r--r--media-libs/grilo/files/grilo-0.1.16-media-source-infinite-loop.patch48
-rw-r--r--media-libs/grilo/grilo-0.2.6.ebuild21
3 files changed, 21 insertions, 54 deletions
diff --git a/media-libs/grilo/ChangeLog b/media-libs/grilo/ChangeLog
index 9b6e60fc33a6..5fd1c8101af9 100644
--- a/media-libs/grilo/ChangeLog
+++ b/media-libs/grilo/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/grilo
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/grilo/ChangeLog,v 1.26 2013/05/26 11:20:45 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/grilo/ChangeLog,v 1.27 2013/08/02 22:29:55 eva Exp $
+
+ 02 Aug 2013; Gilles Dartiguelongue <eva@gentoo.org> grilo-0.2.6.ebuild,
+ -files/grilo-0.1.16-media-source-infinite-loop.patch:
+ Add missing liboauth dependency. Switch to python-any-r1 eclass.
*grilo-0.2.6 (26 May 2013)
diff --git a/media-libs/grilo/files/grilo-0.1.16-media-source-infinite-loop.patch b/media-libs/grilo/files/grilo-0.1.16-media-source-infinite-loop.patch
deleted file mode 100644
index 755faac9d2af..000000000000
--- a/media-libs/grilo/files/grilo-0.1.16-media-source-infinite-loop.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-From df228459d4332f3cb675d28d1d4185ae22929b81 Mon Sep 17 00:00:00 2001
-From: Lionel Landwerlin <lionel.g.landwerlin@linux.intel.com>
-Date: Wed, 29 Jun 2011 13:13:38 +0000
-Subject: media-source: manage end of search/browse with splitted sources
-
-When running in splitted modes (usually when dealing with websites),
-if you get less results than what the user would like to get, we
-currently end up in an infinite loop with the core of grilo keeping
-asking for new items from a source which can't deliver anymore.
-
-To manage this specific case, we just check whether the plugin has
-returned a remaining results number equals to 0 as well as a null
-item.
-
-Signed-off-by: Lionel Landwerlin <lionel.g.landwerlin@linux.intel.com>
----
-diff --git a/src/grl-media-source.c b/src/grl-media-source.c
-index 459e29c..00494c3 100644
---- a/src/grl-media-source.c
-+++ b/src/grl-media-source.c
-@@ -643,8 +643,6 @@ browse_result_relay_cb (GrlMediaSource *source,
-
- brc = (struct BrowseRelayCb *) user_data;
-
-- plugin_remaining = remaining;
--
- /* --- operation cancel management --- */
-
- /* Check if operation is still valid , otherwise do not emit the result
-@@ -697,9 +695,13 @@ browse_result_relay_cb (GrlMediaSource *source,
- as_info->count--;
- as_info->chunk_consumed++;
-
-- /* FIXME: If we received less than we requested we should
-- not do an extra query */
-- remaining = as_info->count;
-+ /* When auto split, if less results than what a chunk should give,
-+ * that means we've reached the end of the results. */
-+ if ((plugin_remaining == 0) &&
-+ (as_info->chunk_consumed < as_info->chunk_requested))
-+ remaining = 0;
-+ else
-+ remaining = as_info->count;
- }
-
- /* --- relay operation --- */
---
-cgit v0.9
diff --git a/media-libs/grilo/grilo-0.2.6.ebuild b/media-libs/grilo/grilo-0.2.6.ebuild
index 3c682d88f573..6c4665ad7d4d 100644
--- a/media-libs/grilo/grilo-0.2.6.ebuild
+++ b/media-libs/grilo/grilo-0.2.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/grilo/grilo-0.2.6.ebuild,v 1.1 2013/05/26 11:20:45 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/grilo/grilo-0.2.6.ebuild,v 1.2 2013/08/02 22:29:55 eva Exp $
EAPI="5"
GCONF_DEBUG="no" # --enable-debug only changes CFLAGS
@@ -10,7 +10,7 @@ VALA_MIN_API_VERSION="0.12"
VALA_MAX_API_VERSION="0.20" # explicitly specified in configure
VALA_USE_DEPEND="vapigen"
-inherit eutils gnome2 vala python-single-r1
+inherit eutils gnome2 python-any-r1 vala
DESCRIPTION="A framework for easy media discovery and browsing"
HOMEPAGE="https://live.gnome.org/Grilo"
@@ -24,24 +24,31 @@ REQUIRED_USE="test? ( introspection )"
RDEPEND="
>=dev-libs/glib-2.29.10:2
dev-libs/libxml2:2
+ net-libs/liboauth
gtk? ( >=x11-libs/gtk+-3:3 )
introspection? ( >=dev-libs/gobject-introspection-0.9 )
network? ( >=net-libs/libsoup-2.41.3:2.4 )
"
DEPEND="${RDEPEND}
>=dev-util/gtk-doc-am-1.10
+ >=dev-util/intltool-0.40
virtual/pkgconfig
vala? ( $(vala_depend) )
test? (
${PYTHON_DEPS}
- dev-python/pygobject:2[${PYTHON_USEDEP}]
- dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/pygobject:2
+ dev-python/pygobject:3
media-plugins/grilo-plugins:0.2 )
"
# eautoreconf requires gnome-common
+python_check_deps() {
+ has_version "dev-python/pygobject:2[${PYTHON_USEDEP}]" && \
+ has_version "dev-python/pygobject:3[${PYTHON_USEDEP}]"
+}
+
pkg_setup() {
- use test && python-single-r1_pkg_setup
+ use test && python-any-r1_pkg_setup
}
src_prepare() {
@@ -68,6 +75,10 @@ src_configure() {
$(use_enable vala)
}
+src_test() {
+ emake check PYTHON=$(PYTHON -2)
+}
+
src_install() {
gnome2_src_install
# Upstream made this conditional on gtk-doc build...