summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2006-10-19 19:41:03 +0000
committerHanno Böck <hanno@gentoo.org>2006-10-19 19:41:03 +0000
commit7ad4a2adb6ec335df9b19ec3f289d9503517cdf4 (patch)
tree12ab6255783da5cdbd96778df4e6b8da174e28a4 /media-libs/gst-plugins-good
parentremove unused dev-util/git:gitsendemail use flag (diff)
downloadgentoo-2-7ad4a2adb6ec335df9b19ec3f289d9503517cdf4.tar.gz
gentoo-2-7ad4a2adb6ec335df9b19ec3f289d9503517cdf4.tar.bz2
gentoo-2-7ad4a2adb6ec335df9b19ec3f289d9503517cdf4.zip
gst-plugins-good update (dep for thoggen)
(Portage version: 2.1.2_pre3-r5)
Diffstat (limited to 'media-libs/gst-plugins-good')
-rw-r--r--media-libs/gst-plugins-good/ChangeLog8
-rw-r--r--media-libs/gst-plugins-good/files/digest-gst-plugins-good-0.10.43
-rw-r--r--media-libs/gst-plugins-good/gst-plugins-good-0.10.4.ebuild65
3 files changed, 75 insertions, 1 deletions
diff --git a/media-libs/gst-plugins-good/ChangeLog b/media-libs/gst-plugins-good/ChangeLog
index cd556c901535..32353ad181c4 100644
--- a/media-libs/gst-plugins-good/ChangeLog
+++ b/media-libs/gst-plugins-good/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/gst-plugins-good
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-good/ChangeLog,v 1.22 2006/09/19 14:29:41 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-good/ChangeLog,v 1.23 2006/10/19 19:41:03 hanno Exp $
+
+*gst-plugins-good-0.10.4 (19 Oct 2006)
+
+ 19 Oct 2006; Hanno Boeck <hanno@gentoo.org>
+ +gst-plugins-good-0.10.4.ebuild:
+ Version bump.
19 Sep 2006; Aron Griffis <agriffis@gentoo.org>
gst-plugins-good-0.10.3.ebuild:
diff --git a/media-libs/gst-plugins-good/files/digest-gst-plugins-good-0.10.4 b/media-libs/gst-plugins-good/files/digest-gst-plugins-good-0.10.4
new file mode 100644
index 000000000000..ccbb02a6291c
--- /dev/null
+++ b/media-libs/gst-plugins-good/files/digest-gst-plugins-good-0.10.4
@@ -0,0 +1,3 @@
+MD5 e189496e7987898823d28d26b79f63dc gst-plugins-good-0.10.4.tar.bz2 1225739
+RMD160 23d774f547e9cdc4929c5bcd24aa21019c2a6b8d gst-plugins-good-0.10.4.tar.bz2 1225739
+SHA256 f2b90ef5fb4b2d0b06d5fd8193a7c19b1d08d4f737abeafabf04d39673ea703b gst-plugins-good-0.10.4.tar.bz2 1225739
diff --git a/media-libs/gst-plugins-good/gst-plugins-good-0.10.4.ebuild b/media-libs/gst-plugins-good/gst-plugins-good-0.10.4.ebuild
new file mode 100644
index 000000000000..86edc0ed0563
--- /dev/null
+++ b/media-libs/gst-plugins-good/gst-plugins-good-0.10.4.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-good/gst-plugins-good-0.10.4.ebuild,v 1.1 2006/10/19 19:41:03 hanno Exp $
+
+# order is important, gnome2 after gst-plugins
+inherit gst-plugins-good gst-plugins10 gnome2 eutils flag-o-matic libtool
+
+DESCRIPTION="Basepack of plugins for gstreamer"
+HOMEPAGE="http://gstreamer.net/"
+SRC_URI="http://gstreamer.freedesktop.org/src/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86"
+
+RDEPEND=">=media-libs/gst-plugins-base-0.10.6
+ >=media-libs/gstreamer-0.10.8
+ >=dev-libs/liboil-0.3.6"
+
+DEPEND="${RDEPEND}
+ >=sys-devel/gettext-0.11.5
+ >=dev-util/pkgconfig-0.9"
+
+# overrides the eclass
+src_unpack() {
+ unpack ${A}
+}
+
+src_compile() {
+ elibtoolize
+
+ # gst doesnt handle optimisations well
+ strip-flags
+ replace-flags "-O3" "-O2"
+ filter-flags "-fprefetch-loop-arrays" # see bug 22249
+ if use alpha || use amd64 || use ia64 || use hppa; then
+ append-flags -fPIC
+ fi
+
+ gst-plugins-good_src_configure
+
+ emake || die
+}
+
+# override eclass
+src_install() {
+ gnome2_src_install
+}
+
+DOCS="AUTHORS INSTALL README RELEASE TODO"
+
+pkg_postinst () {
+ gnome2_pkg_postinst
+
+ echo ""
+ einfo "The Gstreamer plugins setup has changed quite a bit on Gentoo,"
+ einfo "applications now should provide the basic plugins needed."
+ echo ""
+ einfo "The new seperate plugins are all named 'gst-plugins-<plugin>'."
+ einfo "To get a listing of currently available plugins execute 'emerge -s gst-plugins-'."
+ einfo "In most cases it shouldn't be needed though to emerge extra plugins."
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+}