summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2007-06-20 00:56:42 +0000
committerHanno Böck <hanno@gentoo.org>2007-06-20 00:56:42 +0000
commit2d58c67cb4fe071035043e1287b0cdd9048837c8 (patch)
treeb47f844ae3592ff0771892eb8879d94de9013a42 /media-libs/gst-plugins-ugly
parent0.8 update (diff)
downloadgentoo-2-2d58c67cb4fe071035043e1287b0cdd9048837c8.tar.gz
gentoo-2-2d58c67cb4fe071035043e1287b0cdd9048837c8.tar.bz2
gentoo-2-2d58c67cb4fe071035043e1287b0cdd9048837c8.zip
version bump
(Portage version: 2.1.3_rc4)
Diffstat (limited to 'media-libs/gst-plugins-ugly')
-rw-r--r--media-libs/gst-plugins-ugly/ChangeLog8
-rw-r--r--media-libs/gst-plugins-ugly/files/digest-gst-plugins-ugly-0.10.63
-rw-r--r--media-libs/gst-plugins-ugly/gst-plugins-ugly-0.10.6.ebuild78
3 files changed, 88 insertions, 1 deletions
diff --git a/media-libs/gst-plugins-ugly/ChangeLog b/media-libs/gst-plugins-ugly/ChangeLog
index cb654f3b596d..ff8781098796 100644
--- a/media-libs/gst-plugins-ugly/ChangeLog
+++ b/media-libs/gst-plugins-ugly/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/gst-plugins-ugly
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-ugly/ChangeLog,v 1.20 2007/04/30 23:06:08 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-ugly/ChangeLog,v 1.21 2007/06/20 00:56:42 hanno Exp $
+
+*gst-plugins-ugly-0.10.6 (20 Jun 2007)
+
+ 20 Jun 2007; Hanno Boeck <hanno@gentoo.org>
+ +gst-plugins-ugly-0.10.6.ebuild:
+ Version bump.
30 Apr 2007; Marius Mauch <genone@gentoo.org>
gst-plugins-ugly-0.10.3.ebuild, gst-plugins-ugly-0.10.4.ebuild:
diff --git a/media-libs/gst-plugins-ugly/files/digest-gst-plugins-ugly-0.10.6 b/media-libs/gst-plugins-ugly/files/digest-gst-plugins-ugly-0.10.6
new file mode 100644
index 000000000000..24b61c3cde29
--- /dev/null
+++ b/media-libs/gst-plugins-ugly/files/digest-gst-plugins-ugly-0.10.6
@@ -0,0 +1,3 @@
+MD5 f1016148ecbfba968c0ef1773066988b gst-plugins-ugly-0.10.6.tar.bz2 773777
+RMD160 6f2ce61800e1013f8695b8e09a3f03beee1c9af8 gst-plugins-ugly-0.10.6.tar.bz2 773777
+SHA256 9c514d4002fb2a2efc5c60e009c330be2ee05c28649d73de3aa45530161c2c62 gst-plugins-ugly-0.10.6.tar.bz2 773777
diff --git a/media-libs/gst-plugins-ugly/gst-plugins-ugly-0.10.6.ebuild b/media-libs/gst-plugins-ugly/gst-plugins-ugly-0.10.6.ebuild
new file mode 100644
index 000000000000..b06af13b5ca1
--- /dev/null
+++ b/media-libs/gst-plugins-ugly/gst-plugins-ugly-0.10.6.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-ugly/gst-plugins-ugly-0.10.6.ebuild,v 1.1 2007/06/20 00:56:42 hanno Exp $
+
+# order is important, gnome2 after gst-plugins
+inherit gst-plugins-ugly gst-plugins10 gnome2 eutils flag-o-matic libtool
+
+DESCRIPTION="Basepack of plugins for gstreamer"
+HOMEPAGE="http://gstreamer.net/"
+SRC_URI="http://gstreamer.freedesktop.org/src/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~x86 ~x86-fbsd"
+#IUSE="esd alsa oss"
+
+RDEPEND=">=media-libs/gst-plugins-base-0.10.3
+ >=media-libs/gstreamer-0.10.3
+ >=dev-libs/liboil-0.3.0
+ >=dev-libs/glib-2.6.0"
+
+DEPEND="${RDEPEND}
+ >=sys-devel/gettext-0.11.5
+ >=dev-util/pkgconfig-0.9"
+
+GST_PLUGINS_BUILD=""
+
+# overrides the eclass
+src_unpack() {
+
+ unpack ${A}
+}
+
+src_compile() {
+
+ elibtoolize
+
+ # gst doesnt handle optimisations well
+ strip-flags
+ replace-flags "-O3" "-O2"
+ filter-flags "-fprefetch-loop-arrays" # see bug 22249
+ if use alpha || use amd64 || use ia64 || use hppa; then
+ append-flags -fPIC
+ fi
+
+ gst-plugins-ugly_src_configure
+
+ emake || die
+
+}
+
+# override eclass
+src_install() {
+
+ gnome2_src_install
+
+}
+
+DOCS="AUTHORS INSTALL README RELEASE TODO"
+
+pkg_postinst () {
+
+ gnome2_pkg_postinst
+
+ echo ""
+ elog "The Gstreamer plugins setup has changed quite a bit on Gentoo,"
+ elog "applications now should provide the basic plugins needed."
+ elog ""
+ elog "The new seperate plugins are all named 'gst-plugins-<plugin>'."
+ elog "To get a listing of currently available plugins execute 'emerge -s gst-plugins-'."
+ elog "In most cases it shouldn't be needed though to emerge extra plugins."
+
+}
+
+pkg_postrm() {
+
+ gnome2_pkg_postrm
+
+}