summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2004-06-29 16:04:11 +0000
committerMarinus Schraal <foser@gentoo.org>2004-06-29 16:04:11 +0000
commitc5ec502338d7f53b50a7cbc88cc4ab5884a47929 (patch)
tree3aa4af40825f8470de52710cbd33879a40d1793d /media-libs/gst-plugins
parentsync IUSE (missing) (Manifest recommit) (diff)
downloadgentoo-2-c5ec502338d7f53b50a7cbc88cc4ab5884a47929.tar.gz
gentoo-2-c5ec502338d7f53b50a7cbc88cc4ab5884a47929.tar.bz2
gentoo-2-c5ec502338d7f53b50a7cbc88cc4ab5884a47929.zip
new release
Diffstat (limited to 'media-libs/gst-plugins')
-rw-r--r--media-libs/gst-plugins/ChangeLog7
-rw-r--r--media-libs/gst-plugins/files/digest-gst-plugins-0.8.21
-rw-r--r--media-libs/gst-plugins/gst-plugins-0.8.2.ebuild83
3 files changed, 90 insertions, 1 deletions
diff --git a/media-libs/gst-plugins/ChangeLog b/media-libs/gst-plugins/ChangeLog
index 9b18e61c09c7..8b100c575cc3 100644
--- a/media-libs/gst-plugins/ChangeLog
+++ b/media-libs/gst-plugins/ChangeLog
@@ -1,7 +1,12 @@
# ChangeLog for media-libs/gst-plugins
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
# Distributed under the terms of the GNU General Public License, v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins/ChangeLog,v 1.69 2004/06/24 23:01:40 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins/ChangeLog,v 1.70 2004/06/29 16:04:11 foser Exp $
+
+*gst-plugins-0.8.2 (29 Jun 2004)
+
+ 29 Jun 2004; foser <foser@gentoo.org> gst-plugins-0.8.2.ebuild :
+ New release, fix gstreamer dep so it works with the off versioning
13 Jun 2004; Jeremy Huddleston <eradicator@gentoo.org> :
Getting rid of virtual/jack.
diff --git a/media-libs/gst-plugins/files/digest-gst-plugins-0.8.2 b/media-libs/gst-plugins/files/digest-gst-plugins-0.8.2
new file mode 100644
index 000000000000..48658f359186
--- /dev/null
+++ b/media-libs/gst-plugins/files/digest-gst-plugins-0.8.2
@@ -0,0 +1 @@
+MD5 1f46e3aa765659818f309ed5b64c9b88 gst-plugins-0.8.2.tar.bz2 1978467
diff --git a/media-libs/gst-plugins/gst-plugins-0.8.2.ebuild b/media-libs/gst-plugins/gst-plugins-0.8.2.ebuild
new file mode 100644
index 000000000000..4bfd05cbdfb3
--- /dev/null
+++ b/media-libs/gst-plugins/gst-plugins-0.8.2.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins/gst-plugins-0.8.2.ebuild,v 1.1 2004/06/29 16:04:11 foser Exp $
+
+# order is important, gnome2 after gst-plugins
+inherit gst-plugins gnome2 eutils flag-o-matic
+
+DESCRIPTION="Basepack of plugins for gstreamer"
+HOMEPAGE="http://gstreamer.net/"
+LICENSE="GPL-2"
+
+IUSE="esd alsa oss"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~amd64 ~ia64 ~mips"
+
+RDEPEND=">=media-libs/gstreamer-${PV}*
+ >=gnome-base/gconf-1.2"
+
+DEPEND="${RDEPEND}
+ >=sys-devel/gettext-0.11.5
+ >=dev-util/pkgconfig-0.9"
+
+PDEPEND="oss? ( >=media-plugins/gst-plugins-oss-${PV} )
+ alsa? ( >=media-plugins/gst-plugins-alsa-${PV} )
+ esd? ( >=media-plugins/gst-plugins-esd-${PV} )"
+
+# we need x for the x overlay to get linked
+GST_PLUGINS_BUILD="x xshm"
+
+# overrides the eclass
+src_unpack() {
+
+ unpack ${A}
+
+}
+
+src_compile() {
+
+ elibtoolize
+
+ # gst doesnt handle optimisations well
+ strip-flags
+ replace-flags "-O3" "-O2"
+ filter-flags "-fprefetch-loop-arrays" # see bug 22249
+ if use alpha || use amd64 || use ia64 || use hppa; then
+ append-flags -fPIC
+ fi
+
+ gst-plugins_src_configure
+
+ emake || die
+
+}
+
+# override eclass
+src_install() {
+
+ gnome2_src_install
+
+}
+
+DOCS="AUTHORS COPYING INSTALL README RELEASE TODO"
+
+pkg_postinst () {
+
+ gnome2_pkg_postinst
+ gst-plugins_pkg_postinst
+
+ echo ""
+ einfo "The Gstreamer plugins setup has changed quite a bit on Gentoo,"
+ einfo "applications now should provide the basic plugins needed."
+ echo ""
+ einfo "The new seperate plugins are all named 'gst-plugins-<plugin>'."
+ einfo "To get a listing of currently available plugins execute 'emerge -s gst-plugins-'."
+ einfo "In most cases it shouldn't be needed though to emerge extra plugins."
+
+}
+
+pkg_postrm() {
+
+ gnome2_pkg_postrm
+ gst-plugins_pkg_postrm
+
+}