summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2015-05-02 10:52:24 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2015-05-02 10:52:24 +0000
commitc4eea7f69ad085c19087af08b961d159c781045d (patch)
tree0b8907ceadcd1446b221988c2a43e3e3102304d8 /media-libs/gst-rtsp-server
parentvanilla-3.2.68 + genpatches-3.2-16 + grsecurity-3.1-3.2.68-201504302116 (diff)
downloadgentoo-2-c4eea7f69ad085c19087af08b961d159c781045d.tar.gz
gentoo-2-c4eea7f69ad085c19087af08b961d159c781045d.tar.bz2
gentoo-2-c4eea7f69ad085c19087af08b961d159c781045d.zip
Version bump for 1.0 slot, bug #538666.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'media-libs/gst-rtsp-server')
-rw-r--r--media-libs/gst-rtsp-server/ChangeLog8
-rw-r--r--media-libs/gst-rtsp-server/gst-rtsp-server-1.4.5.ebuild79
2 files changed, 86 insertions, 1 deletions
diff --git a/media-libs/gst-rtsp-server/ChangeLog b/media-libs/gst-rtsp-server/ChangeLog
index 03eee7ad7a12..e869364c9919 100644
--- a/media-libs/gst-rtsp-server/ChangeLog
+++ b/media-libs/gst-rtsp-server/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/gst-rtsp-server
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-rtsp-server/ChangeLog,v 1.15 2015/03/15 13:35:49 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-rtsp-server/ChangeLog,v 1.16 2015/05/02 10:52:24 eva Exp $
+
+*gst-rtsp-server-1.4.5 (02 May 2015)
+
+ 02 May 2015; Gilles Dartiguelongue <eva@gentoo.org>
+ +gst-rtsp-server-1.4.5.ebuild:
+ Version bump for 1.0 slot, bug #538666.
15 Mar 2015; Pacho Ramos <pacho@gentoo.org> gst-rtsp-server-0.10.8-r1.ebuild:
x86 stable, bug 534012
diff --git a/media-libs/gst-rtsp-server/gst-rtsp-server-1.4.5.ebuild b/media-libs/gst-rtsp-server/gst-rtsp-server-1.4.5.ebuild
new file mode 100644
index 000000000000..5e1b634b6e28
--- /dev/null
+++ b/media-libs/gst-rtsp-server/gst-rtsp-server-1.4.5.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-rtsp-server/gst-rtsp-server-1.4.5.ebuild,v 1.1 2015/05/02 10:52:24 eva Exp $
+
+EAPI=5
+
+inherit eutils gstreamer
+
+DESCRIPTION="A GStreamer based RTSP server"
+HOMEPAGE="http://people.freedesktop.org/~wtay/"
+
+LICENSE="LGPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples +introspection static-libs test"
+
+# FIXME: check should depend on USE=test but check is losy
+# configure says good and bad are required by macros forces them to be optional
+# they are only used in unittests anyway.
+RDEPEND="
+ >=dev-libs/glib-2.32:2[${MULTILIB_USEDEP}]
+ >=media-libs/gstreamer-1.4:${SLOT}[introspection?,${MULTILIB_USEDEP}]
+ >=media-libs/gst-plugins-base-1.4:${SLOT}[introspection?,${MULTILIB_USEDEP}]
+
+ introspection? ( >=dev-libs/gobject-introspection-1.31.1 )
+"
+DEPEND="${RDEPEND}
+ >=dev-libs/check-0.9.2
+ >=dev-util/gtk-doc-am-1.12
+ virtual/pkgconfig
+ test? (
+ >=media-libs/gst-plugins-bad-1.4:${SLOT}[introspection?,${MULTILIB_USEDEP}]
+ >=media-libs/gst-plugins-good-1.4:${SLOT}[${MULTILIB_USEDEP}]
+ )
+"
+
+# Due to gstreamer src_configure
+QA_CONFIGURE_OPTIONS="--enable-nls"
+
+src_prepare() {
+ # don't waste time building examples
+ sed -e '/SUBDIRS.*=/,/^$/ { s/examples// };' \
+ -i Makefile.am Makefile.in \
+ || die
+}
+
+multilib_src_configure() {
+ # debug: only adds -g to CFLAGS
+ # docbook: nothing behind that switch
+ # libcgroup is automagic and only used in examples
+ gstreamer_multilib_src_configure \
+ --disable-docbook \
+ --disable-gtk-doc \
+ $(multilib_native_use_enable introspection) \
+ $(use_enable static-libs static) \
+ $(use_enable test tests) \
+ LIBCGROUP_LIBS= \
+ LIBCGROUP_FLAGS=
+
+ # work-around gtk-doc out-of-source brokedness
+ if multilib_is_native_abi ; then
+ ln -s "${S}"/docs/libs/${d}/html docs/libs/${d}/html || die
+ fi
+}
+
+multilib_src_install() {
+ emake install DESTDIR="${D}"
+ # Handle broken upstream modifications to defaults of gtk-doc
+ emake install -C docs/libs DESTDIR="${D}"
+ prune_libtool_files
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ if use examples ; then
+ insinto /usr/share/doc/${PF}/examples
+ doins "${S}"/examples/*.c
+ fi
+}