summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2015-02-17 17:19:34 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2015-02-17 17:19:34 +0000
commit471fb1332716ea8e618bdb1c352b749ccf653c09 (patch)
tree66f530771eed5a413077fcce5b0be9966676ec4b /media-libs/harfbuzz
parentversion bump (bug #540394) (diff)
downloadgentoo-2-471fb1332716ea8e618bdb1c352b749ccf653c09.tar.gz
gentoo-2-471fb1332716ea8e618bdb1c352b749ccf653c09.tar.bz2
gentoo-2-471fb1332716ea8e618bdb1c352b749ccf653c09.zip
Version bump; libharfbuzz-gobject is now installed only if USE=introspection (bug #535852, thanks to jshin et al).
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key 0x18E5B6F2D8D5EC8D)
Diffstat (limited to 'media-libs/harfbuzz')
-rw-r--r--media-libs/harfbuzz/ChangeLog9
-rw-r--r--media-libs/harfbuzz/harfbuzz-0.9.38.ebuild95
-rw-r--r--media-libs/harfbuzz/harfbuzz-9999.ebuild10
3 files changed, 110 insertions, 4 deletions
diff --git a/media-libs/harfbuzz/ChangeLog b/media-libs/harfbuzz/ChangeLog
index c327277d4246..b4f82eb65825 100644
--- a/media-libs/harfbuzz/ChangeLog
+++ b/media-libs/harfbuzz/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-libs/harfbuzz
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/harfbuzz/ChangeLog,v 1.96 2015/01/31 13:14:56 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/harfbuzz/ChangeLog,v 1.97 2015/02/17 17:19:34 tetromino Exp $
+
+*harfbuzz-0.9.38 (17 Feb 2015)
+
+ 17 Feb 2015; Alexandre Rostovtsev <tetromino@gentoo.org>
+ +harfbuzz-0.9.38.ebuild, harfbuzz-9999.ebuild:
+ Version bump; libharfbuzz-gobject is now installed only if USE=introspection
+ (bug #535852, thanks to jshin et al).
31 Jan 2015; Agostino Sarubbo <ago@gentoo.org> harfbuzz-0.9.35.ebuild:
Stable for amd64, wrt bug #531592
diff --git a/media-libs/harfbuzz/harfbuzz-0.9.38.ebuild b/media-libs/harfbuzz/harfbuzz-0.9.38.ebuild
new file mode 100644
index 000000000000..44f0181948c5
--- /dev/null
+++ b/media-libs/harfbuzz/harfbuzz-0.9.38.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/harfbuzz/harfbuzz-0.9.38.ebuild,v 1.1 2015/02/17 17:19:34 tetromino Exp $
+
+EAPI=5
+
+EGIT_REPO_URI="git://anongit.freedesktop.org/harfbuzz"
+[[ ${PV} == 9999 ]] && inherit git-r3 autotools
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit eutils libtool multilib-minimal python-any-r1
+
+DESCRIPTION="An OpenType text shaping engine"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/HarfBuzz"
+[[ ${PV} == 9999 ]] || SRC_URI="http://www.freedesktop.org/software/${PN}/release/${P}.tar.bz2"
+
+LICENSE="Old-MIT ISC icu"
+SLOT="0/0.9.18" # 0.9.18 introduced the harfbuzz-icu split; bug #472416
+[[ ${PV} == 9999 ]] || \
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~x64-macos ~x86-macos ~x64-solaris"
+IUSE="+cairo +glib +graphite icu +introspection static-libs test +truetype"
+REQUIRED_USE="introspection? ( glib )"
+
+RDEPEND="
+ cairo? ( x11-libs/cairo:= )
+ glib? ( >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}] )
+ graphite? ( >=media-gfx/graphite2-1.2.1:=[${MULTILIB_USEDEP}] )
+ icu? ( >=dev-libs/icu-51.2-r1:=[${MULTILIB_USEDEP}] )
+ introspection? ( >=dev-libs/gobject-introspection-1.34 )
+ truetype? ( >=media-libs/freetype-2.5.0.1:2=[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ virtual/pkgconfig
+ test? ( ${PYTHON_DEPS} )
+"
+# eautoreconf requires gobject-introspection-common
+# ragel needed if regenerating *.hh files from *.rl
+[[ ${PV} = 9999 ]] && DEPEND="${DEPEND}
+ >=dev-libs/gobject-introspection-common-1.34
+ dev-util/ragel
+"
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ if [[ ${CHOST} == *-darwin* || ${CHOST} == *-solaris* ]] ; then
+ # on Darwin/Solaris we need to link with g++, like automake defaults
+ # to, but overridden by upstream because on Linux this is not
+ # necessary, bug #449126
+ sed -i \
+ -e 's/\<LINK\>/CXXLINK/' \
+ src/Makefile.am || die
+ sed -i \
+ -e '/libharfbuzz_la_LINK = /s/\<LINK\>/CXXLINK/' \
+ src/Makefile.in || die
+ sed -i \
+ -e '/AM_V_CCLD/s/\<LINK\>/CXXLINK/' \
+ test/api/Makefile.in || die
+ fi
+
+ [[ ${PV} == 9999 ]] && eautoreconf
+ elibtoolize # for Solaris
+
+ # failing test, https://bugs.freedesktop.org/show_bug.cgi?id=89190
+ sed -e 's#tests/arabic-fallback-shaping.tests##' -i test/shaping/Makefile.in || die "sed failed"
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" \
+ # harfbuzz-gobject only used for instrospection, bug #535852
+ econf \
+ --without-coretext \
+ --without-uniscribe \
+ $(use_enable static-libs static) \
+ $(multilib_native_use_with cairo) \
+ $(use_with glib) \
+ $(use_with introspection gobject) \
+ $(use_with graphite graphite2) \
+ $(use_with icu) \
+ $(multilib_native_use_enable introspection) \
+ $(use_with truetype freetype)
+
+ if multilib_is_native_abi; then
+ ln -s "${S}"/docs/reference/html docs/reference/html || die
+ fi
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ prune_libtool_files --modules
+}
diff --git a/media-libs/harfbuzz/harfbuzz-9999.ebuild b/media-libs/harfbuzz/harfbuzz-9999.ebuild
index 43bc2733d53d..167c40beaf20 100644
--- a/media-libs/harfbuzz/harfbuzz-9999.ebuild
+++ b/media-libs/harfbuzz/harfbuzz-9999.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/harfbuzz/harfbuzz-9999.ebuild,v 1.31 2014/12/27 20:47:26 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/harfbuzz/harfbuzz-9999.ebuild,v 1.32 2015/02/17 17:19:34 tetromino Exp $
EAPI=5
@@ -64,17 +64,21 @@ src_prepare() {
[[ ${PV} == 9999 ]] && eautoreconf
elibtoolize # for Solaris
+
+ # failing test, https://bugs.freedesktop.org/show_bug.cgi?id=89190
+ sed -e 's#tests/arabic-fallback-shaping.tests##' -i test/shaping/Makefile.in || die "sed failed"
}
multilib_src_configure() {
ECONF_SOURCE="${S}" \
+ # harfbuzz-gobject only used for instrospection, bug #535852
econf \
--without-coretext \
--without-uniscribe \
$(use_enable static-libs static) \
$(multilib_native_use_with cairo) \
$(use_with glib) \
- $(use_with glib gobject) \
+ $(use_with introspection gobject) \
$(use_with graphite graphite2) \
$(use_with icu) \
$(multilib_native_use_enable introspection) \