summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-01-17 10:57:45 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-01-17 10:57:45 +0000
commit9ede8728e8e6db5b1d311f5d0991c0c5e04bb882 (patch)
tree57e7a1ca8fca7ee2009febea000c9ec6957e8e58 /media-libs/ladspa-cmt/ladspa-cmt-1.15.ebuild
parentNew version, 2.8. Fixed copyright headers. Added to text-markup herd (Manifes... (diff)
downloadgentoo-2-9ede8728e8e6db5b1d311f5d0991c0c5e04bb882.tar.gz
gentoo-2-9ede8728e8e6db5b1d311f5d0991c0c5e04bb882.tar.bz2
gentoo-2-9ede8728e8e6db5b1d311f5d0991c0c5e04bb882.zip
more Gentoo-like doc install (bug 38486); more error checking/messages; use sed -i; leave $P alone; use $A in unpack
Diffstat (limited to 'media-libs/ladspa-cmt/ladspa-cmt-1.15.ebuild')
-rw-r--r--media-libs/ladspa-cmt/ladspa-cmt-1.15.ebuild45
1 files changed, 22 insertions, 23 deletions
diff --git a/media-libs/ladspa-cmt/ladspa-cmt-1.15.ebuild b/media-libs/ladspa-cmt/ladspa-cmt-1.15.ebuild
index cd3c49f24ea7..84d6e239c460 100644
--- a/media-libs/ladspa-cmt/ladspa-cmt-1.15.ebuild
+++ b/media-libs/ladspa-cmt/ladspa-cmt-1.15.ebuild
@@ -1,41 +1,40 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/ladspa-cmt/ladspa-cmt-1.15.ebuild,v 1.5 2004/01/14 21:31:16 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/ladspa-cmt/ladspa-cmt-1.15.ebuild,v 1.6 2004/01/17 10:57:30 mr_bones_ Exp $
-S=${WORKDIR}/cmt/src
-P=cmt_src_${PV}
+S="${WORKDIR}/cmt/src"
+MY_P="cmt_src_${PV}"
DESCRIPTION="CMT (computer music toolkit) Lasdpa library plugins"
HOMEPAGE="http://www.ladspa.org/"
-LICENSE="LGPL-2.1"
-DEPEND="media-libs/ladspa-sdk"
-SRC_URI="http://www.ladspa.org/download/${P}.tgz"
-KEYWORDS="x86"
+SRC_URI="http://www.ladspa.org/download/${MY_P}.tgz"
+KEYWORDS="x86"
+LICENSE="LGPL-2.1"
SLOT="0"
+IUSE=""
+
+DEPEND="media-libs/ladspa-sdk
+ >=sys-apps/sed-4"
src_unpack() {
- unpack "${P}.tgz"
+ unpack "${A}"
cd "${S}"
- sed -e "/^CFLAGS/ s/-O3/${CFLAGS}/" \
+ sed -i \
+ -e "/^CFLAGS/ s/-O3/${CFLAGS}/" \
-e 's|/usr/local/include||g' \
- -e 's|/usr/local/lib||g' \
- makefile > makefile.new
- mv makefile.new makefile
-
+ -e 's|/usr/local/lib||g' makefile \
+ || die "sed makefile failed"
}
+
src_compile() {
- emake || die
+ emake || die "emake failed"
}
src_install() {
-
- dodoc ../doc/*
- insinto /usr/lib/ladspa
INSOPTIONS="-m755"
- doins ../plugins/*.so
-
-
-
+ insinto /usr/lib/ladspa
+ doins ../plugins/*.so || die "doins failed"
+ dodoc ../README || die "dodoc failed"
+ dohtml ../doc/* || die "dohtml failed"
}
-