summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2002-01-04 17:12:47 +0000
committerMikael Hallendal <hallski@gentoo.org>2002-01-04 17:12:47 +0000
commitdf491bb0ac4e9215904d83715deae18d842a6a9f (patch)
tree47920d8d2e27e42fc008e567ff44d11fb65ba2b5 /media-libs/libao
parentAdding sendmail to package.mask until it's complete. (diff)
downloadgentoo-2-df491bb0ac4e9215904d83715deae18d842a6a9f.tar.gz
gentoo-2-df491bb0ac4e9215904d83715deae18d842a6a9f.tar.bz2
gentoo-2-df491bb0ac4e9215904d83715deae18d842a6a9f.zip
updated to 0.8.2
Diffstat (limited to 'media-libs/libao')
-rw-r--r--media-libs/libao/files/digest-libao-0.8.21
-rw-r--r--media-libs/libao/libao-0.8.2.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/media-libs/libao/files/digest-libao-0.8.2 b/media-libs/libao/files/digest-libao-0.8.2
new file mode 100644
index 000000000000..f0accfc8826e
--- /dev/null
+++ b/media-libs/libao/files/digest-libao-0.8.2
@@ -0,0 +1 @@
+MD5 98b4eca7851a6650e639b9858db89e6e libao-0.8.2.tar.gz 208896
diff --git a/media-libs/libao/libao-0.8.2.ebuild b/media-libs/libao/libao-0.8.2.ebuild
new file mode 100644
index 000000000000..c3793e3d9336
--- /dev/null
+++ b/media-libs/libao/libao-0.8.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Peter Gavin <pbg1854@garnet.acns.fsu.edu>
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libao/libao-0.8.2.ebuild,v 1.1 2002/01/04 17:12:47 hallski Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="the audio output library"
+SRC_URI="http://www.vorbis.com/files/rc3/unix/${PN}-${PV}.tar.gz"
+HOMEPAGE="http://www.xiph.org/ogg/vorbis/index.html"
+
+DEPEND="virtual/glibc
+ esd? ( >=media-sound/esound-0.2.22 )"
+
+src_compile() {
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --enable-shared \
+ --enable-static || die
+
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+
+ rm -rf ${D}/usr/share/doc
+ dodoc AUTHORS CHANGES COPYING README TODO
+ dodoc doc/API doc/DRIVERS doc/USAGE doc/WANTED
+}