summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefaan De Roeck <stefaan@gentoo.org>2009-08-23 12:56:45 +0000
committerStefaan De Roeck <stefaan@gentoo.org>2009-08-23 12:56:45 +0000
commit0381e61ab29788ed7c1c33edfe792954d61405bc (patch)
treed16c3a65e64a7db6d07eb7a3f8458d59ccd0e32f /media-libs/libdc1394/libdc1394-2.1.2.ebuild
parentUse -j1 for make (bug #282425). (diff)
downloadgentoo-2-0381e61ab29788ed7c1c33edfe792954d61405bc.tar.gz
gentoo-2-0381e61ab29788ed7c1c33edfe792954d61405bc.tar.bz2
gentoo-2-0381e61ab29788ed7c1c33edfe792954d61405bc.zip
Version bump to 2.1.2, as per bug #282249
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/libdc1394/libdc1394-2.1.2.ebuild')
-rw-r--r--media-libs/libdc1394/libdc1394-2.1.2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/media-libs/libdc1394/libdc1394-2.1.2.ebuild b/media-libs/libdc1394/libdc1394-2.1.2.ebuild
new file mode 100644
index 000000000000..001d5a6ed22d
--- /dev/null
+++ b/media-libs/libdc1394/libdc1394-2.1.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libdc1394/libdc1394-2.1.2.ebuild,v 1.1 2009/08/23 12:56:45 stefaan Exp $
+
+inherit eutils
+
+DESCRIPTION="Library to interface with IEEE 1394 cameras following the IIDC specification"
+HOMEPAGE="http://sourceforge.net/projects/libdc1394/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="X doc"
+
+RDEPEND=">=sys-libs/libraw1394-1.2.0
+ X? ( x11-libs/libSM x11-libs/libXv )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_compile() {
+ local myconf=""
+
+ econf \
+ --program-suffix=2 \
+ $(use_with X x) \
+ $(use_enable doc doxygen-html) \
+ ${myconf} \
+ || die "econf failed"
+ emake || die "emake failed"
+ if use doc ; then
+ emake doc || die "emake doc failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ dodoc NEWS README AUTHORS ChangeLog
+ use doc && dohtml doc/html/*
+}