summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2008-11-25 15:26:36 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2008-11-25 15:26:36 +0000
commitabd4d6fa0f44db71faea7bd763f5725bf0bc3773 (patch)
treeb9aecb41872f24d317fadfe1c8c35dbe7ab5c999 /media-libs/libdsp/files
parentarm stable (diff)
downloadgentoo-2-abd4d6fa0f44db71faea7bd763f5725bf0bc3773.tar.gz
gentoo-2-abd4d6fa0f44db71faea7bd763f5725bf0bc3773.tar.bz2
gentoo-2-abd4d6fa0f44db71faea7bd763f5725bf0bc3773.zip
Remove unused and broken versions wrt #239810. Fix building of 5.0.2 with GCC 4.3.
(Portage version: 2.2_rc15/cvs/Linux 2.6.27-gentoo-r3 i686)
Diffstat (limited to 'media-libs/libdsp/files')
-rw-r--r--media-libs/libdsp/files/Makefile.patch53
-rw-r--r--media-libs/libdsp/files/libdsp-5.0.2-gcc43.patch11
2 files changed, 11 insertions, 53 deletions
diff --git a/media-libs/libdsp/files/Makefile.patch b/media-libs/libdsp/files/Makefile.patch
deleted file mode 100644
index b4a69d176b60..000000000000
--- a/media-libs/libdsp/files/Makefile.patch
+++ /dev/null
@@ -1,53 +0,0 @@
---- libDSP/Makefile.old 2004-07-29 14:11:11.843296616 +0900
-+++ libDSP/Makefile 2004-07-29 14:50:34.059185216 +0900
-@@ -29,14 +29,9 @@
- #CFLAGS = -march=athlon-tbird -mcpu=athlon-xp -m3dnow # -msse -mfpmath=sse
- #CFLAGS = -march=pentium3 -mcpu=pentium3 -msse -mfpmath=sse
- #CFLAGS = -march=pentium4 -mcpu=pentium4 -msse2 -mfpmath=sse -m128bit-long-double
--CFLAGS += -O3 -ffast-math -funroll-loops -fprefetch-loop-arrays -Wall -Werror #-g
--CFLAGS += -ftracer
--OPTCFLAGS = -march=pentium2 -mcpu=pentium4 -mmmx
- #OPTCFLAGS = -march=athlon-tbird -mcpu=athlon-xp -m3dnow
- #OPTCFLAGS = -march=pentium3 -mcpu=pentium3 -msse
- #OPTCFLAGS = -march=pentium4 -mcpu=pentium4 -msse2 -m128bit-long-double
--OPTCFLAGS += -O3 -ffast-math -funroll-loops -fprefetch-loop-arrays -Wall -Werror #-g
--OPTCFLAGS += -ftracer
- CXXFLAGS = $(CFLAGS)
-
- # thread safety
-@@ -52,7 +47,7 @@
- # define for Intel Integrated Performance Primitives support
- #DEFS += -DDSP_IPP
-
--INCS = -I. #-I/usr/local/include
-+INCS = -I. -I../Inlines #-I/usr/local/include
- #INCS += `pkg-config --cflags fftw3f fftw3`
- #INCS += -I/opt/intel/ipp/include
-
-@@ -154,7 +149,7 @@
- $(LIBTOOL) --mode=compile $(CXX) $(CXXFLAGS) $(DEFS) $(INCS) -c $<
-
- X86.$(OBJ): X86.$(CSRC)
-- $(LIBTOOL) --mode=compile $(CC) $(OPTCFLAGS) $(DEFS) $(INCS) -c $<
-+ $(LIBTOOL) --mode=compile $(CC) $(CFLAGS) $(DEFS) $(INCS) -c $<
-
- libdsp.la: $(OBJS)
- $(LIBTOOL) --mode=link $(CXX) $(LDFLAGS) -rpath $(TGPREFIX)/lib -version-info $(VERSION) -o libdsp.la $(LOBJS) $(LIBS)
---- DynThreads/Makefile.old 2004-07-29 14:14:35.034406872 +0900
-+++ DynThreads/Makefile 2004-07-29 14:51:14.760997600 +0900
-@@ -21,7 +21,7 @@
- CXXFLAGS = -march=pentium2 -mcpu=athlon-xp -O2 -Wall -Werror #-ggdb
- DEFS = -D_REENTRANT -D_THREAD_SAFE
- #DEFS += -DUSE_NPTL
--INCS = #-I/usr/local/include
-+INCS = -I. -I../Inlines #-I/usr/local/include
- LIBS = -lpthread
-
- PREFIX = /usr/local
-@@ -57,6 +57,3 @@
-
- DynThreads.dep: $(SRCS)
- $(CXX) -MM $(DEFS) $(INCS) $(SRCS) >DynThreads.dep
--
--include DynThreads.dep
--
diff --git a/media-libs/libdsp/files/libdsp-5.0.2-gcc43.patch b/media-libs/libdsp/files/libdsp-5.0.2-gcc43.patch
new file mode 100644
index 000000000000..6a9da33dad59
--- /dev/null
+++ b/media-libs/libdsp/files/libdsp-5.0.2-gcc43.patch
@@ -0,0 +1,11 @@
+diff -ur libdsp-src-5.0.2.orig/Inlines-1.4.0/Alloc.hh libdsp-src-5.0.2/Inlines-1.4.0/Alloc.hh
+--- libdsp-src-5.0.2.orig/Inlines-1.4.0/Alloc.hh 2005-03-26 22:29:01.000000000 +0200
++++ libdsp-src-5.0.2/Inlines-1.4.0/Alloc.hh 2008-11-25 17:17:26.000000000 +0200
+@@ -21,6 +21,7 @@
+
+
+ #include <stdlib.h>
++#include <string.h>
+ #include <sys/types.h>
+ #include <sys/mman.h>
+ #include <string>