summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-07-30 12:48:13 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-07-30 12:48:13 +0000
commit310eecc3b2ad24d51ae00a2416988c125af5a027 (patch)
tree8efaf343097e247150e3f09690e535bbc2c8cd09 /media-libs/libdvdnav
parentMigrate to multilib, modernize -9999 ebuild and slat it for medialibs-r5. (diff)
downloadgentoo-2-310eecc3b2ad24d51ae00a2416988c125af5a027.tar.gz
gentoo-2-310eecc3b2ad24d51ae00a2416988c125af5a027.tar.bz2
gentoo-2-310eecc3b2ad24d51ae00a2416988c125af5a027.zip
Migrate to multilib, modernize -9999 ebuild and slat it for medialibs-r5.
(Portage version: 2.2.0_alpha191/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'media-libs/libdvdnav')
-rw-r--r--media-libs/libdvdnav/ChangeLog10
-rw-r--r--media-libs/libdvdnav/libdvdnav-4.2.0-r1.ebuild47
-rw-r--r--media-libs/libdvdnav/libdvdnav-9999.ebuild49
3 files changed, 85 insertions, 21 deletions
diff --git a/media-libs/libdvdnav/ChangeLog b/media-libs/libdvdnav/ChangeLog
index 38de2cef0e8a..609a2fd6d252 100644
--- a/media-libs/libdvdnav/ChangeLog
+++ b/media-libs/libdvdnav/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/libdvdnav
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libdvdnav/ChangeLog,v 1.70 2012/05/17 14:37:58 aballier Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libdvdnav/ChangeLog,v 1.71 2013/07/30 12:48:13 aballier Exp $
+
+*libdvdnav-4.2.0-r1 (30 Jul 2013)
+
+ 30 Jul 2013; Alexis Ballier <aballier@gentoo.org> +libdvdnav-4.2.0-r1.ebuild,
+ libdvdnav-9999.ebuild:
+ Migrate to multilib, modernize -9999 ebuild and slat it for medialibs-r5.
17 May 2012; Alexis Ballier <aballier@gentoo.org> libdvdnav-4.2.0.ebuild:
keyword ~amd64-fbsd
diff --git a/media-libs/libdvdnav/libdvdnav-4.2.0-r1.ebuild b/media-libs/libdvdnav/libdvdnav-4.2.0-r1.ebuild
new file mode 100644
index 000000000000..05bb75819a43
--- /dev/null
+++ b/media-libs/libdvdnav/libdvdnav-4.2.0-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libdvdnav/libdvdnav-4.2.0-r1.ebuild,v 1.1 2013/07/30 12:48:13 aballier Exp $
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=1
+AUTOTOOLS_PRUNE_LIBTOOL_FILES=all
+
+SCM=""
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="subversion"
+ ESVN_REPO_URI="svn://svn.mplayerhq.hu/dvdnav/trunk/libdvdnav"
+ ESVN_PROJECT="libdvdnav"
+ SRC_URI=""
+else
+ SRC_URI="http://dvdnav.mplayerhq.hu/releases/${P}.tar.bz2"
+fi
+
+inherit autotools-multilib ${SCM}
+
+DESCRIPTION="Library for DVD navigation tools"
+HOMEPAGE="http://dvdnav.mplayerhq.hu/"
+
+LICENSE="GPL-2"
+SLOT="0"
+if [ "${PV#9999}" = "${PV}" ] ; then
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+else
+ KEYWORDS=""
+fi
+IUSE=""
+RDEPEND=">=media-libs/libdvdread-4.2[${MULTILIB_USEDEP}]
+ abi_x86_32? ( !<=app-emulation/emul-linux-x86-medialibs-20130224-r4
+ !app-emulation/emul-linux-x86-medialibs[-abi_x86_32(-)] )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig" # To get pkg.m4 for eautoreconf #414391
+
+DOCS=( AUTHORS ChangeLog DEVELOPMENT-POLICY.txt doc/dvd_structures NEWS README TODO )
+
+PATCHES=( "${FILESDIR}"/${PN}-4.2.0-pkgconfig.patch )
+
+src_prepare() {
+ [ "${PV#9999}" != "${PV}" ] && subversion_src_prepare
+ autotools-multilib_src_prepare
+}
diff --git a/media-libs/libdvdnav/libdvdnav-9999.ebuild b/media-libs/libdvdnav/libdvdnav-9999.ebuild
index 158e03d0f582..87042dab5ced 100644
--- a/media-libs/libdvdnav/libdvdnav-9999.ebuild
+++ b/media-libs/libdvdnav/libdvdnav-9999.ebuild
@@ -1,36 +1,47 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libdvdnav/libdvdnav-9999.ebuild,v 1.7 2012/05/15 17:03:16 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libdvdnav/libdvdnav-9999.ebuild,v 1.8 2013/07/30 12:48:13 aballier Exp $
-EAPI=4
-WANT_AUTOCONF=2.5
+EAPI=5
-inherit autotools eutils subversion
+AUTOTOOLS_AUTORECONF=1
+AUTOTOOLS_PRUNE_LIBTOOL_FILES=all
+
+SCM=""
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="subversion"
+ ESVN_REPO_URI="svn://svn.mplayerhq.hu/dvdnav/trunk/libdvdnav"
+ ESVN_PROJECT="libdvdnav"
+ SRC_URI=""
+else
+ SRC_URI="http://dvdnav.mplayerhq.hu/releases/${P}.tar.bz2"
+fi
+
+inherit autotools-multilib ${SCM}
DESCRIPTION="Library for DVD navigation tools"
HOMEPAGE="http://dvdnav.mplayerhq.hu/"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS=""
+if [ "${PV#9999}" = "${PV}" ] ; then
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+else
+ KEYWORDS=""
+fi
IUSE=""
-
-RDEPEND=">=media-libs/libdvdread-${PV}"
+RDEPEND=">=media-libs/libdvdread-4.2[${MULTILIB_USEDEP}]
+ abi_x86_32? ( !<=app-emulation/emul-linux-x86-medialibs-20130224-r4
+ !app-emulation/emul-linux-x86-medialibs[-abi_x86_32(-)] )"
DEPEND="${RDEPEND}
virtual/pkgconfig" # To get pkg.m4 for eautoreconf #414391
-DOCS=( AUTHORS DEVELOPMENT-POLICY.txt ChangeLog TODO doc/dvd_structures README )
+DOCS=( AUTHORS ChangeLog DEVELOPMENT-POLICY.txt doc/dvd_structures NEWS README TODO )
-ESVN_REPO_URI="svn://svn.mplayerhq.hu/dvdnav/trunk/libdvdnav"
-ESVN_PROJECT="libdvdnav"
+PATCHES=( "${FILESDIR}"/${PN}-4.2.0-pkgconfig.patch )
src_prepare() {
- subversion_src_prepare
- epatch "${FILESDIR}"/${PN}-4.2.0-pkgconfig.patch
- eautoreconf
-}
-
-src_install() {
- default
- rm -f "${ED}"usr/lib*/${PN}*.la
+ [ "${PV#9999}" != "${PV}" ] && subversion_src_prepare
+ autotools-multilib_src_prepare
}