summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2012-03-15 17:33:12 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2012-03-15 17:33:12 +0000
commitf9c55df670cb71afa9c72c947e5a166e81031f71 (patch)
tree64b7ac33ee0fedec61e718f5264f2783e2223a82 /media-libs/libmad
parentAdd missing build dep app-arch/unzip. #372621 (diff)
downloadgentoo-2-f9c55df670cb71afa9c72c947e5a166e81031f71.tar.gz
gentoo-2-f9c55df670cb71afa9c72c947e5a166e81031f71.tar.bz2
gentoo-2-f9c55df670cb71afa9c72c947e5a166e81031f71.zip
Slightly polish the ebuild as it is supposed to be eapi4 so it does not need to contain most of the stuff.
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/libmad')
-rw-r--r--media-libs/libmad/ChangeLog8
-rw-r--r--media-libs/libmad/libmad-0.15.1b-r7.ebuild35
2 files changed, 24 insertions, 19 deletions
diff --git a/media-libs/libmad/ChangeLog b/media-libs/libmad/ChangeLog
index a70681864b2e..c056d5d12e91 100644
--- a/media-libs/libmad/ChangeLog
+++ b/media-libs/libmad/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/libmad
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libmad/ChangeLog,v 1.63 2011/08/21 03:05:59 mattst88 Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libmad/ChangeLog,v 1.64 2012/03/15 17:33:12 scarabeus Exp $
+
+ 15 Mar 2012; Tomáš Chvátal <scarabeus@gentoo.org> libmad-0.15.1b-r7.ebuild:
+ Slightly polish the ebuild as it is supposed to be eapi4 so it does not need
+ to contain most of the stuff.
21 Aug 2011; Matt Turner <mattst88@gentoo.org> libmad-0.15.1b-r7.ebuild:
Added USE=static-libs (bug 378325), also bump to EAPI4.
diff --git a/media-libs/libmad/libmad-0.15.1b-r7.ebuild b/media-libs/libmad/libmad-0.15.1b-r7.ebuild
index 812e721bdbf3..c8d3b8af0f9e 100644
--- a/media-libs/libmad/libmad-0.15.1b-r7.ebuild
+++ b/media-libs/libmad/libmad-0.15.1b-r7.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libmad/libmad-0.15.1b-r7.ebuild,v 1.2 2011/08/21 03:05:59 mattst88 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libmad/libmad-0.15.1b-r7.ebuild,v 1.3 2012/03/15 17:33:12 scarabeus Exp $
EAPI=4
@@ -12,16 +12,19 @@ SRC_URI="mirror://sourceforge/mad/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+KEYWORDS="~alpha amd64 ~arm ~hppa ~ia64 ~mips ppc ~ppc64 ~sh ~sparc x86 ~x86-fbsd"
IUSE="debug static-libs"
DEPEND=""
RDEPEND=""
+DOCS="CHANGES CREDITS README TODO VERSION"
+
src_prepare() {
- epatch "${FILESDIR}"/libmad-0.15.1b-cflags.patch
- epatch "${FILESDIR}"/libmad-0.15.1b-cflags-O2.patch
- epatch "${FILESDIR}"/libmad-0.15.1b-gcc44-mips-h-constraint-removal.patch
+ epatch \
+ "${FILESDIR}"/libmad-0.15.1b-cflags.patch \
+ "${FILESDIR}"/libmad-0.15.1b-cflags-O2.patch \
+ "${FILESDIR}"/libmad-0.15.1b-gcc44-mips-h-constraint-removal.patch
eautoreconf
@@ -38,23 +41,21 @@ src_configure() {
# Fix for b0rked sound on sparc64 (maybe also sparc32?)
# default/approx is also possible, uses less cpu but sounds worse
- use sparc && myconf="${myconf} --enable-fpm=64bit"
+ use sparc && myconf+=" --enable-fpm=64bit"
- [[ $(tc-arch) == "amd64" ]] && myconf="${myconf} --enable-fpm=64bit"
- [[ $(tc-arch) == "x86" ]] && myconf="${myconf} --enable-fpm=intel"
- [[ $(tc-arch) == "ppc" ]] && myconf="${myconf} --enable-fpm=default"
- [[ $(tc-arch) == "ppc64" ]] && myconf="${myconf} --enable-fpm=64bit"
+ [[ $(tc-arch) == "amd64" ]] && myconf+=" --enable-fpm=64bit"
+ [[ $(tc-arch) == "x86" ]] && myconf+=" --enable-fpm=intel"
+ [[ $(tc-arch) == "ppc" ]] && myconf+=" --enable-fpm=default"
+ [[ $(tc-arch) == "ppc64" ]] && myconf+=" --enable-fpm=64bit"
econf \
$(use_enable debug debugging) \
$(use_enable static-libs static) \
- ${myconf} || die "configure failed"
+ ${myconf}
}
src_install() {
- emake install DESTDIR="${D}" || die "make install failed"
-
- dodoc CHANGES CREDITS README TODO VERSION
+ default
# This file must be updated with each version update
insinto /usr/$(get_libdir)/pkgconfig
@@ -62,7 +63,7 @@ src_install() {
# Use correct libdir in pkgconfig file
sed -i -e "s:^libdir.*:libdir=/usr/$(get_libdir):" \
- "${D}"/usr/$(get_libdir)/pkgconfig/mad.pc
+ "${ED}"/usr/$(get_libdir)/pkgconfig/mad.pc
- find "${D}" -name '*.la' -delete
+ find "${ED}" -name '*.la' -delete
}