summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-01-08 18:41:25 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-01-08 18:41:25 +0000
commitbbb7991f8b0b520e8b6d09660501ea741df7d762 (patch)
treef30ee5af103bf0b9e5a9e06cbf0376a8515fd17f /media-libs/libmnote/libmnote-0.5.6.ebuild
parentremoved !x11-libs/xft from depend, added -no-xft to configure (diff)
downloadgentoo-2-bbb7991f8b0b520e8b6d09660501ea741df7d762.tar.gz
gentoo-2-bbb7991f8b0b520e8b6d09660501ea741df7d762.tar.bz2
gentoo-2-bbb7991f8b0b520e8b6d09660501ea741df7d762.zip
Initial version.
Diffstat (limited to 'media-libs/libmnote/libmnote-0.5.6.ebuild')
-rw-r--r--media-libs/libmnote/libmnote-0.5.6.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/media-libs/libmnote/libmnote-0.5.6.ebuild b/media-libs/libmnote/libmnote-0.5.6.ebuild
new file mode 100644
index 000000000000..943e00c785cc
--- /dev/null
+++ b/media-libs/libmnote/libmnote-0.5.6.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libmnote/libmnote-0.5.6.ebuild,v 1.1 2003/01/08 18:41:25 mholzer Exp $
+
+inherit flag-o-matic
+
+IUSE="nls"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="libmnote is a library for parsing, editing, and saving MakerNote-EXIF-tags."
+SRC_URI="mirror://sourceforge/libexif/${P}.tar.gz"
+HOMEPAGE="http://libexif.sf.net/"
+
+SLOT="0"
+LICENSE="LGPL"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+
+DEPEND="dev-util/pkgconfig
+ >=media-libs/libexif-0.5.9"
+
+src_compile() {
+ local myconf
+ use nls || myconf="${myconf} --disable-nls"
+ econf ${myconf}
+ emake || die
+}
+
+src_install() {
+ dodir /usr/lib
+ dodir /usr/include/libmnote
+ dodir /usr/share/locale
+ dodir /usr/lib/pkgconfig
+ einstall || die
+}