summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Crête <tester@gentoo.org>2005-12-20 14:29:22 +0000
committerOlivier Crête <tester@gentoo.org>2005-12-20 14:29:22 +0000
commit2e06a9bb8e09ecdcc63778737b0e1fb198825ac3 (patch)
tree3fc757154bd511ace1efd8c85f8ee8997eb9d332 /media-libs/libmp4v2
parentremove stable ppc64 keyword from partimae (diff)
downloadgentoo-2-2e06a9bb8e09ecdcc63778737b0e1fb198825ac3.tar.gz
gentoo-2-2e06a9bb8e09ecdcc63778737b0e1fb198825ac3.tar.bz2
gentoo-2-2e06a9bb8e09ecdcc63778737b0e1fb198825ac3.zip
Remove check for faac
(Portage version: 2.0.51.22-r3)
Diffstat (limited to 'media-libs/libmp4v2')
-rw-r--r--media-libs/libmp4v2/ChangeLog6
-rw-r--r--media-libs/libmp4v2/files/mpeg4ip-1.4.1-disable-faac-test.patch38
-rw-r--r--media-libs/libmp4v2/libmp4v2-1.4.1.ebuild9
3 files changed, 51 insertions, 2 deletions
diff --git a/media-libs/libmp4v2/ChangeLog b/media-libs/libmp4v2/ChangeLog
index 9d8d8090e450..732029a1ca95 100644
--- a/media-libs/libmp4v2/ChangeLog
+++ b/media-libs/libmp4v2/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for <CATEGORY>/<PACKAGE_NAME>
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libmp4v2/ChangeLog,v 1.2 2005/12/20 09:17:05 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libmp4v2/ChangeLog,v 1.3 2005/12/20 14:29:22 tester Exp $
+
+ 20 Dec 2005; Olivier Crête <tester@gentoo.org>
+ +files/mpeg4ip-1.4.1-disable-faac-test.patch, libmp4v2-1.4.1.ebuild:
+ Remove check for faac
20 Dec 2005; Diego Pettenò <flameeyes@gentoo.org> libmp4v2-1.4.1.ebuild:
Add missing multilib inherit for $(get_libdir).
diff --git a/media-libs/libmp4v2/files/mpeg4ip-1.4.1-disable-faac-test.patch b/media-libs/libmp4v2/files/mpeg4ip-1.4.1-disable-faac-test.patch
new file mode 100644
index 000000000000..f86539260de3
--- /dev/null
+++ b/media-libs/libmp4v2/files/mpeg4ip-1.4.1-disable-faac-test.patch
@@ -0,0 +1,38 @@
+--- bootstrap.orig 2005-12-20 09:02:57.000000000 -0500
++++ bootstrap 2005-12-20 09:17:09.000000000 -0500
+@@ -45,35 +45,6 @@
+ fi
+
+ allargs="$@"
+-#
+-# Test for faac and possible error
+-#
+-if test $target_system = "Linux"; then
+- have_faac=no
+- if which faac >/dev/null 2>/dev/null; then
+- have_faac=yes
+- fi
+-
+- if test $have_faac = "yes"; then
+- # we have lame and faac - see if faac is built with mp4 support
+- faac --help >&faac_help
+- sdf=`grep "MP4 support unavailable" faac_help`
+- rm -f faac_help
+- if test -z "$sdf"; then
+- if which mpeg4ip-config >/dev/null 2>/dev/null; then
+- echo "Warning - faac uses libmp4v, but we've detected a version"
+- echo "of mpeg4ip. If you get errors building mp4live, please"
+- echo "rebuild faac without mp4v2 support"
+- else
+- echo "Error - we have detected a version of faac that has libmp4v2 support"
+- echo "and no copy of mpeg4ip-config. This means faac was built with"
+- echo "faad2 and the libraries will be incompatible".
+- echo "Please reinstall faac without mp4v2 support"
+- exit 1
+- fi
+- fi
+- fi
+-fi
+ set -x
+
+ # if src tree is created via cvs export to tar.gz
diff --git a/media-libs/libmp4v2/libmp4v2-1.4.1.ebuild b/media-libs/libmp4v2/libmp4v2-1.4.1.ebuild
index 2408dcb5b32d..2befc6b2c138 100644
--- a/media-libs/libmp4v2/libmp4v2-1.4.1.ebuild
+++ b/media-libs/libmp4v2/libmp4v2-1.4.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libmp4v2/libmp4v2-1.4.1.ebuild,v 1.3 2005/12/20 13:57:00 tester Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libmp4v2/libmp4v2-1.4.1.ebuild,v 1.4 2005/12/20 14:29:22 tester Exp $
inherit multilib
@@ -19,6 +19,13 @@ RDEPEND="!<media-video/mpeg4ip-1.4.1
S=${WORKDIR}/mpeg4ip-${PV}
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/mpeg4ip-${PV}-disable-faac-test.patch
+}
+
src_compile() {
cd ${S}