summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-12-30 07:24:23 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-12-30 07:24:23 +0000
commit6f4ac168f67dbda0a6bb38942453540eb37e8db5 (patch)
tree0fe951351fcd1bafa8830afdcb95b0d3105279df /media-libs/libmpeg3
parentremove old (diff)
downloadgentoo-2-6f4ac168f67dbda0a6bb38942453540eb37e8db5.tar.gz
gentoo-2-6f4ac168f67dbda0a6bb38942453540eb37e8db5.tar.bz2
gentoo-2-6f4ac168f67dbda0a6bb38942453540eb37e8db5.zip
Convert to multilib, bug #496382. Fix implicit declaration of free().
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'media-libs/libmpeg3')
-rw-r--r--media-libs/libmpeg3/ChangeLog8
-rw-r--r--media-libs/libmpeg3/files/libmpeg3-1.8-impldecl.patch24
-rw-r--r--media-libs/libmpeg3/libmpeg3-1.8-r1.ebuild61
3 files changed, 92 insertions, 1 deletions
diff --git a/media-libs/libmpeg3/ChangeLog b/media-libs/libmpeg3/ChangeLog
index 11fa444adb2d..7e9884d5051c 100644
--- a/media-libs/libmpeg3/ChangeLog
+++ b/media-libs/libmpeg3/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/libmpeg3
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libmpeg3/ChangeLog,v 1.81 2013/12/30 07:16:15 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libmpeg3/ChangeLog,v 1.82 2013/12/30 07:24:22 aballier Exp $
+
+*libmpeg3-1.8-r1 (30 Dec 2013)
+
+ 30 Dec 2013; Alexis Ballier <aballier@gentoo.org> +libmpeg3-1.8-r1.ebuild,
+ +files/libmpeg3-1.8-impldecl.patch:
+ Convert to multilib, bug #496382. Fix implicit declaration of free().
30 Dec 2013; Alexis Ballier <aballier@gentoo.org> -libmpeg3-1.7.ebuild,
-files/libmpeg3-1.7-memcpy.patch:
diff --git a/media-libs/libmpeg3/files/libmpeg3-1.8-impldecl.patch b/media-libs/libmpeg3/files/libmpeg3-1.8-impldecl.patch
new file mode 100644
index 000000000000..632537b87191
--- /dev/null
+++ b/media-libs/libmpeg3/files/libmpeg3-1.8-impldecl.patch
@@ -0,0 +1,24 @@
+Index: libmpeg3-1.8/audio/ac3.c
+===================================================================
+--- libmpeg3-1.8.orig/audio/ac3.c
++++ libmpeg3-1.8/audio/ac3.c
+@@ -6,6 +6,7 @@
+ #include "mpeg3protos.h"
+
+ #include <string.h>
++#include <stdlib.h>
+
+
+ mpeg3_ac3_t* mpeg3_new_ac3()
+Index: libmpeg3-1.8/audio/layer3.c
+===================================================================
+--- libmpeg3-1.8.orig/audio/layer3.c
++++ libmpeg3-1.8/audio/layer3.c
+@@ -5,6 +5,7 @@
+
+ #include <stdio.h>
+ #include <string.h>
++#include <stdlib.h>
+
+ struct gr_info_s
+ {
diff --git a/media-libs/libmpeg3/libmpeg3-1.8-r1.ebuild b/media-libs/libmpeg3/libmpeg3-1.8-r1.ebuild
new file mode 100644
index 000000000000..966f2c497acb
--- /dev/null
+++ b/media-libs/libmpeg3/libmpeg3-1.8-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libmpeg3/libmpeg3-1.8-r1.ebuild,v 1.1 2013/12/30 07:24:22 aballier Exp $
+
+EAPI=5
+
+inherit eutils autotools toolchain-funcs multilib-minimal
+
+DESCRIPTION="An mpeg library for linux"
+HOMEPAGE="http://heroinewarrior.com/libmpeg3.php"
+SRC_URI="mirror://sourceforge/heroines/${P}-src.tar.bz2
+ mirror://gentoo/${PN}-1.7-gentoo.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="mmx"
+
+RDEPEND="sys-libs/zlib
+ virtual/jpeg
+ media-libs/a52dec"
+DEPEND="${RDEPEND}
+ mmx? ( dev-lang/nasm )"
+
+src_prepare() {
+ epatch "${WORKDIR}"/${PN}-1.7-mpeg3split.patch
+ epatch "${WORKDIR}"/${PN}-1.7-textrel.patch
+ epatch "${WORKDIR}"/${PN}-1.7-gnustack.patch
+ epatch "${WORKDIR}"/${PN}-1.7-a52.patch
+ epatch "${WORKDIR}"/${PN}-1.7-all_gcc4.patch
+ epatch "${WORKDIR}"/${PN}-1.7-all_pthread.patch
+
+ epatch "${FILESDIR}/${P}-impldecl.patch"
+
+ cp -rf "${WORKDIR}"/1.7/* .
+ eautoreconf
+}
+
+multilib_src_configure() {
+ #disabling css since it's a fake one.
+ #One can find in the sources this message :
+ # Stubs for deCSS which can't be distributed in source form
+
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable mmx) \
+ --disable-css
+}
+
+multilib_src_install_all() {
+ dohtml -r docs
+ # This is a workaround, it wants to rebuild
+ # everything if the headers have changed
+ # So we patch them after install...
+ cd "${ED}/usr/include/libmpeg3"
+ # This patch patches the .h files that get installed into /usr/include
+ # to show the correct include syntax '<>' instead of '""' This patch
+ # was also generated using info from SF's src.rpm
+ epatch "${WORKDIR}"/gentoo-p2.patch
+
+ find "${ED}" -name '*.la' -exec rm -f '{}' +
+}