summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2014-09-27 21:50:58 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2014-09-27 21:50:58 +0000
commit6bd116dfd7cfa92384db620c562911d81b58e4b9 (patch)
tree942c1ebce1661f1baf1689a5379de69bc22fa075 /media-libs/libmtp
parentx86 stable wrt bug #523900 (diff)
downloadgentoo-2-6bd116dfd7cfa92384db620c562911d81b58e4b9.tar.gz
gentoo-2-6bd116dfd7cfa92384db620c562911d81b58e4b9.tar.bz2
gentoo-2-6bd116dfd7cfa92384db620c562911d81b58e4b9.zip
Version bump wrt #521888 by Dimitri Semitsoglou-Tsiapos and Maik Nijhuis
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'media-libs/libmtp')
-rw-r--r--media-libs/libmtp/ChangeLog8
-rw-r--r--media-libs/libmtp/libmtp-1.1.8.ebuild74
-rw-r--r--media-libs/libmtp/libmtp-9999.ebuild47
3 files changed, 109 insertions, 20 deletions
diff --git a/media-libs/libmtp/ChangeLog b/media-libs/libmtp/ChangeLog
index 758ad224101a..9774430e5801 100644
--- a/media-libs/libmtp/ChangeLog
+++ b/media-libs/libmtp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/libmtp
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libmtp/ChangeLog,v 1.150 2014/09/10 22:17:02 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libmtp/ChangeLog,v 1.151 2014/09/27 21:50:58 ssuominen Exp $
+
+*libmtp-1.1.8 (27 Sep 2014)
+
+ 27 Sep 2014; Samuli Suominen <ssuominen@gentoo.org> +libmtp-1.1.8.ebuild,
+ libmtp-9999.ebuild:
+ Version bump wrt #521888 by Dimitri Semitsoglou-Tsiapos and Maik Nijhuis
10 Sep 2014; Rick Farina <zerochaos@gentoo.org> libmtp-1.1.6-r1.ebuild,
libmtp-9999.ebuild:
diff --git a/media-libs/libmtp/libmtp-1.1.8.ebuild b/media-libs/libmtp/libmtp-1.1.8.ebuild
new file mode 100644
index 000000000000..250e784522e4
--- /dev/null
+++ b/media-libs/libmtp/libmtp-1.1.8.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libmtp/libmtp-1.1.8.ebuild,v 1.1 2014/09/27 21:50:58 ssuominen Exp $
+
+EAPI=5
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="git://git.code.sf.net/p/${PN}/code"
+ inherit autotools git-r3
+else
+ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~amd64-fbsd ~x86-fbsd"
+fi
+
+inherit eutils udev user
+
+DESCRIPTION="An implementation of Microsoft's Media Transfer Protocol (MTP)"
+HOMEPAGE="http://libmtp.sourceforge.net/"
+
+LICENSE="LGPL-2.1" # LGPL-2+ and LGPL-2.1+ ?
+SLOT="0/9" # Based on SONAME of libmtp shared library
+IUSE="+crypt doc examples static-libs"
+
+RDEPEND="virtual/libusb:1
+ crypt? ( >=dev-libs/libgcrypt-1.5.4:0= )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+pkg_setup() {
+ DOCS="AUTHORS README TODO"
+ enewgroup plugdev
+}
+
+src_unpack() {
+ [[ ${PV} == 9999* ]] && git-r3_src_unpack
+ default_src_unpack
+}
+
+src_prepare() {
+ # ChangeLog says "RETIRING THIS FILE ..pause.. GIT" (Last entry from start of 2011)
+ rm -f ChangeLog
+
+ if [[ ${PV} == 9999* ]]; then
+ local crpthf=config.rpath
+ local crpthd=/usr/share/gettext/${crpthf}
+ if has_version '>sys-devel/gettext-0.18.3' && [[ -e ${crpthd} ]]; then
+ cp "${crpthd}" .
+ else
+ touch ${crpthf} # This is from upstream autogen.sh
+ fi
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable doc doxygen) \
+ $(use_enable crypt mtpz) \
+ --with-udev="$(get_udevdir)" \
+ --with-udev-group=plugdev \
+ --with-udev-mode=0660
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+
+ if use examples; then
+ docinto examples
+ dodoc examples/*.{c,h,sh}
+ fi
+}
diff --git a/media-libs/libmtp/libmtp-9999.ebuild b/media-libs/libmtp/libmtp-9999.ebuild
index 3a5189053819..ad0d54572e3f 100644
--- a/media-libs/libmtp/libmtp-9999.ebuild
+++ b/media-libs/libmtp/libmtp-9999.ebuild
@@ -1,43 +1,54 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libmtp/libmtp-9999.ebuild,v 1.14 2014/09/10 22:17:02 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libmtp/libmtp-9999.ebuild,v 1.15 2014/09/27 21:50:58 ssuominen Exp $
EAPI=5
-inherit autotools eutils udev user toolchain-funcs
-
-if [[ ${PV} == *9999* ]]; then
- EGIT_REPO_URI="git://git.code.sf.net/p/libmtp/code"
- EGIT_PROJECT="libmtp"
- inherit git-2
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="git://git.code.sf.net/p/${PN}/code"
+ inherit autotools git-r3
else
- KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~amd64-fbsd"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~amd64-fbsd ~x86-fbsd"
fi
+inherit eutils udev user
+
DESCRIPTION="An implementation of Microsoft's Media Transfer Protocol (MTP)"
HOMEPAGE="http://libmtp.sourceforge.net/"
-LICENSE="LGPL-2.1"
-SLOT="0"
+LICENSE="LGPL-2.1" # LGPL-2+ and LGPL-2.1+ ?
+SLOT="0/9" # Based on SONAME of libmtp shared library
IUSE="+crypt doc examples static-libs"
RDEPEND="virtual/libusb:1
- crypt? ( dev-libs/libgcrypt:0=
- dev-libs/libgpg-error )"
+ crypt? ( >=dev-libs/libgcrypt-1.5.4:0= )"
DEPEND="${RDEPEND}
virtual/pkgconfig
doc? ( app-doc/doxygen )"
-DOCS="AUTHORS ChangeLog README TODO"
-
pkg_setup() {
+ DOCS="AUTHORS README TODO"
enewgroup plugdev
}
+src_unpack() {
+ [[ ${PV} == 9999* ]] && git-r3_src_unpack
+ default_src_unpack
+}
+
src_prepare() {
- if [[ ${PV} == *9999* ]]; then
- touch config.rpath # This is from upstream autogen.sh
+ # ChangeLog says "RETIRING THIS FILE ..pause.. GIT" (Last entry from start of 2011)
+ rm -f ChangeLog
+
+ if [[ ${PV} == 9999* ]]; then
+ local crpthf=config.rpath
+ local crpthd=/usr/share/gettext/${crpthf}
+ if has_version '>sys-devel/gettext-0.18.3' && [[ -e ${crpthd} ]]; then
+ cp "${crpthd}" .
+ else
+ touch ${crpthf} # This is from upstream autogen.sh
+ fi
eautoreconf
fi
}
@@ -54,12 +65,10 @@ src_configure() {
src_install() {
default
- prune_libtool_files
+ prune_libtool_files --all
if use examples; then
docinto examples
dodoc examples/*.{c,h,sh}
fi
-
- sed -i -e '/^Unable to open/d' "${ED}/$(get_udevdir)"/rules.d/*-libmtp.rules || die #481666
}