summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2013-02-28 07:46:00 +0000
committerMichael Weber <xmw@gentoo.org>2013-02-28 07:46:00 +0000
commit838b6f019c9d62c0b887f2f0ccaff336c9f095a7 (patch)
treed9df394d979f232ebccddc9eedd7abbc6e52b9a3 /media-libs/libnsgif
parentnetsurf eclass preparation. (diff)
downloadgentoo-2-838b6f019c9d62c0b887f2f0ccaff336c9f095a7.tar.gz
gentoo-2-838b6f019c9d62c0b887f2f0ccaff336c9f095a7.tar.bz2
gentoo-2-838b6f019c9d62c0b887f2f0ccaff336c9f095a7.zip
netsurf eclass preparation. Restore cross-compile functionality (thanks James Le Cuirot, bug 431884)
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 62EEF090)
Diffstat (limited to 'media-libs/libnsgif')
-rw-r--r--media-libs/libnsgif/ChangeLog8
-rw-r--r--media-libs/libnsgif/libnsgif-0.0.3.ebuild57
2 files changed, 43 insertions, 22 deletions
diff --git a/media-libs/libnsgif/ChangeLog b/media-libs/libnsgif/ChangeLog
index ed3b9cfe15d9..198c5ce0aaeb 100644
--- a/media-libs/libnsgif/ChangeLog
+++ b/media-libs/libnsgif/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/libnsgif
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libnsgif/ChangeLog,v 1.2 2012/07/17 23:25:46 xmw Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libnsgif/ChangeLog,v 1.3 2013/02/28 07:46:00 xmw Exp $
+
+ 28 Feb 2013; Michael Weber <xmw@gentoo.org> libnsgif-0.0.3.ebuild:
+ netsurf eclass preparation. Restore cross-compile functionality (thanks James
+ Le Cuirot, bug 431884)
17 Jul 2012; Michael Weber <xmw@gentoo.org> libnsgif-0.0.3.ebuild:
Fix typo
diff --git a/media-libs/libnsgif/libnsgif-0.0.3.ebuild b/media-libs/libnsgif/libnsgif-0.0.3.ebuild
index ad5e2d6c2a23..001465908e4b 100644
--- a/media-libs/libnsgif/libnsgif-0.0.3.ebuild
+++ b/media-libs/libnsgif/libnsgif-0.0.3.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libnsgif/libnsgif-0.0.3.ebuild,v 1.2 2012/07/17 23:25:46 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libnsgif/libnsgif-0.0.3.ebuild,v 1.3 2013/02/28 07:46:00 xmw Exp $
-EAPI=4
+EAPI=5
inherit multilib toolchain-funcs
@@ -13,34 +13,51 @@ SRC_URI="http://download.netsurf-browser.org/libs/releases/${P}-src.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm"
-IUSE="static-libs"
+IUSE="debug static-libs"
RDEPEND=""
-DEPEND=""
+DEPEND="virtual/pkgconfig"
+
+pkg_setup(){
+ netsurf_src_prepare() {
+ sed -e "/^CCOPT :=/s:=.*:=:" \
+ -e "/^CCNOOPT :=/s:=.*:=:" \
+ -e "/^CCDBG :=/s:=.*:=:" \
+ -i build/makefiles/Makefile.{gcc,clang}
+ sed -e "/^INSTALL_ITEMS/s: /lib: /$(get_libdir):g" \
+ -i Makefile || die
+ sed -e "/^libdir/s:/lib:/$(get_libdir):g" \
+ -i ${NETSURF_PKGCONFIG:-${PN}}.pc.in || die
+ }
+ netsurf_src_configure() {
+ echo "Q := " >> Makefile.config
+ echo "CC := $(tc-getCC)" >> Makefile.config
+ echo "AR := $(tc-getAR)" >> Makefile.config
+ }
+
+ netsurf_make() {
+ emake COMPONENT_TYPE=lib-shared BUILD=$(usex debug debug release) "$@"
+ use static-libs && \
+ emake COMPONENT_TYPE=lib-static BUILD=$(usex debug debug release) "$@"
+ }
+}
src_prepare() {
- sed -e "/^INSTALL_ITEMS/s: /lib: /$(get_libdir):g" \
- -e "s:-Werror::g" \
- -i Makefile || die
- sed -e "/^libdir/s:/lib:/$(get_libdir):g" \
- -i ${PN}.pc.in || die
- echo "Q := " >> Makefile.config.override
- echo "CC := $(tc-getCC)" >> Makefile.config.override
- echo "AR := $(tc-getAR)" >> Makefile.config.override
+ netsurf_src_prepare
+}
+
+src_configure() {
+ netsurf_src_configure
}
src_compile() {
- emake COMPONENT_TYPE=lib-shared
- use static-libs && emake COMPONENT_TYPE=lib-static
+ netsurf_make
}
src_test() {
- emake COMPONENT_TYPE=lib-shared test
- use static-libs && emake COMPONENT_TYPE=lib-static test
+ netsurf_make test
}
src_install() {
- emake COMPONENT_TYPE=lib-shared DESTDIR="${D}" PREFIX=/usr install
- use static-libs && \
- emake COMPONENT_TYPE=lib-static DESTDIR="${D}" PREFIX=/usr install
+ netsurf_make DESTDIR="${D}" PREFIX=/usr install
}