summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-06-01 09:00:09 +0000
committerAlexis Ballier <aballier@gentoo.org>2015-06-01 09:00:09 +0000
commit5559fc289d41888a12921ea79496d9c830b9117f (patch)
tree4a5aa7e9a211f65f216cba8b75495ef4b74b84e6 /media-libs/libsoundtouch
parentDrop old (diff)
downloadgentoo-2-5559fc289d41888a12921ea79496d9c830b9117f.tar.gz
gentoo-2-5559fc289d41888a12921ea79496d9c830b9117f.tar.bz2
gentoo-2-5559fc289d41888a12921ea79496d9c830b9117f.zip
version bump
Signed-off-by: Alexis Ballier <aballier@gentoo.org> (Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'media-libs/libsoundtouch')
-rw-r--r--media-libs/libsoundtouch/ChangeLog8
-rw-r--r--media-libs/libsoundtouch/libsoundtouch-1.9.0.ebuild50
2 files changed, 57 insertions, 1 deletions
diff --git a/media-libs/libsoundtouch/ChangeLog b/media-libs/libsoundtouch/ChangeLog
index 11045ca56951..593d74901f69 100644
--- a/media-libs/libsoundtouch/ChangeLog
+++ b/media-libs/libsoundtouch/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/libsoundtouch
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libsoundtouch/ChangeLog,v 1.87 2015/02/25 15:29:33 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsoundtouch/ChangeLog,v 1.88 2015/06/01 09:00:09 aballier Exp $
+
+*libsoundtouch-1.9.0 (01 Jun 2015)
+
+ 01 Jun 2015; Alexis Ballier <aballier@gentoo.org>
+ +libsoundtouch-1.9.0.ebuild:
+ version bump
25 Feb 2015; Agostino Sarubbo <ago@gentoo.org> libsoundtouch-1.8.0-r1.ebuild:
Stable for x86, wrt bug #526018
diff --git a/media-libs/libsoundtouch/libsoundtouch-1.9.0.ebuild b/media-libs/libsoundtouch/libsoundtouch-1.9.0.ebuild
new file mode 100644
index 000000000000..d99237c0f9cb
--- /dev/null
+++ b/media-libs/libsoundtouch/libsoundtouch-1.9.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsoundtouch/libsoundtouch-1.9.0.ebuild,v 1.1 2015/06/01 09:00:09 aballier Exp $
+
+EAPI=5
+inherit autotools eutils flag-o-matic multilib-minimal
+
+MY_PN=${PN/lib}
+
+DESCRIPTION="Audio processing library for changing tempo, pitch and playback rates"
+HOMEPAGE="http://www.surina.net/soundtouch/"
+SRC_URI="http://www.surina.net/soundtouch/${P/lib}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+IUSE="cpu_flags_x86_sse openmp static-libs"
+
+DEPEND=">=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]"
+
+S=${WORKDIR}/${MY_PN}
+
+src_prepare() {
+ use openmp && { tc-has-openmp || die "Please switch to an openmp compatible compiler"; }
+ sed -i "s:^\(pkgdoc_DATA=\)COPYING.TXT :\1:" Makefile.am || die
+ sed -i 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:g' configure.ac || die
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ econf \
+ --enable-shared \
+ --disable-integer-samples \
+ $(use_enable cpu_flags_x86_sse x86-optimizations) \
+ $(use_enable openmp) \
+ $(use_enable static-libs static)
+}
+
+multilib_src_compile() {
+ emake CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}"
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" pkgdocdir="${EPREFIX}"/usr/share/doc/${PF}/html install
+}
+
+multilib_src_install_all() {
+ prune_libtool_files
+}