summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Meier <maekke@gentoo.org>2009-02-07 21:11:28 +0000
committerMarkus Meier <maekke@gentoo.org>2009-02-07 21:11:28 +0000
commite56220f42ed4210f84af831fb145765f3f16ac34 (patch)
tree20759d64097e5583ed6b70c863c802cfdb0542db /media-libs/openinventor/openinventor-2.1.5.10-r3.ebuild
parentmake graphviz with tcl support work with >=dev-lang/swig-1.3.38 wrt bug #257856 (diff)
downloadgentoo-2-e56220f42ed4210f84af831fb145765f3f16ac34.tar.gz
gentoo-2-e56220f42ed4210f84af831fb145765f3f16ac34.tar.bz2
gentoo-2-e56220f42ed4210f84af831fb145765f3f16ac34.zip
respect CC etc, bug #256325
(Portage version: 2.2_rc23/cvs/Linux i686)
Diffstat (limited to 'media-libs/openinventor/openinventor-2.1.5.10-r3.ebuild')
-rw-r--r--media-libs/openinventor/openinventor-2.1.5.10-r3.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/media-libs/openinventor/openinventor-2.1.5.10-r3.ebuild b/media-libs/openinventor/openinventor-2.1.5.10-r3.ebuild
index 902fdf6e6998..1a12c78964ad 100644
--- a/media-libs/openinventor/openinventor-2.1.5.10-r3.ebuild
+++ b/media-libs/openinventor/openinventor-2.1.5.10-r3.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/openinventor/openinventor-2.1.5.10-r3.ebuild,v 1.4 2009/01/25 15:07:27 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/openinventor/openinventor-2.1.5.10-r3.ebuild,v 1.5 2009/02/07 21:11:28 maekke Exp $
-inherit eutils versionator flag-o-matic
+inherit eutils versionator flag-o-matic toolchain-funcs
MY_PV=$(replace_version_separator 3 '-')
MY_PN="inventor"
@@ -56,6 +56,13 @@ src_unpack() {
epatch "${FILESDIR}"/gcc4-support.patch
# fix bug #251681
epatch "${FILESDIR}"/bug-251681.patch
+
+ # respect CC etc
+ sed -i \
+ -e "s:CC = /usr/bin/gcc:CC = $(tc-getCC):g" \
+ -e "s:C++ = /usr/bin/g++:C++ = $(tc-getCXX):g" \
+ -e "s:LD = /usr/bin/g++:LD = $(tc-getCXX):g" \
+ make/ivcommondefs || die
}
src_compile() {