summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2014-11-02 18:54:41 +0000
committerAlexis Ballier <aballier@gentoo.org>2014-11-02 18:54:41 +0000
commit16bda3b620206d321ffbc1d8f693911a1fd3ea64 (patch)
treeb0eb408d2ff7e329f41177e493a5083053fcb2a3 /media-libs/sratom
parentversion bump (diff)
downloadgentoo-2-16bda3b620206d321ffbc1d8f693911a1fd3ea64.tar.gz
gentoo-2-16bda3b620206d321ffbc1d8f693911a1fd3ea64.tar.bz2
gentoo-2-16bda3b620206d321ffbc1d8f693911a1fd3ea64.zip
version bump
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'media-libs/sratom')
-rw-r--r--media-libs/sratom/ChangeLog7
-rw-r--r--media-libs/sratom/sratom-0.4.6.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/media-libs/sratom/ChangeLog b/media-libs/sratom/ChangeLog
index 12a2ca37f984..781f3bebbe9c 100644
--- a/media-libs/sratom/ChangeLog
+++ b/media-libs/sratom/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/sratom
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/sratom/ChangeLog,v 1.9 2014/11/02 18:49:38 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/sratom/ChangeLog,v 1.10 2014/11/02 18:54:41 aballier Exp $
+
+*sratom-0.4.6 (02 Nov 2014)
+
+ 02 Nov 2014; Alexis Ballier <aballier@gentoo.org> +sratom-0.4.6.ebuild:
+ version bump
02 Nov 2014; Alexis Ballier <aballier@gentoo.org> -sratom-0.2.0.ebuild,
-sratom-0.4.0.ebuild, -sratom-0.4.2.ebuild, -files/ldconfig.patch:
diff --git a/media-libs/sratom/sratom-0.4.6.ebuild b/media-libs/sratom/sratom-0.4.6.ebuild
new file mode 100644
index 000000000000..53d1736ccb40
--- /dev/null
+++ b/media-libs/sratom/sratom-0.4.6.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/sratom/sratom-0.4.6.ebuild,v 1.1 2014/11/02 18:54:41 aballier Exp $
+
+EAPI=4
+
+inherit waf-utils
+
+DESCRIPTION="Library for serialising LV2 atoms to/from RDF, particularly the Turtle syntax"
+HOMEPAGE="http://drobilla.net/software/sratom/"
+SRC_URI="http://download.drobilla.net/${P}.tar.bz2"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc static-libs test"
+
+RDEPEND=">=media-libs/lv2-1.8.1
+ >=dev-libs/serd-0.14.0
+ >=dev-libs/sord-0.12.0"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ virtual/pkgconfig"
+
+DOCS=( "NEWS" "README" )
+
+src_prepare() {
+ sed -i -e 's/^.*run_ldconfig/#\0/' wscript || die
+}
+
+src_configure() {
+ waf-utils_src_configure \
+ --docdir=/usr/share/doc/${PF} \
+ $(use test && echo "--test") \
+ $(use doc && echo "--docs") \
+ $(use static-libs && echo "--static")
+}
+
+src_test() {
+ ./waf test || die
+}