summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2013-09-13 13:05:04 +0000
committerLuca Barbato <lu_zero@gentoo.org>2013-09-13 13:05:04 +0000
commit6de360e0b8254a62bc3cc8f8f9a3614971595632 (patch)
tree5bdc1b0d8613789e0f606088f074fab2d1747244 /media-libs/x264
parentNew snapshot matching lib (diff)
downloadgentoo-2-6de360e0b8254a62bc3cc8f8f9a3614971595632.tar.gz
gentoo-2-6de360e0b8254a62bc3cc8f8f9a3614971595632.tar.bz2
gentoo-2-6de360e0b8254a62bc3cc8f8f9a3614971595632.zip
Version bump, cflags patch updated
(Portage version: 2.2.3/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'media-libs/x264')
-rw-r--r--media-libs/x264/ChangeLog9
-rw-r--r--media-libs/x264/files/x264-0.0.20130731-cflags.patch62
-rw-r--r--media-libs/x264/files/x264-cflags.patch26
-rw-r--r--media-libs/x264/x264-0.0.20130731.ebuild4
-rw-r--r--media-libs/x264/x264-0.0.20130912.ebuild71
5 files changed, 152 insertions, 20 deletions
diff --git a/media-libs/x264/ChangeLog b/media-libs/x264/ChangeLog
index f58fb7b9364e..4e38a212e2af 100644
--- a/media-libs/x264/ChangeLog
+++ b/media-libs/x264/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-libs/x264
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/x264/ChangeLog,v 1.98 2013/08/12 15:54:33 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/x264/ChangeLog,v 1.99 2013/09/13 13:05:04 lu_zero Exp $
+
+*x264-0.0.20130912 (13 Sep 2013)
+
+ 13 Sep 2013; Luca Barbato <lu_zero@gentoo.org> x264-0.0.20130731.ebuild,
+ files/x264-cflags.patch, +files/x264-0.0.20130731-cflags.patch,
+ +x264-0.0.20130912.ebuild:
+ Version bump, cflags patch updated
12 Aug 2013; Alexis Ballier <aballier@gentoo.org> x264-0.0.20130731.ebuild,
x264-9999.ebuild, metadata.xml:
diff --git a/media-libs/x264/files/x264-0.0.20130731-cflags.patch b/media-libs/x264/files/x264-0.0.20130731-cflags.patch
new file mode 100644
index 000000000000..3014b47eca8e
--- /dev/null
+++ b/media-libs/x264/files/x264-0.0.20130731-cflags.patch
@@ -0,0 +1,62 @@
+https://bugs.gentoo.org/420241 for x32 stuff
+initial x32 support -- no asm code, just pure C
+
+avoid messing too much with CFLAGS.
+https://bugs.gentoo.org/show_bug.cgi?id=351219
+https://bugs.gentoo.org/show_bug.cgi?id=413661
+
+
+Index: x264-9999/configure
+===================================================================
+--- x264-9999.orig/configure
++++ x264-9999/configure
+@@ -553,11 +553,6 @@ case $host_cpu in
+ if [[ "$asm" == auto && "$CFLAGS" != *-march* ]]; then
+ CFLAGS="$CFLAGS -march=i686"
+ fi
+- if [[ "$asm" == auto && "$CFLAGS" != *-mfpmath* ]]; then
+- CFLAGS="$CFLAGS -mfpmath=sse -msse"
+- fi
+- CFLAGS="-m32 $CFLAGS"
+- LDFLAGS="-m32 $LDFLAGS"
+ else
+ # icc on linux has various degrees of mod16 stack support
+ if [ $SYS = LINUX ]; then
+@@ -588,13 +583,8 @@ case $host_cpu in
+ x86_64)
+ ARCH="X86_64"
+ AS="yasm"
+- [ $compiler = GNU ] && CFLAGS="-m64 $CFLAGS" && LDFLAGS="-m64 $LDFLAGS"
+ if [ "$SYS" = MACOSX ]; then
+ ASFLAGS="$ASFLAGS -f macho64 -m amd64 -DPIC -DPREFIX"
+- if cc_check '' "-arch x86_64"; then
+- CFLAGS="$CFLAGS -arch x86_64"
+- LDFLAGS="$LDFLAGS -arch x86_64"
+- fi
+ elif [ "$SYS" = WINDOWS ]; then
+ ASFLAGS="$ASFLAGS -f win32 -m amd64"
+ # only the GNU toolchain is inconsistent in prefixing function names with _
+@@ -602,7 +592,11 @@ case $host_cpu in
+ [ $compiler = GNU ] && LDFLAGS="$LDFLAGS -Wl,--nxcompat -Wl,--dynamicbase"
+ [ $compiler = GNU ] && RCFLAGS="--target=pe-x86-64 $RCFLAGS"
+ else
+- ASFLAGS="$ASFLAGS -f elf -m amd64"
++ if cpp_check "" "" "__ILP32__" ; then
++ ASFLAGS="$ASFLAGS -f elf -m x32"
++ else
++ ASFLAGS="$ASFLAGS -f elf -m amd64"
++ fi
+ fi
+ ;;
+ powerpc|powerpc64)
+@@ -964,10 +958,6 @@ if [ "$pic" = "yes" ] ; then
+ [ $SYS = SunOS -a "$ARCH" = "X86" ] && SOFLAGS="$SOFLAGS -mimpure-text"
+ fi
+
+-if [ "$debug" != "yes" -a "$gprof" != "yes" ]; then
+- CFLAGS="$CFLAGS -fomit-frame-pointer"
+-fi
+-
+ if [ "$strip" = "yes" ]; then
+ CFLAGS="$CFLAGS -s"
+ LDFLAGS="$LDFLAGS -s"
diff --git a/media-libs/x264/files/x264-cflags.patch b/media-libs/x264/files/x264-cflags.patch
index 3014b47eca8e..c08a0d7e3de1 100644
--- a/media-libs/x264/files/x264-cflags.patch
+++ b/media-libs/x264/files/x264-cflags.patch
@@ -1,16 +1,8 @@
-https://bugs.gentoo.org/420241 for x32 stuff
-initial x32 support -- no asm code, just pure C
-
-avoid messing too much with CFLAGS.
-https://bugs.gentoo.org/show_bug.cgi?id=351219
-https://bugs.gentoo.org/show_bug.cgi?id=413661
-
-
-Index: x264-9999/configure
-===================================================================
---- x264-9999.orig/configure
-+++ x264-9999/configure
-@@ -553,11 +553,6 @@ case $host_cpu in
+diff --git a/configure b/configure
+index 07796b1..afdda94 100755
+--- a/configure
++++ b/configure
+@@ -556,11 +556,6 @@ case $host_cpu in
if [[ "$asm" == auto && "$CFLAGS" != *-march* ]]; then
CFLAGS="$CFLAGS -march=i686"
fi
@@ -22,7 +14,7 @@ Index: x264-9999/configure
else
# icc on linux has various degrees of mod16 stack support
if [ $SYS = LINUX ]; then
-@@ -588,13 +583,8 @@ case $host_cpu in
+@@ -591,13 +586,8 @@ case $host_cpu in
x86_64)
ARCH="X86_64"
AS="yasm"
@@ -33,10 +25,10 @@ Index: x264-9999/configure
- CFLAGS="$CFLAGS -arch x86_64"
- LDFLAGS="$LDFLAGS -arch x86_64"
- fi
- elif [ "$SYS" = WINDOWS ]; then
+ elif [ "$SYS" = WINDOWS -o "$SYS" = CYGWIN ]; then
ASFLAGS="$ASFLAGS -f win32 -m amd64"
# only the GNU toolchain is inconsistent in prefixing function names with _
-@@ -602,7 +592,11 @@ case $host_cpu in
+@@ -605,7 +595,11 @@ case $host_cpu in
[ $compiler = GNU ] && LDFLAGS="$LDFLAGS -Wl,--nxcompat -Wl,--dynamicbase"
[ $compiler = GNU ] && RCFLAGS="--target=pe-x86-64 $RCFLAGS"
else
@@ -49,7 +41,7 @@ Index: x264-9999/configure
fi
;;
powerpc|powerpc64)
-@@ -964,10 +958,6 @@ if [ "$pic" = "yes" ] ; then
+@@ -971,10 +965,6 @@ if [ "$pic" = "yes" ] ; then
[ $SYS = SunOS -a "$ARCH" = "X86" ] && SOFLAGS="$SOFLAGS -mimpure-text"
fi
diff --git a/media-libs/x264/x264-0.0.20130731.ebuild b/media-libs/x264/x264-0.0.20130731.ebuild
index ec29e9bfb3be..ceff5dbdde4f 100644
--- a/media-libs/x264/x264-0.0.20130731.ebuild
+++ b/media-libs/x264/x264-0.0.20130731.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/x264/x264-0.0.20130731.ebuild,v 1.3 2013/08/12 15:54:33 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/x264/x264-0.0.20130731.ebuild,v 1.4 2013/09/13 13:05:04 lu_zero Exp $
EAPI=5
@@ -36,7 +36,7 @@ DOCS="AUTHORS doc/*.txt"
src_prepare() {
# Initial support for x32 ABI, bug #420241
# Avoid messing too much with CFLAGS.
- epatch "${FILESDIR}"/x264-cflags.patch
+ epatch "${FILESDIR}"/${P}-cflags.patch
}
multilib_src_configure() {
diff --git a/media-libs/x264/x264-0.0.20130912.ebuild b/media-libs/x264/x264-0.0.20130912.ebuild
new file mode 100644
index 000000000000..e7a7bb3b9ed2
--- /dev/null
+++ b/media-libs/x264/x264-0.0.20130912.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/x264/x264-0.0.20130912.ebuild,v 1.1 2013/09/13 13:05:04 lu_zero Exp $
+
+EAPI=5
+
+inherit flag-o-matic multilib toolchain-funcs eutils multilib-minimal
+
+DESCRIPTION="A free library for encoding X264/AVC streams"
+HOMEPAGE="http://www.videolan.org/developers/x264.html"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-2
+ EGIT_REPO_URI="git://git.videolan.org/x264.git"
+else
+ inherit versionator
+ MY_P="x264-snapshot-$(get_version_component_range 3)-2245"
+ SRC_URI="http://download.videolan.org/pub/videolan/x264/snapshots/${MY_P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+SONAME="135"
+SLOT="0/${SONAME}"
+
+LICENSE="GPL-2"
+IUSE="10bit +interlaced pic static-libs sse +threads"
+
+ASM_DEP=">=dev-lang/yasm-1.2.0"
+DEPEND="abi_x86_32? ( ${ASM_DEP} )
+ abi_x86_64? ( ${ASM_DEP} )"
+RDEPEND="abi_x86_32? ( !<=app-emulation/emul-linux-x86-medialibs-20130224-r7
+ !app-emulation/emul-linux-x86-medialibs[-abi_x86_32(-)] )"
+
+DOCS="AUTHORS doc/*.txt"
+
+src_prepare() {
+ # Initial support for x32 ABI, bug #420241
+ # Avoid messing too much with CFLAGS.
+ epatch "${FILESDIR}"/x264-cflags.patch
+}
+
+multilib_src_configure() {
+ tc-export CC
+ local asm_conf=""
+
+ if [[ ${ABI} == x86* ]] && use pic || [[ ${ABI} == "x32" ]]; then
+ asm_conf=" --disable-asm"
+ fi
+
+ # Upstream uses this, see the cflags patch
+ use sse && append-flags "-msse" "-mfpmath=sse"
+
+ "${S}/configure" \
+ --prefix="${EPREFIX}"/usr \
+ --libdir="${EPREFIX}"/usr/$(get_libdir) \
+ --disable-cli \
+ --disable-avs \
+ --disable-lavf \
+ --disable-swscale \
+ --disable-ffms \
+ --disable-gpac \
+ --enable-pic \
+ --enable-shared \
+ --host="${CHOST}" \
+ $(usex 10bit "--bit-depth=10" "") \
+ $(usex interlaced "" "--disable-interlaced") \
+ --disable-opencl \
+ $(usex static-libs "--enable-static" "") \
+ $(usex threads "" "--disable-thread") \
+ ${asm_conf} || die
+}