summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-09-23 21:31:18 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-09-23 21:31:18 +0000
commitb28ef4466c160df1e63b2b51040ffce5cf60e31b (patch)
tree65bd8258c2c8425fef9a6c1cf4f0e48e70657477 /media-libs/x264
parentmask new x264 snapshots (diff)
downloadgentoo-2-b28ef4466c160df1e63b2b51040ffce5cf60e31b.tar.gz
gentoo-2-b28ef4466c160df1e63b2b51040ffce5cf60e31b.tar.bz2
gentoo-2-b28ef4466c160df1e63b2b51040ffce5cf60e31b.zip
new snapshot
(Portage version: 2.2_rc41/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/x264')
-rw-r--r--media-libs/x264/ChangeLog8
-rw-r--r--media-libs/x264/x264-0.0.20090923.ebuild61
2 files changed, 68 insertions, 1 deletions
diff --git a/media-libs/x264/ChangeLog b/media-libs/x264/ChangeLog
index b19a203e8df6..8da2b0f72de0 100644
--- a/media-libs/x264/ChangeLog
+++ b/media-libs/x264/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/x264
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/x264/ChangeLog,v 1.23 2009/09/09 08:57:19 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/x264/ChangeLog,v 1.24 2009/09/23 21:31:18 aballier Exp $
+
+*x264-0.0.20090923 (23 Sep 2009)
+
+ 23 Sep 2009; Alexis Ballier <aballier@gentoo.org>
+ +x264-0.0.20090923.ebuild:
+ new snapshot
*x264-0.0.20090908 (09 Sep 2009)
diff --git a/media-libs/x264/x264-0.0.20090923.ebuild b/media-libs/x264/x264-0.0.20090923.ebuild
new file mode 100644
index 000000000000..d0e0c2e30871
--- /dev/null
+++ b/media-libs/x264/x264-0.0.20090923.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/x264/x264-0.0.20090923.ebuild,v 1.1 2009/09/23 21:31:18 aballier Exp $
+
+EAPI=2
+inherit eutils multilib toolchain-funcs versionator
+
+MY_P=x264-snapshot-$(get_version_component_range 3)-2245
+
+DESCRIPTION="A free library for encoding X264/AVC streams"
+HOMEPAGE="http://www.videolan.org/developers/x264.html"
+SRC_URI="ftp://ftp.videolan.org/pub/videolan/x264/snapshots/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug +threads"
+# pic
+
+RDEPEND=""
+DEPEND="amd64? ( >=dev-lang/yasm-0.6.2 )
+ x86? ( >=dev-lang/yasm-0.6.2 )
+ x86-fbsd? ( >=dev-lang/yasm-0.6.2 )"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-nostrip.patch \
+ "${FILESDIR}"/${PN}-onlylib-20090408.patch
+}
+
+src_configure() {
+ tc-export CC
+
+ local myconf=""
+ use debug && myconf="${myconf} --enable-debug"
+
+# if use x86 && use pic; then
+# myconf="${myconf} --disable-asm"
+# fi
+
+ ./configure \
+ --prefix=/usr \
+ --libdir=/usr/$(get_libdir) \
+ --disable-avis-input \
+ --disable-mp4-output \
+ $(use_enable threads pthread) \
+ --enable-pic \
+ --enable-shared \
+ --extra-asflags="${ASFLAGS}" \
+ --extra-cflags="${CFLAGS}" \
+ --extra-ldflags="${LDFLAGS}" \
+ --host="${CHOST}" \
+ ${myconf} \
+ || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS doc/*.txt
+}