summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2008-12-21 11:44:41 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2008-12-21 11:44:41 +0000
commit60cdeee3e66bc54238705d4639425f874825b250 (patch)
treeaca83460f0ef6490c012e7aa26e5a158d29ff0f3 /media-libs/yiff/yiff-2.14.5-r1.ebuild
parentx86 stable, bug #250933 (diff)
downloadgentoo-2-60cdeee3e66bc54238705d4639425f874825b250.tar.gz
gentoo-2-60cdeee3e66bc54238705d4639425f874825b250.tar.bz2
gentoo-2-60cdeee3e66bc54238705d4639425f874825b250.zip
Don't install yiffconfig which is GTK+-1.2. Don't install support for KDE 3, kmid. Respect CC, CXX, CFLAGS and CXXFLAGS. Remove unnecessary RESTRICT for strip from ebuild. Install default yiffrc so yiff server can be started out of box.
(Portage version: 2.1.6.1/cvs/Linux 2.6.27.7 i686)
Diffstat (limited to 'media-libs/yiff/yiff-2.14.5-r1.ebuild')
-rw-r--r--media-libs/yiff/yiff-2.14.5-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/media-libs/yiff/yiff-2.14.5-r1.ebuild b/media-libs/yiff/yiff-2.14.5-r1.ebuild
new file mode 100644
index 000000000000..fae2a840f57d
--- /dev/null
+++ b/media-libs/yiff/yiff-2.14.5-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/yiff/yiff-2.14.5-r1.ebuild,v 1.1 2008/12/21 11:44:41 ssuominen Exp $
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="high performance and stable sound server for UNIX games and apps"
+HOMEPAGE="http://wolfpack.twu.net/YIFF/"
+SRC_URI="ftp://wolfpack.twu.net/users/wolfpack/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="alsa"
+
+DEPEND="alsa? ( media-libs/alsa-lib )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-build-2.patch
+ sed -i -e "/^YLIB_DIR/s:/lib:/$(get_libdir):" \
+ */Makefile* || die "sed failed."
+}
+
+src_compile() {
+ tc-export CC CXX
+ use alsa && append-flags -DALSA_RUN_CONFORM
+ emake linux || die "emake failed."
+}
+
+src_install() {
+ emake PREFIX="${D}"/usr install || die "emake install failed."
+ dodoc AUTHORS README
+ insinto /etc
+ doins yiff/yiffrc || die "doins failed."
+}